Login screen shows: file:///usr/share/sddm/themes/breath2/main.qml: No such file or directory

Please correct me if i am wrong.
This "echo $shell command shows output /bin/bash… does this command actually telling me that if i use ssh or tty, my shell would be /bash ?

echo $SHELL                             

The command will give you the defined shell for your user, I think the one defined in /etc/passwd (do not touch this file manually). The command outputs the environment variable called $SHELL. This is what is called the login shell, I think.


This variable shall represent a pathname of the user’s preferred command language interpreter.

I guess you can change this with the command chsh

Anyway, this is kinda out of the scope of this thread, which is already solved.

1 Like

zsh, as implemented in a default plasma install … is defined in konsole profile, not by login shell (chsh).

Yes, already covered that


Is there a cli cmd to check what shell i am using in terminal emulator ?

echo $0
ps -p $$
lsof -p $$

Haha… so simple but i dont know.
From internet, i read it is $SHELL. I kept using this cmd (echo $SHELL) to check (since my desktop manjaro changed to zsh …) my shell, not knowing it was totally wrong.

Yes it is, but if you read what has been said already, Konsole HAS A SETTING TO CUSTOMIZE THE SHELL. So Konsole is not standard, it uses its own setting for each Konsole profile, you can use dozens of different profiles with each a different shell. The command would most likely work with any other terminal emulator, but Konsole has its own shell setting.

I have read your msg… but i can’t make it work.
I have a desktop with manjaro kde… after lastest update, it changed my bash to zsh… the ugly username% prompt. No matter how i change (settings > edit current profile > command ) to /bin/bash, it just return to /bash/zsh when i restart a new terminal emulator.
Anyway, i am gonna try one more time on the desktop… if not, i will start a new thread so i won’t get kick by moderator saying off topic

copy /etc/skel/.zshrc to your ~/ user folder. (note that /etc/skel/.zshrc is hidden file so you need to show hidden file to copy it if you don’t do it from terminal)

What you described is what happens when you press 1 when it asks you for what to do the first time you use ZSH.

There is no .zshrc in the folder… only .bashrc and other files in it.

Install manjaro-zsh-config

huh ? don’t understand. Were you saying when i first run zsh , the configuration that zsh asked me to enter ? I have never install zsh before… i didn’t enter anything in zsh… (perhaps long long time ago, i did try to dip my toe in zsh , i can’t recall on which computer i did that), but i uses bash all the time…

that is a function of the (Konsole) profile you are using

Settings → Edit Profile
there you can specify the shell you want

(KDE - and especially this - is very strange to me)

Then you had already a ZSH config in your user profile (and you didn’t have this prompt asking for what to do here). Again all your problems are related to you, besides the already explained changed in the DEFAULTS in Manjaro.


No, it does not work. i have tried many time… every since it changes on my desktop… but never work. hence i gave up on it. i just type bash everytime i start terminal emulator.

Its not so much a KDE thing, as a decision by the maintainers … I think its weird too.
(honestly I think the zsh change is itself a … questionable move … but, thats another matter)
Then again … I guess TTY using bash is preferable to it using zsh … so theres that …

1 Like

Yeah I don’t like the ZSH change too… I guess it looks ‘fancy’… But whatever, it is just one setting in Konsole to go back.

Off topic much everyone? :joy:

Already explained, even put a screenshot, create new profile, change default shell, make it default.

1 Like

Oh, ic, that’s why there is separate shell… one for emulator, one for tty

I understand what to do … i will do it tomorrow… else i won’t have to sleep already if i keep working on the issue on my both computer. thx for all your help. apprecriate it very much.