Login screen freezes after entering login/password, but works for root user


Manjaro stucks at login (freezes) as soon as login/username is filled in and “Enter” is pressed.

The main issue is that I don’t see any errors and, to be honest, don’t understand where to find them.

inxi -Fazy

System:    Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
       parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=e93c1cc8-0dab-4647-b3f7-3759cc1571f6 rw quiet apparmor=1
       security=apparmor resume=UUID=38e41417-4214-4e78-aff9-d80d7a540ba2 udev.log_priority=3
       Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine:   Type: Laptop System: Dell product: XPS 15 9500 v: N/A serial: <filter> Chassis: type: 10 serial: <filter>
       Mobo: Dell model: 05XYW7 v: A00 serial: <filter> UEFI: Dell v: 1.4.0 date: 08/14/2020
Battery:   ID-1: BAT0 charge: 74.2 Wh condition: 78.7/84.3 Wh (93%) volts: 12.6/11.4 model: BYD DELL M59JH06 type: Li-poly
       serial: <filter> status: Discharging
CPU:       Info: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP arch: N/A family: 6 model-id:         A5 (165) stepping: 2
       microcode: C8 L1 cache: 384 KiB L2 cache: 12.0 MiB L3 cache: 11.7 MiB
       flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431
       Speed: 800 MHz min/max: 800/5000 MHz base/boost: 2673/2600 volts: 0.8 V ext-clock: 100 MHz Core speeds (MHz):
       1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 801 8: 800 9: 800 10: 800 11: 800 12: 800
       Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
       Type: l1tf status: Not affected
       Type: mds status: Not affected
       Type: meltdown status: Not affected
       Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
       Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
       Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
       Type: srbds status: Not affected
       Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel UHD Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9bc4
       Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Dell driver: nvidia v: 450.80.02
       alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f95
       Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-11:3 chip ID: 0bda:5510
       serial: <filter>
       Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: modesetting,nvidia
       alternate: fbdev,intel,nouveau,nv,vesa display ID: :0 screens: 1
       Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.0x12.5") s-diag: 599mm (23.6")
       Monitor-1: eDP-1 res: 1920x1200 hz: 60 dpi: 145 size: 336x210mm (13.2x8.3") diag: 396mm (15.6")
       OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.2.1 direct render: Yes
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci
       bus ID: 00:1f.3 chip ID: 8086:06c8
       Sound Server: ALSA v: k5.8.18-1-MANJARO
Network:   Device-1: Intel Wireless-AC 9462/9560 vendor: Bigfoot Networks driver: iwlwifi v: kernel port: 4000 bus ID: 00:14.3
       chip ID: 8086:06f0
       IF: wlp0s20f3 state: down mac: <filter>
       IF-ID-1: br-38bbe1457817 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
       IF-ID-2: br-73bf00f80b95 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
       IF-ID-3: docker0 state: down mac: <filter>
       IF-ID-4: veth237eba9 state: up speed: 10000 Mbps duplex: full mac: <filter>
       IF-ID-5: vethe8797e5 state: up speed: 10000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 70.72 GiB (14.8%)
       ID-1: /dev/nvme0n1 vendor: Micron model: 2200S NVMe 512GB size: 476.94 GiB block size: physical: 512 B
       logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 22001050 temp: 25 Celsius C scheme: GPT
       SMART: yes health: PASSED on: 20d 16h cycles: 1,351 read-units: 1,519,164 [777 GB]
       written-units: 2,655,744 [1.35 TB]
Partition: ID-1: / raw size: 39.06 GiB size: 38.20 GiB (97.79%) used: 28.32 GiB (74.1%) fs: ext4 block size: 4096 B
       dev: /dev/nvme0n1p8
       ID-2: /home raw size: 265.62 GiB size: 260.46 GiB (98.05%) used: 13.99 GiB (5.4%) fs: ext4 block size: 4096 B
       dev: /dev/nvme0n1p9
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default)
       ID-1: swap-1 type: partition size: 8.00 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p7
Sensors:   System Temperatures: cpu: 29.0 C mobo: N/A
       Fan Speeds (RPM): cpu: 0 fan-2: 0
Info:      Processes: 369 Uptime: 52m Memory: 15.38 GiB used: 1.54 GiB (10.0%) Init: systemd v: 246     Compilers: gcc: 10.2.0
       clang: 10.0.1 Packages: 1390 pacman: 1379 lib: 369 flatpak: 0 snap: 11 Shell: Bash v: 5.0.18 running in: konsole

And sudo mhwd -li

> Installed PCI configs:
              NAME               VERSION          FREEDRIVER           TYPE
 video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-450xx-prime            2020.10.04               false            PCI

Warning: No installed USB configs!

Interesting part is that I can log in under root user (no freezes), but my personal user doesn’t work.

I tried chroot-ing and upgrading the libs with pacman -Syyu, but it didn’t help.

Also, when I use CTRL+ALT_F(N) - tty - and try executing any commands, it says “command not found”. For example ls, cat, nano, sude - all of these are not found :expressionless:

Could you please help with with debugging the issue, especially where can I find the logs when login page freezes?

Thank you

You should copy-paste text, these pictures are unreadable :expressionless:

1 Like

I’ve updated the post, thank you

after spending another night, I was able to log in under my account, doing the following:

  1. boot
  2. CTRL + ALT + F3 (text console)
  3. log in as root (my user simply don’t works as expected, saying “command not found” for any command)
  4. sudo su xxx, where xxx is my user
  5. startx

startx loads the environment, however with weird fonts and some UI bugs, but still it works.

I tried to analyze logs

journalctl -p 3 -xb

-- Reboot --
Nov 09 00:44:34 maks systemd-modules-load[292]: Failed to find module 'platform-integrity'
Nov 09 00:44:34 maks systemd-udevd[365]: could not read from '/sys/module/fjes/initstate': No such device
Nov 09 00:44:35 maks kernel: psmouse serio1: elantech: elantech_send_cmd query 0x02 failed.
Nov 09 00:44:35 maks kernel: psmouse serio1: elantech: failed to query capabilities.
Nov 09 00:44:41 maks wpa_supplicant[1205]: nl80211: kernel reports: Attribute failed policy validation
Nov 09 00:44:41 maks wpa_supplicant[1205]: Failed to create interface p2p-dev-wlp0s20f3: -22 (Invalid argument)
Nov 09 00:44:41 maks wpa_supplicant[1205]: nl80211: Failed to create a P2P Device interface p2p-dev-wlp0s20f3
Nov 09 00:44:43 maks kernel: snd_hda_intel 0000:00:1f.3: No response from codec, resetting bus: last cmd=0x01770740
Nov 09 00:44:47 maks kernel: ucsi_acpi USBC000:00: unknown error 0
Nov 09 00:44:47 maks kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS failed (-5)
Nov 09 00:45:07 maks kernel: sd 0:0:0:0: [sda] Asking for cache data failed
Nov 09 00:45:07 maks kernel: sd 0:0:0:0: [sda] Assuming drive cache: write through


cat /var/log/Xorg.0.log | grep EE

    cat /var/log/Xorg.0.log | grep EE                                                                                                                                                                                                    
[    23.100] Current Operating System: Linux maks 5.8.18-1-MANJARO #1 SMP PREEMPT Sun Nov 1 14:10:04 UTC 2020 x86_64
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    24.381] (EE) Failed to load module "intel" (module does not exist, 0)
[    24.381] (EE) Failed to load module "nouveau" (module does not exist, 0)
[    24.381] (EE) Failed to load module "nv" (module does not exist, 0)
[    24.381] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    24.382] (EE) Failed to load module "vesa" (module does not exist, 0)
[    25.054] (II) Initializing extension MIT-SCREEN-SAVER
[    25.658] (EE) libinput: DELL097D:00 04F3:311C Touchpad: Failed to create a device for /dev/input/mouse1
[    25.658] (EE) PreInit returned 2 for "DELL097D:00 04F3:311C Touchpad"
[    26.016] (EE) Failed to open authorization file "/var/run/sddm/{ae5e5776-cbe0-4077-bafa-68eba3dc8922}": No such file or directory

Interesting, that I have the same errors even when logged in under root, so I don’t think it’s the root of the issue with freezing login page.

I have also successfully reinstalled nvidia driver for the latest recommended one - but it didn’t help.

So still looking forward to some help with debugging the issue, at least how to get an error message…

As I explained here, the issue is in the zsh, which somehow breaks the system.

I changed the shell back to bash, and now it works:

chsh -s /bin/bash

Login screen is no longer freezes and works as expected.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.