Login screen broken after last update

hello the 28 april update broke my system, when i start my computer and click on Different user to login the screen is freezing (but the mouse still works) and i can't do anything (can't login), any idea how to solve?

thanks

i'm using manjaro kde, latest nvidia drivers propriatary, 4.19LTS kernel

thanks

Difficult to answer. Switch to a TTY via ctrl+alt+f3 and login as any user to the console. Then try to check if you fully updated or only partially via sudo pacman -Syu. Else you may check for errors in /var/log.

1 Like

thanks, i updated but still blocked,

i have maybe found some errors in journalctl -b

thanks

Did you updated the package manjaro-system? If so call a second time sudo pacman -Syu to update other packages. Some packages we update before the system update to ease the procedure.

yea if have update manjaro system, ok i will try to update one more time.

meanwhile i have took those pictures.

i'm rebooting to try to check for updates

no update available, system is up to date already

If possible use ( for inxi -FGxxxz your logfiles)

sudo pacman -S pastebinit
inxi -FGxxxz | pastebinit

or


sudo pacman -S wgetpaste
inxi -Fxxxz | wgetpaste

Also if needed.

thanks,

System:    Host: me-pc Kernel: 4.19.36-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Console: tty 3 dm: SDDM
           Distro: Manjaro Linux
Machine:   Type: Desktop Mobo: ASUSTeK model: Z170I PRO GAMING v: Rev X.0x serial: <filter> UEFI: American Megatrends v: 3805
           date: 05/16/2018
Battery:   Device-1: hidpp_battery_0 model: Logitech M705 serial: <filter> charge: 5% rechargeable: yes status: Discharging
           Device-2: hidpp_battery_1 model: Logitech Illuminated Living-Room Keyboard K830 serial: <filter>
           charge: 55% (should be ignored) rechargeable: yes status: Discharging
CPU:       Topology: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP arch: Skylake-S rev: 3 L2 cache: 6144 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28040
           Speed: 4100 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 4100 2: 4101 3: 4099 4: 4098
Graphics:  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] driver: nvidia v: 418.56 bus ID: 01:00.0 chip ID: 10de:1b06
           Display: tty server: X.org 1.20.4 driver: nvidia tty: 430x90
           Message: Advanced graphics data unavailable in console. Try -G --display
Audio:     Device-1: NVIDIA GP102 HDMI Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10ef
           Sound Server: ALSA v: k4.19.36-1-MANJARO
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6
           chip ID: 8086:15b8
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: half mac: <filter>
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Drives:    ID-1: /dev/sda vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB speed: 6.0 Gb/s serial: <filter> rev: DB6Q
           scheme: GPT
           ID-2: /dev/sdc model: SATA SSD size: 111.79 GiB speed: 6.0 Gb/s serial: <filter> rev: 12.2 scheme: GPT
Partition: ID-1: / size: 92.34 GiB used: 81.01 GiB (87.7%) fs: ext4 dev: /dev/dm-0
           ID-2: swap-1 size: 7.40 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 157 Uptime: 4m Memory: 15.61 GiB used: 363.6 MiB (2.3%) Init: systemd v: 242 Compilers: gcc: 8.3.0
           clang: 8.0.0 Shell: bash v: 5.0.3 running in: tty 3 inxi: 3.0.33

manjaro-system this time adjusts file permissions of accountsservice to match the latest upstream package. The error message displayed points to sddm-greeter. Could this be related?
@naca to rule that out you could try reverting this by executing from the tty:

sudo chmod 755 /var/lib/AccountsService/users/
sudo chmod 775 /var/lib/AccountsService/icons/

This will bring back the permissions warning when installing accountsservice, but maybe it will make sddm happier again?

but i had the problem before manjaro-system update of the 29 april update, i'm going to try in an hour. thx

There was a first version of manjaro-system (20190427-3) included in the bulk stable update. The additional update that arrived today (20190429-1) was only addressing systems without accountsservice installed to avoid an error message on those systems.
You can try the above mentioned in any case. It won't hurt anyway. Just make sure you don't mistype!!! :stuck_out_tongue_winking_eye:

ok i have tried it but it didn't helped (same errors in log).

also i have tried to export the whole journal since boot to pastebin but it's not working, do you need the log?

i have tried journalctl -b | wgetpaste but it return something about empty request

wait i have CHMOD 755 both of line, i din't saw there was a difference, i'm going to try again, sorry

ok this time i have done the chmod correctly but it don't help. thanks and sorry for spamming for i can't edit nor posting in the update topic because new user.

Hm. Your output shows that sddm-greeter crashed:

Screenshot%20from%202019-04-29%2018-15-51

:thinking:
At this point we are sure that your update is complete, right? qt5-base and such...
And you said the crash happens when you try to switch user? So can you access a session with a different user?

i have to click on Different user because the default user is not the one that i use, i have set up the default user to be displayed in login screen so it won't show my real account, that's all. i don't even remember the password that i used for it because i used it only once.

i'm going to try to login to the default user if i can remember the password, or i'm going to change the password in TTY and try to login, thanks.

ok i have managed to reset the pass and so to login to the default user and it works fine, the only problem is when i click on the "Different user" in the login screen, the screen freeze (but the mouse is still working) and sddm-greeter crash.

Please check the user ID of the other user. Normally our users start with 1000 and the crashing one is at 973.

yes my user is 1000, 973 is sdmm user.

also i have tried to update to kernel 5 but it won't help.

maybe i can try to set up the user that i want to use as default so i can use it, i'm going to try that