Login keeps reseting

pam_unix(sddm:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=  user=z
Sep 11 20:03:05 z dbus-daemon[723]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.40' (uid=0 pid=1235 comm="/usr/lib/sddm/sddm-helper --socket >
Sep 11 20:03:05 z dbus-daemon[723]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
Sep 11 20:03:05 z sddm-helper[1235]: pam_systemd_home(sddm:auth): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.

Then how did you boot? Manjaro always uses systemd.

Well, in that case, you have to unmask it. Somehow you’ve been assimilated by systemd-homed. I masked it on my system before it was included in systemd. Apparently your system needs it.

sudo systemctl unmask systemd-homed.service
sudo systemctl enable --now systemd-homed.service 

this “systemd_homed” are only warning since last pam update ! warning if we not use systemd_homed :wink:
It’s not a problem ! there’s nothing to do and is fixed with next systemd update


sudo systemctl unmask systemd-homed.service
Removed /etc/systemd/system/systemd-homed.service.
sudo systemctl enable --now systemd-homed.service

Created symlink /etc/systemd/system/dbus-org.freedesktop.home1.service -> /usr/lib/systemd/system/systemd-homed.service.
Created symlink /etc/systemd/system/multi-user.target.wants/systemd-homed.service -> /usr/lib/systemd/system/systemd-homed.service.
Created symlink /etc/systemd/system/sockets.target.wants/systemd-userdbd.socket -> /usr/lib/systemd/system/systemd-userdbd.socket.
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down

Then I repeat my question from higher up: What did you boot with?

well i am in -chroot in the live usb has that something to do with it
I dont realy know, thats what it poped up when i typed the comand

Have you tried changing your password? You can change it again later, but it’s just so you’d be able to get in. :thinking:

i ll try
Edit: Neh that wasn’t it

What if I get rid of the need to login alltogether, would manjaro just put me in desktop or would it show me the user screen first

For the record, just because you do have the ability to log in automatically doesn’t mean that there’s no login procedure going on. It’s just taking place in the background, without asking you for a user name and a password.

You could always try enabling it, of course. :thinking:

Whell i tryed, but i don’t know how to do that.
And this is geting tiring. I think im going to try wipeing my SSD and reinstaling manjaro.
Anything I need to watch for that this doesn’t happen again?