Logging in to system is no longer accessible

Hi!

I can no longer log in to my system.

Here’s how I usually do it:

  1. Press power button

  2. Decrypt the disk

  3. Log in to the graphical desktop system

Now I’m stuck between steps 2 and 3, i.e. after decrypting the disk (presumably successfully) the usual graphical login view does not appear. Instead, I’m stuck in a black screen where a single underscore blinks slowly in the top left corner.

There were 2 notable things I did before this problem started to occur:

  1. I updated (or attempted to update) the system (via some graphical package manager dialog). At the end the dialog said something along the lines of “transaction failed due to not enough disk space being available”. Then I just shut down the system.

  2. A couple hours later I attempted to boot the system again. Now I accidentally entered an incorrect passphrase when decrypting the disk, and I got into a grub rescue dialog. I shut down the system by pressing the power button.

  3. I pressed the power button again in order to retry with a correct passphrase, and seemingly succeeded to decrypt the disk, but I’m not getting further. This is where I’m stuck at now.

Some things I’ve tried:

I’ve tried to access the system so that I could explore any logs by

  • Opening alternative terminals by Ctrl+Alt+F2…F6: When I just press the combination, nothing happens. If I hold the keys down for a longer period, then a login terminal briefly appears but it goes away so fast I can barely read that there’s a login prompt.

  • Accessing the filesystem via a live USB: I booted into an Arch installation medium and attempted to decrypt the disk. I failed: sudo cryptsetup luksOpen $some_lsblk_path cryptroot said something like “the thing doesn’t exist or you don’t have permission”.

Now I don’t really know what to do and I have no clue what I’ve broken even so I don’t know what and how I should fix. Is a fresh installation my only option?

I guess you need to fix this first. Try to delete unnecessary stuff or extend the partition being affected and then try to manjaro-chroot and to finish the update process.

Side note: You are using Manjaro for at least two years now and still have no idea of the name of the “graphical package manager”?

One possibilty would be to remove unneeded files from package cache:

sudo pacman -Sc

Or look into ~/.cache to find files which could be deleted.

There you go.

“transaction failed due to not enough disk space being available"

The update didn’t finish.

Boot from some Linux iso (Manjaro, preferrably)

chroot and finish the update

install kernels and tell Grub about them

and, of course, before all that:

create enough space - delete stuff - there was not enough space

sudo rm -rf /var/cache/pacman/pkg/*

is one pretty blunt way to make some room

The name of the GUI package manager never was relevant for me. I always do updates either via pacman CLI or by clicking a notification icon in a corner that then opens the GUI. Maybe my setup doesn’t advertise the program’s name anywhere or I just haven’t paid attention to it. At least I don’t ever call it by name myself. I do know pacman is Arch’s thing, and pamac is a Manjaro thing, and I’ve used both of those via CLI.

That’s fine, just was curious. :smiley:

This is true in a number of environments.
You may not even be able to find it in your applications menu using ‘pamac’ because it is listed as “Add or Remove Programs”.

Anyhoo you need to take care of this and then make sure to finish your updating.

To gain access to the system I’ll leave this here:

you have ran out of space
that is why your updates did not complete

your disk is full

make room before you try again

it is as simple as that

Thanks everyone. The problem was indeed that the system update that I attempted and that failed (due to lack of disk space) somehow corrupted something quite essential rendering the system unusable at next boot. Using a live USB to chroot to the system to free up disk space and then finish the system upgrade fixed the system. Now everything is working again!

Here are some caveats I ran into in the process of fixing:

  • When decrypting the disk in order to be able to chroot in there from a live USB and in the case of the disk being an “nvme”, the (part of the) disk must be referred to by format “/dev/nvme0n1p2”, i.e. by specifying all 3 segments of the name that contain numbers. lsblk renders a hierarchical view with something like “nvme0n1” at the top and “nvme0n1p1” and “nvme0n1p2” below it, but “device” in cryptsetup luksOpen <device> <name> cannot be either /dev/nvme0n1 nor /dev/nvme0n1/nvme0n1p2, but instead must be /dev/nvme0n1p2. I find this very confusing (given the hiearchical output of lsblk) and so I was thinking I’m not even trying to do the right thing when I was getting errors from cryptsetup.

  • Establish internet connection before chrooting. Establishing it after chrooting lead into being able to ping by IP addresses (e.g. 9.9.9.9), but not by domain names. I.e. internet connectivity could be established, but DNS was not set up. That made finishing the system update impossible as DNS is an essential part of the package management system. Exiting from the chrooted system back to the live USB system with networking and then chrooting back to the fixable system fixed the issue: now DNS worked and the system update could be finished.

Lessons learned:

  • When a system update fails, don’t shut it down. Instead fix what’s wrong and finish the update because fixing a corrupt (partially updated, or whatever) system that cannot be e.g. logged into is a mess.

  • Even if you do mess up your system, don’t hesitate to ask for support in the knowledgeable, active and kind Manjaro community! :slight_smile:

I have fixed a broken system via a live USB before too. Last time was when I replaced my GLIBC with an incompatible version. (I don’t recommend trying that!) I just couldn’t remember the nuances when it comes to decrypting the disk.

1 Like

lsblk -f

will give you identifiable information which you can just copy/paste
for your next commands

no need to think a lot - just copy/paste :wink:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.