Log in my xfce without identification

Hi there,

I recently installed a new manjaro beside my vista install. I did it very easily from a manjaro 64bits version I have, even if my laptop is a 32 bit one; but this is not the issue .

I’m wondering how to overpass the identification stage as I’m the only user.
I tried by uncommenting the 3 autologin lines of the lightdm.conf without any success.
I tried also by copying .xinitrc into my home directory without success as well.
Any advice will be appreciated.

This should help.

1 Like

Almost done.
Nevertheless it’s just stopping at my name window, just need to push the enter key to go in, but how to go in directly?

Any anwer please?

Sorry, i don’t have any clue beside the documentation.

after you add your name to lightdm.conf you need to run the commands.
replace “username” with your name.

groupadd -r autologin

gpasswd -a username autologin

HI, I’m using majaro-arm XFCE on a Raspberry Pi 400 and have been doing everything in this thread and the archlinix wiki link posted by @maycne.sonahoz. When I try to enter the command

groupadd -r autologin

I get the following in terminal

groupadd: Permission denied.
groupadd: cannot lock /etc/group; try again later.

What do I do to get the command to work and not get the “Permission denied” message?

Have your tried ?

sudo groupadd -r autologin

LOL I keep forgetting sudo is the most important command in all of linix. I come from the microsoft windows OS

I did sudo like you said like you said and it worked. Now I have the issue of it stopping at the login screen and I have to hit return or click on login to continue How do I make it go directly to the main desktop?

Exactly what I described above :slight_smile:

A possible solution to our problem

in the doc that @maycne.sonahoz linked to there is the following

** Troubleshooting

Autologin does not work**

read that and see if it works for you

I followed the link, it was ok already.
I installed … greeter, nothing happened more

Ok thought it might help

I think I found a solution!

Goto /etc/lightdm/lightdm.conf then go down till you see


Remove the # and change 0 to 1 That will make it work. It won’t hide the login screen but it will auto execute an enter for you. If you leave it at 0 then it is off. Setting it to 1 will let it wait 1 second before loading the default user like it says in the comment in the file.

# autologin-user-timeout = Number of seconds to wait before loading default user

If 1 doesn’t work try setting it to 2

Also goto Applications (Manjaro button) → SettingsManjaro Settings ManagerUser Accounts → Your MAIN ACCOUNT (The account you normally login with) → Administrator (a small window will pop up labeled Account Type) → Check the box next to Show Groups → Check the box next to autologin → Click on the Apply button → Password window will popup, enter your password and press enter

Try this and see what you think.

1 Like

It doesn’t work as well.
I’m wondering if there is an incompatibility with the “greeter” lines inside lightdm.conf

OK It works for me as I described it

Try uninstalling the greeter app you have and then try what i described

Please try this


Tried this as well, the box was already checked, unchecked and checked, reboot, no more effect…