Locked myself out of sudoers, how do I regain admin rights?

So I tried (keyword: tried) following a tutorial youtube and added my user to a newly created audio group. Well that worked, but now thats the only group my user is in.
How do I regain access to standard groups and regain admin rights?
I dont have the live bootable drive anymore and cant even install an app to do this

You learned that following instructions from random people without understanding what they tell you to do might not be a good idea.

It has been described many times.

Get to the Grub Prompt.
add a “1” to the parameters
or add "init=/bin/bash"
boot - and you’ll land at a TTY where you can rectify the situation and fix the group rights
gpasswd -a ...
is the command you should have used - and the one you can use to rectify the situation


Enhancement:- This should also be possible by dropping to the Super User account; entering the admin rather than user password, in this instance:

su -
1 Like

Keyword: it was usermod -aG, not usermod -G:wink:

If you can reach terminal you can try what @soundofthunder says, then type groups to see the group list and which groups you need to add to your user. My home user (tr1) is in groups “wheel lp sys network power vboxusers tr1”.

So after you reach some form of root prompt,

Get to the Grub Prompt.
add a “1” to the parameters

it will be

usermod -aG wheel,input,lp,sys,network,power gonomo

gonomo being your username. Vboxusers is only in case you have virtualbox installed.

p.s. or maybe

usermod -aG wheel,input,lp,sys,network,power,gonomo gonomo

that did it
logged grub prompt and added the user back using the commands provided by Teo

thanks folks!
I’ll be breaking more stuff in the future, I’m sure there’s no better way to learn


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.