Lock on suspend

i3
elogind

#21

What I found out until now:
It works completely fine when I just suspend from the power menu. The problem is that my laptop suspends but does not lock when I just close the lid. (I guess this delayed locking is because I close the lid and when I open up again my screen gets locked because of inactivity, didn’t try that though because I didn’t wanna wait for that)
I found that there is a script in /etc/acpi which handles all kinds of events, also lid open and close. I added screen lock there. It does work. Also this script doesn’t say anything about suspend. I tried adding a sleep there; still instantly suspends. So the suspend action on lid close is defined somewhere else and I cannot find it. It makes me crazy.


#22

The link I posted addressed that problem. It had a setting you could adjust to shorten that delay time. The delay is intentional, to handle false suspends when there is a docking station involved. If the system can get suspended before that delay, then it resumes unlocked.

If you never have such, try setting that down to 10 seconds.


#23

Yes it describes the solution for systemd not for OpenRC.


#24

No, not sure.
I used ManopenRC before Elogind. I did not update for months because the move to elogind was a mess (and I use my laptop for work).

Suspend was working, and I had to type the password on resume. But I noticed that on hybernate it was not the case from time to time (maybe linked to mkinitcpio etc). I know, If you can’t rely on it, it is weak.

Generally speaking, Manjaro OpenRC is not built for laptops.
I installed the systemd/KDE version, it just work out of the box.
it is a pity.


closed #25

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.