Locale not properly set/interpreted by applications started from KDE causes problems with filenames with special characters

Hi there,

I’ve been having a problem with filenames with special characters (esp. german umlauts & co.) in filenames in some applications. The applications that I notice this most, since I use them on a regular basis are Filezilla, Smartgit, PhpStorm but I have seen this behaviour in other applications, too.

The problem is that when I start these applications from the KDE start menu or krunner they have problems with filenames that have special characters. Filezilla for example shows a “character encoding issue” when a directory contains files with special characters in filenames:

“A local filename could not be decoded. Please make sure the LC_CTYPE (or LC_ALL) environment variable is set correctly.”

Phpstorm just does not show those files at all, as if they were not there at all. Smartgit shows placeholder symbols for special characters it cannot interpret…

However when I open these applications from a shell instance everything is working fine. I tried linking the start menu entries to a shell script and have it “run in terminal” but the effect is always the same. It only works when I start directly from a shell instance.

I tried to fiddle with the locale settings for LC_CTYPE and LC_ALL in Plasma but wasn’t able to resolve this issue…

How can I check whats wrong and how do I fix this? Its quite annoying…

Thanks in advance!


Hi koshikas,

I had already tried that…I already uncommented de_DE.UTF-8 UTF-8 and en_US.UTF-8 UTF-8 without any success…the errors still appear…

Any other ideas?



edit: of course I ran locale-gen after uncommenting above mentioned entries from /etc/locale.gen