Local Manjaro Mirror stopped working

Heya, I use several Manjaro Instances in my private network (2 workstations, 3 laptops, several vms, …) and I often have internet connection issues. I therefore implemented a Manjaro Mirror for my “intranet”. I basically followed this guide here:

So: minimalistic manjaro installation on a VM using architect, putting Apache on it, using the mentioned rsync script and be good. Worked like a charm AND I was learning systemd instead of cron - definately a well done little project.
I had one minor issue from the get go - some updates on the clients refreshed the file /etc/pacman.d/mirrorlist and I had to add my local mirror again. I was too lazy to find a solution to that yet (any hint would be appreciated, but it’s minor at this point), but rest was good until recently.
Recently is like hte last update - was not at home so made the updates on the “normale” way via remote access and just have the time to check for it - seems that pacman just ignores my mirror completely. Any idea why this could be the case? I didn’t change anything in the mirror (beside it’s updates, ofc). When I add it to the mirrorlist it is ignored, when I clean the mirrorlist and add just the local mirror there are no updates available, which is also confirmed by pacman-mirrors --status (local mirror does not exist).
The mirrors are adressable (traceroute works) pingable (ya, via ping), the webserver’s payload is accessable (wget, browser), the mirror itself has sufficient storage available (for logs or something else which would block it’ work). the mirrorservice is downloading files every 6 hours as it should (if newer files are available, that is), and I am lost. I have no idea what else I could check to analyze my major problem here.
Any help, ideas or advice would be highly appreciated.

Create a custom mirror pool with one mirror.

Then edit the file /var/lib/pacman-mirrors/custom-mirrors.json and replace the server with your local mirror server. Set the mirror country to e.g. Custom to avoid pamac-mirrorlist.timer from changing the mirror country.

Distribute the custom-mirrors.json file to the systems your want to update from your local server.

Another option is to create a custom pacman-mirrors package with a higher version number and some customimization utilizing the errror handling function inside pacman-mirrors code.

So, I had time to follow your advice, but it ain’t change a thing. I guess it will solve my minor issue, but my major issue persists. Still the same error doing pacman-mirrors --status: Mirror # 1 http://mirror/manjaro/ does not exist. Whats going on here? Why did it stop working?

Okay, now it is getting interesting. As mentioned before I have several machines in my local net. So I used one of those for a test. I just put the custom mirrorpool active via distributing the json file as suggested and then did… nothing. At least for a day. I switched to that machine just a minute ago and checked the status: local pool not available. I did the second test that I always did, and expected it to fail. The test is, ofc, sudo pacman-mirrors -f 5 followed by sudo pacman -Syyuw and sudo pacman -Syu. I was quite surprised that it started to download packages and I thought “well, there it is again, igonring my pool, using the internet agai” and was positivly shocked when I checked the download speed, which peaked at ~550 MiB/s - here is obv the SATA SSD the bottleneck. So status shows “not available” but pacman uses the local mirror? What is this trickery? Getting more and more confused…