Loading Wi-Fi DKMS module (rtl88x2bu-dkms-git) at boot time

Hello folks,

so I installed rtl88x2bu-dkms-git via the AUR and the necessary linux-headers for my TP-Link T3U Plus Wi-Fi dongle. Everything works fine!


The DKMS module only works/is loaded after the graphical login.

So my question is: How can I make sure that the DKMS module gets loaded at boot time, so I can have a connection in a plain TTY session?

I tried to manually add the module in /etc/modules-load.d/modules.conf, but this didn’t seem to do the trick.

Thanks for your help!

Are you sure the module is not loaded? Because with default settings, the Wifi password is stored encrypted in the users keyring, which means a connection can only established after the user logged in.

1 Like

No, I’m not entirely sure. How do I check if it has been loaded? Is dkms status enough?

Good point with the keyring… but why does it work with my other setup (no Wi-Fi dongle) in the TTY session?

The “flawed” setup with the Wi-Fi dongle uses KDE as DE, my other setup uses AwesomeWM and polkit-gnome if that matters.

Not every DE has a keyring that can be used. For example KDE uses KWallet. XFCE uses the Keyring solution from Gnome. Depending on how you set up your AwesomeWM, you might have a keyring or not.
However, you can check this in your NM connections settings. The icon in the wifi password field indicate how it is saved.

The dkms status command does not show if a module is loaded or not. Check your dmseg messesges, it indicates at whichpoint the hardware was found. Or if you really make sure, start your system, do not log in, switch to a tty and log in as root and check lsmod, do not log in as your normal user. But is is probably easier to check the status of your wifi password, and make sure it is not encrypted.

Thanks for the all the hints and your help! Very much appreciated.

Seems like Kwallet encrypted the Wi-Fi password so the Wi-Fi password can only be used by my user after login. Once I removed the encryption it worked in the TTY session as well.

But what’s interesting is that once I logged in as root after a fresh boot, the output of lsmod didn’t show the rtl88x2bu module whatsoever.

Anyway, I learned a few things today and thank you once again. This might be helpful for someone else in the future :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.