LiveUSB won't boot - cannot mount /dev/disk/by-id/M1804

Hi!

Today I’ve downloaded a fresh ISO of Manjaro KDE 18.0.4 and written it to a USB drive:

However - I couldn’t boot it! The UEFI menu opened fine, I could choose non-free video driver but after that the system waited 30 seconds and dropped into initramfs prompt with a message that it couldn’t mount /dev/disk/by-in/M1804 to something…

I’ve checked what’s in /dev/ - there was no /dev/disk.
blkid returned nothing, and there was no lsblk command there.

I’ve tried a rear USB port - as first I tried the front one and they are wacky sometimes - no luck.
I’ve tried a different USB drive - same result. I’ve checked my UEFI BIOS boot settings - and changed to UEFI first, from Legacy mode - no difference.

I’ve tried writing the image with dd if=ISO of=/dev/sdX bs=100M command instead of the GUI ISO writer included in Manjaro - no difference.

I’ve written an old Linux Mint 18.2 KDE ISO to the same drive and that worked without issues right off the bat!

What is strange is that I’ve been installing Manjaro on this machine not longer than three weeks ago, and I used the same process to boot it off of USB - it worked back them.

I wonder if that could be an indication of a problem with my motherboard, a I’ve had some strange behaviours:

did you confirm the iso checksum?

problem with that command is that it can finish the command but the writing is not actually finished. if you accidentally take the usb drive out before it’s ready, it will not work.

  • first confirm the checksum of the iso (instructions linked on download page, also in manjaro wiki)

  • install and use Etcher to write the usb, you can us DD instead, but use it like this so you know it’s confirmed as synced/finished.

sudo dd if=/path/to/manjaro.iso of=/dev/sdx bs=1M oflag=sync status=progress
1 Like

I didn’t mention it, but I always sync after writing to ensure the write is complete.

In one of my notes i have manjaro-kde-18.0-stable-x86_64.iso as the best iso for my system to install from. Right now i don’t recall if i had issues with the KDE 18.0.4 one, but i think it might be related to something you just experience now…

1 Like

not sure how much it matters, but maybe its the different bs= variable.

I suggest you try this. And if you succeed, you can write a tutorial for alternate method to boot ISOs from USB


There are instructions for creation of usb. Then you just copy/paste ISOs with file manager.

The bs parameter in the dd command is “block size” - it only matters for performance. I’ve found that using 100M (100MB) of bs is a fast and efficient value for both flash memory and hard disks.

Using too small value will generate much more I/O calls and cause an overhead, too high value will require more RAM to store the buffer and hence create a bigger delay between reads and writes - with no further speed gain. That’s my experience with dd bs=100M.

Some sites say that bs=64K is faster. Make sure you are using the right drive before running this command!

1 Like

i know this, but is it too far fetched as a possible reason why the write may or may not of failed? dvd’s in comparison are IIRC instructed to be written much slower than it’s capabilities for the same issue. besides, what’s 2-3 minutes worth to try it that way?

worst case scenario, im wrong and you lost a few minutes of time you’ll never get back.

The numbers proposed have something to do with number 8.
Better to use those IMHO.
64K
128K
:wink:
Of course, it may have nothing to do with your issue and just is a hardware issue. You could check with another drive.

1 Like

I've had this problem again and looks like booting in Legacy mode instead of UEFI from USB works.
Weird.

Hello, I had the same issue. Are you using an USB3 port ? If so try with USB2.