Live USB stuck on boot

I recently bought one of those: Intel SERPENT CANYON NUC12SNKI72
I have been trying to boot Live USB to be able to install Manjaro from there, but that doesn’t seem to work. After choosing language, keyboard and drivers boot just gets stuck right away.
I guess the hardware is not supported yet.
Inside the machine is

  • Intel Core i7-12700H (Alder Lake-H)
  • Intel Arc A770M (Intel Xe HPG)

Is it just the Kernel on that recent ‘Official Plasma Edition’ that causes the problem?
Which choices do i have to get Manjaro installed on that machine?
Thanks for your help

it could be because the hardware is new…
check if secure boot is disabled in bios;
fast boot disabled in bios - you may not have this option;
AHCI enabled in bios;
fast startup disabled in windows, if you are having installed it;
and use ventoy to flash the iso

hey brahma
i have tried all those options already…
Ventoy was the only way to get the Manjaro Live USB recognized at boot.
I had to disable secure boot and fast boot anyway. It’ll be a dual boot with Windows 11.
i haven’t seen AHCI option in the bios.
Is the above hardware supposed to work with the latest stable manjaro image?

the ahci option should be there, search for sata and raid options…
also download the manjaro iso with 5.19 kernel - youll have more chances booting with this newer kernel - from here, download both the zip and the z01 files, and try with it… but this iso could be unstable, so if you were able to install it, then run this command:

sudo pacman-mirrors --api --set-branch stable && sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyuu

I will try (again) as soon as i get home, although i might have done so already. I have tried various things yesterday and it looks like i can’t remember them all :slight_smile:
Thank you so far. I will let you know if that works.

in fact this is really a new hardware and even the drivers for ms-windows do have a lot of issues. as described in this article kernel 6.0 might be helpful.


you could try clear-linux. this is a linux provided and developed from intel for intel and try if this intel-specific distro might handle your hardware.

Thanks for your help guys! I used the KDE Version from here at the end. Obviously it’s not as smooth as installations went before, but it worked. Booting from the stick only worked every other time…could also be a problem with the stick. I will see how good the hardware is supported. For tonight i am a happy boy :slight_smile: . Thank you Olli for the clearlinux distribution. I have never heard of that before and probably give it a try.

dont forget to run this command in your installation:

sudo pacman-mirrors --api --set-branch stable && sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyuu

after its done install the latest 6.0 kernel from system settings/kernel, reboot

Done it already :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.