Live USB Freezes during boot



I’ve been trying to install Manjaro (i3 Version) on my newly build computer. I installed it on my previous laptop with no problem but now I can’t even get to the live demo part. Every time I boot it up it freezes at what seems random steps in the boot process. I tried different USB sticks, different DEs and even different distros. The only distro I got a GUI was Ubuntu but even that crashed after a while. I tried it with safe boot enabled and disabled, but still nothing. For some reason, it even sometimes corrupts my WIFI driver for Windows when crashing so I have to reset my Network Adapter! I have no idea how to fix it and would greatly appreciate help. It’s my first time trying to debug the installation of Manjaro so I’m not quite sure what resources to post.

Thank you in advance.

My hardware:
Motherboard: Gigabyte B650 AORUS ELITE AX ATX AM5 Motherboard
CPU: AMD Ryzen 7 7700X 4.5 GHz 8-Core Processor
GPU: GeForce RTX 4070
RAM: G.Skill Trident Z5 RGB 32 GB (2 x 16 GB) DDR5-6000 CL36
Storage: Samsung 980 Pro 2 TB M.2-2280 PCIe 4.0 X4 NVME

check version UEFI motherboard ,
you can try version in Testing ( 6.3.3 )
from latest daily developer images ,
you need to add theses option on boot kernel
“iommu=pt amd_pstate=passive processor.max_cstate=5”

Any update?

I’m having the same issue, even down to the issue with wifi on windows afterwards. I have the same mobo, video card, and have an amd 7900x

I think it must have to do with the proprietary drivers, as I’ve had issues with these in the past on other systems.

Sadly didn’t help. The motherboard is on the lastest available version (F5).

@Kerail @gstroot have you tested iso from dev ( daily iso ) ?
see link on last testing

Sorry I forgot to mention. I did try the latest build (xfce and plasma). Both didn’t work.

you can report on testing

Small update:
Updating the BIOS to version F6a somwhat fixes the problem. I was able to install Manjaro with dual boot but the wifi problem still exists. Every time I boot into Manjaro then wifi drivers just break (on both windows and linux) and the only thing that helps is manually resetting the network card by holding down the power button for 60 seconds. If I boot into Linux twice in a row, the first time the wifi won’t work. Then I reset the card and then it works for the next boot. But if I ever boot into Windows and then back into Manjaro everything breaks again.

is it possible to return

inxi -Fza