Live USB flash drive won't boot on new PC

I am trying manjaro-kde-18.0.4-stable-x86_64, I created a live USB flash drive using Etcher. The USB key works on my older pc, but not on a newer PC where I want to install Manjaro (filled specs in profile). I see a lot of [FAILED] Failed to start followed by See 'systemctl status ....

Any idea what's the cause and how to fix it?

Edit: Adding more info:

  • AMD RYZEN 7 3800X
  • ASUS ROG STRIX GAMING GeForce RTX 2080Ti O11GB
  • ASROCK X570 Phantom Gaming X
  • HxperX 32GB Kit DDR4 3200MHz CL16 XMP RGB Predator
  • Corsair HX850i
  • Samsung 970 EVO PLUS 250GB
  • WD Blue 2TB

I believe Etcher creates USB for "legacy boot", not sure how to create UEFI bootable USB key (tried just unpack iso and copy which didn't work). I did verify checksum and signature of the ISO, Etcher verified flash drive as a last step.

Here are some helpful threads with similar issues:

Use this ISO instead. Use rc8

You can use etcher, it should make a UEFI fine but from the boot menu you need to choose when you boot the ISO the UEFI: {Name of usb}, not the USB: {Name of usb}.
If you feel like Etcher isn't working, use rufus and use dd mode.

Also, make sure you have the latest BIOS. It's important for the new ryzens.

1 Like

Thank you, RC8 works :smile:.

Excellent! Glad it worked for you.

Enjoy!

:grin:

1 Like

Forum kindly sponsored by Bytemark