Live USB booting fails

Hi guys, so I heard Manjaro is a fun distro, I downloaded XFCE version like 1 hour ago and flashed it (Rufus flashing failed on grub loading with missing filters something, Etcher kinda worked).

System boot hangs for both versions: free and proprietary drivers on different steps, free drivers, here are the screen photos:

For the proprietary one, everything reports to be ok, but I get no gui and keyboard doesn't work.

Is there anything else I can do to try Manjaro?

1 Like

The only fun thing here is how you managed to ask for help without providing some useful info about your hardware :laughing:

Where did you get the ISO?
Is it verified nad intact?

How did the writers 'not work' or 'kinda work' ?

Use 'DD' mode with Rufus?


Yes, sorry, it's an MSI laptop with i7 cpu and intel hd + nvidia 1060 gtx dual graphics. Not sure what else might be related.

I got the iso here on manjaro download section, regular not torrent. Rufus said there is some core or boot file which has newer version than in Rufus and suggested to try to download an updated file. It seems it found and downloaded it, but finally booting with it resulted in grub error "symbol grub_file_filters not found".

In Rufus, select EFI/GPT mode and, most importantly, DD writing method when creating a bootable stick. In BIOS, choose UEFI mode (not CSM/Legacy), and then boot from media. Select boot using proprietary driver. This should be enough to boot properly.

Thanks for fast reply! I can not find "DD writing method" in Rufus:

IIRC, it's in a dialog window which appears when hitting Start button.
Also do note that if it doesn't boot, you can try to set MBR instead of GPT, but keep UEFI (non CSM) intact.

Ok, I'm doing it, thanks a lot. The previous one I tried without GPT/UEFI.

UEFI must be used on any recent (up to 7 year old I guess) laptop or mobo. Using CSM is pretty dumb imho (no offence just my opinion) and only good for older or buggy hardware.

Ok, with UEFI my bios said "invalid signature detected, check secure boot policy in setup" and "secure boot" is disabled in bios..

If I turn on SCM in bios - it boots the grub, the the Manjaro again hangs on "Reached target Graphical Interface"

Manjaro does not support Secure Boot. You have to turn it off in BIOS settings after changing to UEFI again. Sometimes it has to be turned on and then off, sometimes SB reset helps...

But I can boot into Manjaro except it it hangs on the graphical interface part. Is there anything I can do about it?

Hello, can anyone help with this?

You can try to select free driver menu option, press "e" key and write the following in the line starting with "linux":
Then press F10 to save this edit, and boot with these altered options.
This will prevent nouveau driver from loading (looks like it is the culprit of your issue).

1 Like

I am using Rufus to create a bootable USB to use on Surface Book v1. I have tried using Rufus (3.5) with MBR and BIOS or UEFI, as well as with GPT with UEFI. Both methods will not create a bootable USB. I have tried with 18.04 XFCE and 17.1.12 (both stable). When I create a bootable USB using ubuntu 19.04 and the same USB it work (using Rufus). Ideas? I really want to try using Manjaro on the Surface Book as I have heard it works.. Help appreciated.

Using Rufus on a Windows system - when started write - you will be prompted to use either standard or DD mode. Be sure to select DD mode.

I tried with DD mode. The USB still doesn't boot. The surface logo appears and carries on logging into windows. Any ideas on what I need to do to get the USB to boot into Manjaro? As previously mentioned the I can get Ubuntu working straight off.. Since I am a noob, I am thinking it's get something to do with the loader as part of the Manjaro ISO which Ubuntu does differently?

Have done an sha1 comparison to make sure your downloaded imagine is good? Got secure boot turned off? Have fast boot off? (This may slow windows loading a bit)? Have usb set as first boot device?

Forum kindly sponsored by Bytemark