Live-iso fails to boot (manjaro-cinnamon-22.0-230104-linux61.iso)

I am booting the iso from a usb-stick, where ventoy is installed.
Tried the latest manjaro-iso of kde from april 21, the same error happens.

What can I do to install the manjaro-cinnamon desktop ?

franz@lmde5 ~> sudo inxi --admin --verbosity=7 --filter --no-host --width
[sudo] Passwort für franz:          
  Kernel: 5.10.0-21-amd64 x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10.0-21-amd64 
  root=UUID=ffe059e3-3bc1-4383-9970-b2a226f98227 ro quiet splash 
  Console: tty 0 wm: muffin DM: LightDM 1.26.0 Distro: LMDE 5 Elsie 
  base: Debian 11.2 bullseye 
  Type: Desktop System: Wortmann_AG product: TERRA_PC v: N/A serial: N/A 
  Chassis: Gigabyte Technology Co., Ltd. type: 3 serial: N/A 
  Mobo: Gigabyte model: H61M-S2PV serial: N/A UEFI: American Megatrends 
  v: FH WG date: 04/24/2013 
  RAM: total: 3.8 GiB used: 1.88 GiB (49.5%) 
  Array-1: capacity: 32 GiB slots: 2 EC: None max module size: 16 GiB 
  note: est. 
  Device-1: ChannelB-DIMM0 size: No Module Installed 
  Device-2: ChannelA-DIMM0 size: 4 GiB speed: 1333 MT/s type: DDR3 
  detail: synchronous bus width: 64 bits total: 64 bits manufacturer: 029E 
  part-no: CMX8GX3M2A1333C9 serial: N/A 
  Info: Dual Core model: Intel Core i3-3220 bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L1 cache: 64 KiB L2 cache: 3 MiB L3 cache: 2.9 MiB bogomips: 26341 
  Speed: 1640 MHz min/max: 1600/3300 MHz base/boost: 3300/7000 volts: 1.0 V 
  ext-clock: 100 MHz Core speeds (MHz): 1: 1640 2: 1955 3: 1936 4: 1597 
  Flags: acpi aperfmperf apic arat arch_perfmon avx bts clflush cmov 
  constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept 
  erms est f16c flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs lahf_lm 
  lm mca mce md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe 
  pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdtscp 
  rep_good sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 
  tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid xsave xsaveopt xtopology 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: mmio_stale_data status: Unknown: No mitigations 
  Type: retbleed status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW, STIBP: 
  conditional, RSB filling, PBRSB-eIBRS: Not affected 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Redwood XT [Radeon HD 5670/5690/5730] 
  vendor: PC Partner Limited driver: radeon v: kernel bus ID: 01:00.0 
  chip ID: 1002:68d8 class ID: 0300 
  Display: server: X.Org 1.20.11 driver: loaded: ati,radeon 
  unloaded: fbdev,modesetting,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.0x12.5") 
  s-diag: 599mm (23.6") 
  Monitor-1: HDMI-0 res: 1920x1200 hz: 60 dpi: 103 
  size: 474x296mm (18.7x11.7") diag: 559mm (22") 
  OpenGL: renderer: AMD REDWOOD (DRM 2.50.0 / 5.10.0-21-amd64 LLVM 11.0.1) 
  v: 3.3 Mesa 20.3.5 compat-v: 3.1 direct render: Yes 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 class ID: 0403 
  Device-2: AMD Redwood HDMI Audio [Radeon HD 5000 Series] 
  vendor: PC Partner Limited driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 1002:aa60 class ID: 0403 
  Sound Server: ALSA v: k5.10.0-21-amd64 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 class ID: 0200 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No Bluetooth data was found. 
  Message: No RAID data was found. 
  Local Storage: total: 704.24 GiB used: 249.3 GiB (35.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZ7LN256HMJP-00000 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: SSD serial: <filter> rev: 100Q temp: 36 C scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST500DM002-1BD142 
  size: 465.76 GiB block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: KC45 temp: 40 C scheme: GPT 
  Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW SH-224DB rev: SB00 
  dev-links: cdrom,cdrw,dvd,dvdrw 
  Features: speed: 48 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw size: 35.33 GiB size: 34.48 GiB (97.59%) used: 10.34 GiB (30.0%) 
  fs: ext4 block size: 4096 B dev: /dev/sda8 maj-min: 8:8 label: N/A 
  uuid: ffe059e3-3bc1-4383-9970-b2a226f98227 
  ID-2: /boot/efi raw size: 100 MiB size: 96 MiB (96.00%) 
  used: 56.5 MiB (58.8%) fs: vfat block size: 512 B dev: /dev/sda1 
  maj-min: 8:1 label: EFI uuid: C632-CBD5 
  ID-3: /mnt/DATA raw size: 404.06 GiB size: 396.65 GiB (98.17%) 
  used: 238.9 GiB (60.2%) fs: ext4 block size: 4096 B dev: /dev/sdb1 
  maj-min: 8:17 label: DATA uuid: bee41684-b15c-4f6f-8511-77ea6624ad21 
  Kernel: swappiness: 10 (default 60) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 6.84 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb2 maj-min: 8:18 label: N/A 
  uuid: 40951ef9-753d-4128-9a7e-a8ec6628cfd5 
  ID-1: /dev/sda12 maj-min: 8:12 size: 515 MiB fs: ntfs label: N/A 
  uuid: DA5204CC5204AEF7 
  ID-2: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: N/A label: N/A uuid: N/A 
  ID-3: /dev/sda3 maj-min: 8:3 size: 53.49 GiB fs: ntfs label: N/A 
  uuid: 5460449560447FAA 
  ID-4: /dev/sda4 maj-min: 8:4 size: 526 MiB fs: ntfs label: N/A 
  uuid: FEAC7D64AC7D17FB 
  ID-5: /dev/sda5 maj-min: 8:5 size: 40.52 GiB fs: ext4 label: N/A 
  uuid: db897649-4c09-400f-b64e-087f5285c9bc 
  ID-6: /dev/sda6 maj-min: 8:6 size: 28.31 GiB fs: ext4 label: Mint-LXDE 
  uuid: 70086c2b-dd71-4f51-a0ce-fc6b00840fe0 
  ID-7: /dev/sda7 maj-min: 8:7 size: 28.79 GiB fs: ext4 label: ROS-Plasma 
  uuid: 9bc5380e-6cb4-425b-9c72-a43a80304aaa 
  ID-8: /dev/sda9 maj-min: 8:9 size: 44.91 GiB fs: ext4 label: ROS-LXQt 
  uuid: e2afdfe0-c7df-42f7-8d2c-746283288d6c 
  ID-9: /dev/sdb3 maj-min: 8:19 size: 54.87 GiB fs: ext4 label: Mint-Cinnamon 
  uuid: 1cbd3ca6-fad2-4b57-a6ec-a1a2e482b7fa 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:0024 class ID: 0900 
  Device-1: 1-1.1:3 info: Silicon Labs USB OPTICAL MOUSE type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s 
  chip ID: 10c4:8105 class ID: 0301 
  Device-2: 1-1.2:4 info: Chicony KU-0833 Keyboard type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 1.5 Mb/s 
  chip ID: 04f2:0833 class ID: 0300 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:0024 class ID: 0900 
  Hub-5: 2-1.5:3 info: Microchip (formerly SMSC) USB 2.0 Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 0424:2514 class ID: 0900 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: radeon temp: 36.5 C 
  Fan Speeds (RPM): N/A 
  Processes: 213 Uptime: 9m wakeups: 0 Init: systemd v: 247 runlevel: 5 
  Compilers: gcc: 10.2.1 alt: 10 Packages: apt: 2132 lib: 1069 flatpak: 0 
  Shell: fish (sudo) v: 3.1.2 default: Bash v: 5.1.4 
  running in: gnome-terminal inxi: 3.3.01 
franz@lmde5 ~> 

This looks like a damaged iso file. Did you verify the checksums after copying it to the usb drive?

Thanks, @mithrial. Yes, I checked the iso twice. checksum is ok.

More info: The ventoy-usb-stick does boot, I have other distros on it, select Manjaro-cinnamon and it is booting ok.
I select language etc. , then select “boot” .
After that the installation fails with the black screen and the info you see on the screenshot

I tried to find a solution by creating an usb-live-stick without ventoy.
From that usb-stick Manjaro-Cinnamon was installed on my PC, but unfortunately the installation of the uefi-grub-entry failed.

So I installed Manjaro again , but without the uefi-boot-partition. Installation was successfull, but of course , Manjaro cannot be booted. Therefore I booted Reborn-OS (another arch-based distro) and did “sudo update-grub” there.
This update failed and gave me the same error which Manjaro-Calamares-installer produced:

Adding boot menu entry for UEFI Firmware Settings ...
error: syntax error.
error: Incorrect command.
error: syntax error.
Syntax error at line 425
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/grub/ file attached.

Now I am stuck, because I don’t know how to fix this. I am sure there are no errors in /etc/default/grub because everything there is according to the wiki.
I installed a better grub on Reborn from chaotic-aur, but it gives the same error-message.

Booting from a Mint-distro will not help because no Ubuntu or Debian-based distro is able to boot Manjaro.

The live iso is fully and totally independent from your installation and grub. I don’t understand what you did.
Third party repos are even less supported than the AUR. I am at a loss here.

I installed hundreds of distros on my PC.
Ubuntu-based, arch-based etc.
From that I remember that some distros cannot be installed from a ventoy-stick.
Therefore I installed to manjaro-iso on a single usb-stick and installed manjaro from that stick.

But the installation failed because of a grub-error.
I have no idea why that happened and what I did wrong. Nothing, I guess, because I installed dozens of distros from single-usb-sticks and dozens from ventoy-sticks.

Has nothing to do with AUR , because I installed not from AUR, but from Manjaro-iso.

Maybe I should not have mentioned RebornOS.

Ok. here is an excerpt from the Calamares installer log. There you can see the pure Manjaro-cinnamon live-iso and how it failed to install grub. Just forget about RebornOS please:

grub-probe: error: cannot find a GRUB drive for /dev/sdc1.  Check your
Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
Found Linux Mint 21.1 Vera (21.1) on /dev/sda6
Found RebornOS Linux (rolling) on /dev/sda7
Found LMDE 5 Elsie (5) on /dev/sda8
Found RebornOS Linux (rolling) on /dev/sda9
Found RebornOS Linux (rolling) on /dev/sdb3
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
error: syntax error.
error: Incorrect command.
error: syntax error.
Syntax error at line 460
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/grub/ file attached.
2023-04-22 - 16:11:48 [2]: WARNING: [PYTHON JOB]: "Command 'grub-mkconfig -o /boot/grub/grub.cfg' returned non-zero exit status 1." 

I’m not sure this helps but the manjaro cinnamon iso is old, last updated on the 4th of january.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.

[HowTo] Provide System Information

  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

(Wisdom lies in reading :wink: )

Thank you. I added the info about my PC in the 1st posting.

Besides that I tried to install Manjaro again, then 2 other Arch-based Distros (one of them is Archcraft-Xfce). They all failed with a similar error. Something wrong in the grub files.

A few minutes ago I installed PeppermintOS which is based on Debian-stable.
No problem at all, it installed perfectly.

Since I installed LMDE5 ( Linux Mint, based on Debian ) yesterday without errors and installed Linux-Mint-Cinnamon yesterday without any errors, this looks like a problem related only to arch-based Distros .

I have no idea why this happens.

I chrooted Manjaro as proposed in the Manjaro tutorials, but the same problem happens, nothing is getting done.

I will now install an arch-based distro offline, which produced no problems last week.
I am guessing that it will run through without errors because it is not getting access to the grub-files which are now in the repos.

My guess was wrong. Installation failed because of grub.

After that nothing could be booted anymore.
So I installed PeppermintOS and now I have a working Grub-menu on start and can at least boot alle the non-arch Distros.

So, bye bye Arch … until there is a solution for this.

This sorta sounds like you have an existing /boot that is encrypted, or an otherwise locked down grub/mbr.
I recall a similar thing happening on systems running fedora (I think).

Thanks, @cscs for your comment.
The last few hours I tried many things.

  1. Installed the latest iso , this time I selected Plasma.
    Installation went fine … until the bootloader had to be installed. It failed like all the other installations before. Syntax error

  2. I chrooted the new installed Manjaro Plasma straight from the live-usb.
    Failed each time. Syntax error.

  3. I tried many suggested solutions from the forum. Renaming some files. Re-installing grub …
    Nothing worked.

I gave up. Lost about 7 hours or more today and yesterday with this Syntax error, which results in failed installations of arch-based distros.

Installed - as already mentioned - several non-arch distros like Peppermint (Debian), Linux-Mint (Ubuntu), LMDE5 (Debian) … and they all installed without the error, just installed the bootloader like it should be.

By the way: I have an efi - PC.
Fedora didn´t work at all on this PC, I wasted many hours trying to install that monster, then gave up.
Of course there are people who install Fedora without problems. I bless them and hope that somewhere and somehow arch-based distros will come my way which install without that Syntax-error.

Today on Endeavour Telegram support channel, I got a solution.

I created a second ESP and in Calamares selected manual partitioning.
Selected the second ESP for boot and mounted it on /mnt/boot/efi
Selected a root-partition for Manjaro Plasma and Calamares installed without errors.

Moderator edit: Moved off-topic content that to a new topic

3 posts were merged into an existing topic: Manjaro fails to install brother-dcp165c

Linux - as ecosystem - does not have the backing of a multi-billion corporate - so generally speaking - any Linux will fail - unless of course RedHad or Novell.

Lucky punch.

The first series of ISOs which implement the rocket-launch-slideshow has a serious drawback - they require an excessive amount of available RAM to complete.

The OOM killer will kill the installer if the system has no less then 4GB ram - virtual or otherwise.

One of the perks of being an early adopter - using Arch - is to get the early bugs - if you don’t like that use Debian, RedHat, SuSE or Novell.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.