Live Boot USB doesn't start to desktop. [SOLUTION: Update BIOS firmware.]

I wanted to install 18.1 XFCE using my USB stick, but I wasn't able to get to the live desktop. At this point, whenever I try, I just end up with a black screen, nothing else going on (which I have left for 3-5 minutes). I've tried the following:

  • When I first tried, I got some usual logs and that. I left it running for around 1100 seconds before I gave up and shut down the computer. It seemed to repeat the same 50 odd lines over and over with very slight changes, however, I can't recall what they exactly said, as this was a few hours ago and I've tried many more thing after that.
  • After I rebooted the computer, I got a different message. After around 45 seconds, I got ERROR: ‘/dev/disk/by-label/MJRO170’ device did not show up after 30 seconds…. I followed instructions in this thread, but I failed on step 2 of post 12/19 on the thread. I only got the labels of my hard drives, and I couldn't find the USB drive anywhere.
  • Then, I thought that maybe the USB wasn't working right. I used Rufus 3.8, and 2.18, both copying the same thing on to the USB. I thought that maybe it didn't copy correctly, as Windows' Disk Manager only showed one partition of 4 MB and two unpartitioned spaces filling up the rest, however, I read that that's what should be shown since Windows can't read those two partitions. Anyhow, I tried Etcher too, and the same result as bullet point 2 happened.
  • I tried putting in two different USB slots on my machine, both USB 3 and 2, with no changes.

Eventually, I don't know what I did to envoke this, I stopped getting any output, and now I only have a black screen, with one in ten times the "did not show up after 30 seconds" message appearing. I have disabled Fast Startup too. I have no clue what to do now except try another distro, though I really wanted to use Manjaro. Hopefully you can help.

@TheSheepGuy Welcome to Manjaro. First off, some questions need to be answered:

  1. What system are you trying to install it on? Brand, model, specifications, laptop or desktop, if laptop, does if have an nVidia or AMD card.

  2. When you did get logs, what did it stop on?

Without knowing those 2 pieces of information, people will not know what they can do to help you.

You may need to add a kernel parameter to get the USB to boot properly. You can check out this post on how to add a kernel parameter.

If you want to remake your USB disk, in Windows, you will have to do the following:

Open the start menu and type "cmd". Right click on the result and select "run as administrator"

  1. Type "diskpart". Diskpart is the only way to be able to remove the existing partitions on your USB and reset it.

  2. Type "list disk" This will list all the disks attached to your system.

  3. Type "select disk #" Replace the # with the number listed by your USB drive.

  4. Type "list partition" This will list all the partitions on your USB drive. There should only be one.

  5. Type: "select partition #" Replace the # with the number of the partition on your USB drive.

  6. Type "delete partition"

diskpart-delete-partitions

You can now exit the command line and reformat your USB drive. I suggest using "Etcher" to write the image to the USB drive.

2 Likes

I'd love to tell you what those logs said, however I really cannot rememeber. Sometimes it came up with the aforementioned error in bullet no. 2, othertimes it had 5-6 distinct lines with what looked like hex codes for something? As I said, this was several hours ago and since around 2 h I've only been getting a completely black screen. I can load up the menu where you chose your timezone, etc., but as soon as I hit "boot", it turns black.

The computer is a self-built one:

  • CPU: AMD Ryzen 3 2200G (4 core @ 3.5 GHz)
  • GPU: AMD Radeon R9 380X
  • RAM: 8 GB DDR4
  • Motherboard: ASUS PRIME B450M-A
  • Memory: SATA 1: 1 TB HDD NTFS used for storing files. SATA 2: 320 GB NTFS, this is where I want to install Manjaro on (this ought to be formatted during the installation). SATA 3: 500 GB SSD Windows 10 x64.

When I use diskpart, it shows a 28 GB disk (my 32 GB USB stick), but only a 4 MB partition. This is the same as Windows Disk Manager shows (excuse the German. 2.21 GB not partitioned, 4 MB EFI-system partition, 26.43 GB not partitioned):

The label "MISO_EFI" is what Rufus named it.

Yes, it will. I gave you directions on how to remove that partition and get your full size back. Take a look at the picture I included. It is step by step.

On the screen where you hit "boot". Instead of hitting enter, hit "E". then look for a line with "quiet". Before replace "quiet" with: acpi_osi='Windows 2018' Then press the F10 key to boot the system.

1 Like

The same "did not show up after 30 seconds" error appeared.

I wrote the image using Etcher as you asked after clearing all partitions using diskpart.

I've finally gotten the second log that I mentioned earlier. This is the alternative that comes up occasionally.

I've found out more information. I tried installing Debian since I thought it might be a Manjaro issue. However, there it failed on the step where it detects CD-ROM drivers. I went the terminal to check which disks are there.

Turns out, my hard drive are listed, but my USB stick isn't.

This is why Manjaro cannot find the disk, it doesn't exist to the system's eyes. I can boot on my USB, but as soon as it tries to read from it, it disappears. Hopefully this will help narrow the issue down.

The issue definitely is that it can't find the USB even installing. I've tried the trucks that have been posted before, plugging it in to a USB 3, or 2 port, using a USB hub, fiddling with BIOS UEFI settings (Legacy USB Support, XHCI hand-off, and emulating the stick it as a HDD or a CD-ROM). Lastly, I've used a different USB stick, the over I was using and will be using from here on out is a USB 3 32 GB stick, the other I've briefly tried out is a USB 2 2 GB stick.

I have so far tried this in Manjaro, Debian, and Ubuntu, all with the same error, and I'm literally out of ideas to even look up now.

SOLUTION: Update BIOS firmware. Apparently Ryzen 2 and 3 processors have issues with outdated firmware.

2 Likes

Forum kindly sponsored by Bytemark