Little Help Configuring USB Webcam?

I am here because I have been running Manjaro on my Surface Pro for a few months now, and am somewhat new to linux as a whole. I bought an external USB camera because I did not want to go through the hassle of configuring the built in camera with linux, and this seemed to work for short amount of time, although now when I go to use my webcam I get the follow error message (testing with cheese).

    (cheese:3638): cheese-WARNING **: 13:49:08.467: Device '/dev/video11' has no supported format: ../gst-plugins-good/sys/v4l2/gstv4l2object.c(3942): gst_v4l2_object_set_format_full (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin35/GstV4l2Src:v4l2src1:

Call to TRY_FMT failed for NV12 @ 5120x3840: Invalid argument

Anyone here have any experience with how to fix these types of issues? I can provide any info necessary I just want my webcam to work for courses. A little more detail; this webcam even worked right out of the box plugged into the surface hub on manjaro, now even plugging it in to the device itself I get the same error.