Liquidshell: KDE's upcoming lower resource replacement of Plasma

Or buy nvidia.

2 Likes

Just because you do doesn’t mean we do.

Nvidia is trying to play the dominance card here as it certainly has some fan base in Linux. Most people will condemn their Linux distro for not supporting the good guy nvidia out of the box.
The thing is open source does not work that way. Kwin not supporting it means other small DE that depends on it will not support it.
The only one at fault here is Red Hat. They have the resources and they have made the patch but what about the small and independent Linux developers? They barely have any time to do their passion project and now they are facing a huge unnecessary workload.
The main complaint of Nvidia is gdm is not compatible with windows and thus not cross-platform. Then what about contributing codes to gdm and making it compatible with other platforms? Besides, developers don’t use EGL that much anyway.
Nvidia is likely to lose this game. There are lots of enthusiasm going on Linux world now since 2015. Now, people have two choices, either buy Nvidia and face countless errors for the foreseeable future or buy AMD card.
AMD card is not inferior to Nvidia anymore and they are priced fairly low. It has adopted open source and now open source will maintain it even if they leave some card in the cold. What was the Nvidia’s edge again?

3 Likes

Wow an ultrafast shell…I like

has some issues with the nm-icon though

This is not even in alpha. So this is expected.

How did you get it running?
I downloaded from the git website, using the green download button. Extracted the zip, placed a desktop file in ~/.config/autostart folder and another to stop Plasma from starting.
After reboot I am left with a black screen on which I can read that Plasma is starting, I have a cursor but there is nothing to click upon.
What am i missing in the directions on the git page?

That’s source code, you have to compile it first.

When I do that I’m getting errors:

cmake ..            
-- The C compiler identification is GNU 7.2.0
-- The CXX compiler identification is GNU 7.2.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:5 (find_package):
  Could not find a package configuration file provided by "ECM" (requested
  version 1.3.0) with any of the following names:

    ECMConfig.cmake
    ecm-config.cmake

  Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
  to a directory containing one of the above files.  If "ECM" provides a
  separate development package or SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/home/jan/Downloads/liquidshell-master/build/CMakeFiles/CMakeOutput.log".

Why does it have to be so complicated? Why not make it easy so more people can do this?

Because it is still pre-alpha software under heavy develpment that has not been packaged.

Some would argue that those who cannot compile their own pre-alpah software maybe shouldn’t be running it. Not me personally, but some would.

Instead of complaining look at this as an interesting learning exercise.

1 Like

you need extra-cmake-modules
and you could easy use my PKGBUILD

3 Likes

It could be when I would learn from it. I tell you this: in 9 years of using Linux I have NEVER EVER been able to install something compiling myself. Every time I got errors, then it was, then it was that. Always something blocked a success.
I am so fed up with it. Now I just thought I would like to see this new KDE interface so once again I started and once again I can’t do it.

@fido How would I do that? What do I need to do to make it work?

If you look in the CMakeLists.txt there are lists of dependencies (find_package) that need to be satisfied:

This is also true for other developement suites: configure.ac (gnu make), meson.build (meson/ninja), {application_name}.pro (qmake), etc.

I know you are trying to help, and thank you for that, but it makes things only more complicated.
I give up and wait till there is package which can be installed the normal way.
Thank you for your help, but I am just not capable of understanding this.

yaourt -S liquidshell-git

2 Likes

I was almost typing: you have got to be kidding when I saw the yaourt line. But then I got this:

Starting build()...
/tmp/yaourt-tmp-jan/aur-liquidshell-git/./PKGBUILD: line 26: cd: /tmp/yaourt-tmp-jan/aur-liquidshell-git/src/liquidshell-git-r65.87b14e3: No such file or directory
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build liquidshell-git.
==> Restart building liquidshell-git ? [y/N]

Answering with Yes restarted it and now it is does other things than before, it takes much longer. It actually installed it. Can I now just reboot and see the result or do I need to do something else?

try
sudo rm -r /tmp/yaourt-tmp-jan/aur-liquidshell-git

and try again

As I wrote I restarted the installation and the second time it worked. Can I now reboot and it will work or do I need to do something else first?

open krunner and run liquidshell

Your PKGBUILD is flawed.
When building from git you never use the pkgver sting wen changing directories ${pkgname}-${pkgver}, etc.

But I fixed it for you, this would be correct:

# Maintainer: Jan Neumann <neum dot ja at gmail dot com>


pkgname=liquidshell-git
pkgver=r64.9cc1429
pkgrel=1
pkgdesc='liquidshell is an alternative to plasmashell'
arch=('x86_64')
url='https://cgit.kde.org/liquidshell.git/'
license=('GPL3')
depends=('networkmanager-qt' 'bluez-qt' 'kcmutils' 'knewstuff')
makedepends=('cmake' 'extra-cmake-modules' 'git')
source=("git://anongit.kde.org/${pkgname}.git")
sha256sums=('SKIP')

pkgver() {
  
  cd ${srcdir}/${pkgname}
  printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"

}
prepare() {
  mkdir -p build
}

build() {
  cd build
  cmake ../${pkgname} \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DLIB_INSTALL_DIR=lib \
    -DKDE_INSTALL_USE_QT_SYS_PATHS=ON

  make
}


package() {
  cd build
  make DESTDIR="${pkgdir}" install

  install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" README
  install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING
}