Linux62-nvidia does not exist!

Hi. After updating to the 6.2 Linux kernel the Nvidia proprietary drivers don’t work anymore.

In fact, when I try to install a driver with sudo mhwd -a pci nonfree 0300 I get error: target not found: linux62-nvidia

Likewise, when doing sudo pacman -Syu nvidia I get the following options:

   1) linux419-nvidia  2) linux419-nvidia-390xx  3) linux419-nvidia-470xx  4) linux510-nvidia  5) linux510-nvidia-390xx  6) linux510-nvidia-470xx  7) linux515-nvidia  8) linux515-nvidia-390xx
   9) linux515-nvidia-470xx  10) linux54-nvidia  11) linux54-nvidia-390xx  12) linux54-nvidia-470xx  13) linux61-nvidia  14) linux61-nvidia-390xx  15) linux61-nvidia-470xx  16) linux61-rt-nvidia
   17) linux61-rt-nvidia-390xx  18) linux61-rt-nvidia-470xx  19) linux63-nvidia  20) linux63-nvidia-390xx  21) linux63-nvidia-470xx  22) linux63-rt-nvidia  23) linux63-rt-nvidia-390xx
   24) linux63-rt-nvidia-470xx  25) linux64-nvidia  26) linux64-nvidia-390xx  27) linux64-nvidia-470xx  28) linux64-rt-nvidia  29) linux64-rt-nvidia-390xx  30) linux64-rt-nvidia-470xx  31) nvidia-dkms

Notice there is no linux62-nvidia.
The same happens in Manjaro Settings Manager.

What should I do now? Downgrade to the 6.1 kernel or pick another nvidia driver?

Because linux62 does not exist and is dead.
You need to install and boot into a supported kernel.
Then remove 6.2.



That is not how we manage drivers on manjaro.
We use Manjaro Settings Manager // mhwd , or else is unsupported.


Thank you, @cscs!

Now I have the 6.3.13-1-MANJARO kernel.

But when I try to install the nvidia driver from the Manjaro Settings Manager I still get error: target not found: linux62-nvidia even after rebooting.

I don’t know where it is taking the 6.2 version from. In that case would installing it with sudo pacman -Syu nvidia be a valid workaround?


Did you remove 6.2 ?

mhwd-kernel -li
pacman -Qs linux62

Now I removed it and it worked, thanks again @cscs !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.