Linux Mint broke my Manjaro installation

I tried to install Linux Mint to a USB drive. I have tried to make sure that it wasn’t going to override my current Manjaro installation on my internal drive.
When the installation was complete, I couldn’t boot into Manjaro and the Linux Mint install didn’t work either.

Is there a way I could repair my Manjaro install or do I have to reinstall Manjaro back onto my computer? If you do have solutions to my problem, please let me know!


I must be in a helpful mood tonight.

Anyway, I can feel your pain on that one. I’m going to take a guess and say that either Grub got blown out or you blew away your Manjaro installation. I’ve not run into this issue with Manjaro but I’ve made a few Windows installations regret life. Check out here as it has a rundown of how to fix the boot loader.

Future tip. I have done this exact same idea where I wanted to have a bootable usb linux distro. I unplugged my bootable hard drive so I wouldn’t make the mistake of blowing my existing distro away. I’ve gotten better at checking but also why I keep a lot of hardware around to do dumb stuff like this.

Hope that helps and I wish you luck.

1 Like

Always install manjaro second as manjaro grub can boot mint but mint can’t boot manjaro

Hello, I have tried to follow the instructions you provided me. I came across some issues with parts of the solution I feel I should address. When I got to the step where it wants me to Verify the existance of an EFI system partition,


My output showed my drives but my efi partition, sda1, didn’t show itself as an EFI partition. All the drives didn’t show any information about the partition types.

Secondly, when I type in:

manjaro-chroot /mnt /bin/bash

It gave me an error saying /mnt/proc directory doesn’t exist.

I do apologize for not being able to show the full information as I am using my phone to reply. If you do want more information, I will be more than glad to provide more information!