Linux-lts update: USB-C display no longer working

A while ago I asked here, how to get the usb-c dock hdmi output working on my pinebook pro, and was told to use the linux-lts kernel.

I updated the kernel yesterday after not doing so for months, and since then, the display is no longer working, even though the patch to remove the hack was only included into the linux kernel.


I would use the linux-megi kernel, but only if there is a PKGBUILD for it.

linux-lts was recently updated from 5.15 to 6.1, which is the newest LTS kernel.

There was no patch to remove the hack. The patches that was present in 5.15 to enable the functionality has not applied for a while and has never been included in any of our linux 6.X kernels.
Although I have tried applying Megi’s versions, they seem to present other issues. The one I currently face is that if I enable the DP altmode patches, the keyboard and touchpad does not work on the Pinebook Pro. So they are currently not enabled.

The patches are hacks. They only work for some. And they only work in certain conditions, it seems. I deemed them unreliable and opted to no longer include them in kernel 5.18 and above.

can I somehow obtain a package of the old kernel again? it seems like the gitlab ci automatically removes old builds, and it’s been so long that I long deleted my copy of that package.

I don’t think my computers are fast enough to finish compiling the kernel in my life…

Unless you saved in your pacman cache, you would need to either compile it yourself, or get someone to compile it for you.

I’m going to make a bold request: Could you retrigger a CI build of the kernel version you mentioned above?

It’s not really that easy.

The jobs where run on a CI runner that no longer exists, so the CI file in that commit would need to be changed to use an existing runner.

Sorry about that.

aw. Well thanks for the help anways. I’m gonna hope that my PBP can compile this in one day

I ended up compiling this commit, which is the last 5.* release on the master branch that compiled successfully.

makepkg worked perfectly, even though it look like 10 hours to compile on my PBP.

I’m sharing the package here in case anyone needs it. It’s working perfectly for me.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.