Linux installation broken in Dual-Boot system, need help reinstalling Manjaro

Here is my /etc/fstab:

# <file system>                          <mount point>  <type>  <options>  <dump>  <pass>
UUID=A47A-E698                            /boot/efi      vfat    umask=0077 0 2
UUID=cbc87e37-4f83-4f21-a23b-bbd2ea05d0b5 swap           swap    defaults,noatime 0 2
UUID=36874956-5802-45b7-b40b-7c47b66fd5ef /              ext4    defaults,noatime 0 1
UUID=a05618e2-00d7-4b61-bd89-d3eaf4bb50c3 /home          ext4    defaults,noatime 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

Not sure what to check, did there had to be a mount of swap and /tmp? Everything seems fine.

The removed packages are still in the pacman cache, so i guess i am gonna reinstall them and see if it fix things.

Nope - don’t worry about that.
You could try
swapon -a
to use it.
But I wouldn’t bother unless you are low on RAM.
and tmpfs is taken care of by the chroot

It was probably a bit much to ask of you to judge whether the system inside the chroot is indeed assembled fully and correctly.
Let’s just assume it is. :wink:

Just be careful - you are root!
No questions asked, whatever you do.
… but at least I didn’t give you any potentially dangerous commands to try and execute - I’m very sure of that!

Another thing, what about the only package i reinstalled yesterday using pacman -S linux510 i have the old version in the pacman cache. Do i reinstall the old version or let it pass and just try to reinstall all the other packages?

If you installed it yesterday, it is very very unlikely that this is “an old version”
let it pass I’d say

this is Manjaro - not Arch
in Manjaro you normally do not install kernels with:
pacman -S linux510
In Manjaro, there is a tool for that:

Don’t worry - it just takes care of some extra steps that are needed after installing a kernel via pacman … to make it actually usable.
If you are worried nonetheless:
just reinstall it :wink:

I used pacman -U /var/cache/pacman/pkg/_name_of_package to reinstall all the packages i could find that matched the ones i removed. After exiting and rebooting my system is still the same, GRUB won’t show up, it boots directly into the “Emergency Mode” with the same messages as before.

Here is the list of the orphaned packages removed:

[2021-02-12T11:36:56-0300] [ALPM] removed xorg-fonts-alias (1.0.3-3)
[2021-02-12T11:36:56-0300] [ALPM] removed xorg-font-utils (7.6-6)
[2021-02-12T11:36:56-0300] [ALPM] removed xorg-mkfontscale (1.2.1-2)
[2021-02-12T11:36:56-0300] [ALPM] removed xorg-font-util (1.3.2-2)
[2021-02-12T11:36:56-0300] [ALPM] removed xorg-bdftopcf (1.1-2)
[2021-02-12T11:36:56-0300] [ALPM] removed startup-notification (0.12-7) 
[2021-02-12T11:36:56-0300] [ALPM] removed quazip (1.1-1)    
[2021-02-12T11:36:56-0300] [ALPM] removed python-sip4 (4.19.24-1)
[2021-02-12T11:36:56-0300] [ALPM] removed python-pytoml (0.1.21-6)
[2021-02-12T11:36:56-0300] [ALPM] removed opencolorio (1.1.1-6)
[2021-02-12T11:36:56-0300] [ALPM] removed yaml-cpp (0.6.3-2) 
[2021-02-12T11:36:56-0300] [ALPM] removed tinyxml (2.6.2-7) 
[2021-02-12T11:36:56-0300] [ALPM] removed mhwd-nvidia-340xx (340.108-1) 
[2021-02-12T11:36:56-0300] [ALPM] removed lua (5.4.2-1) 
[2021-02-12T11:36:56-0300] [ALPM] removed linux59 (5.9.16-1)
[2021-02-12T11:36:56-0300] [ALPM] removed linux-latest (5.10-1)  
[2021-02-12T11:36:57-0300] [ALPM] removed linux510 (5.10.7-3) 
[2021-02-12T11:36:57-0300] [ALPM] removed linux-firmware (20210109.r1812.d528862-1) 
[2021-02-12T11:36:57-0300] [ALPM] removed libpwquality (1.4.4-3) 
[2021-02-12T11:36:57-0300] [ALPM] removed cracklib (2.9.7-2)    
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-vulkan-icd-loader (1.2.166-1) 
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-openal (1.21.0-1)
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-nss (3.60.1-1) 
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-nspr (4.29-1) 
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-lz4 (1.9.3-1)   
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-libxss (1.2.3-1) 
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-attr (2.4.48-1)  
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-alsa-oss (1.1.8-2) 
[2021-02-12T11:36:57-0300] [ALPM] removed kseexpr ( 
[2021-02-12T11:36:57-0300] [ALPM] removed js68 (68.12.0-1) 
[2021-02-12T11:36:57-0300] [ALPM] removed js60 (60.9.0-2) 
[2021-02-12T11:36:57-0300] [ALPM] removed gtest (1.10.0-3)   
[2021-02-12T11:36:57-0300] [ALPM] removed gsl (2.6-2)   
[2021-02-12T11:36:57-0300] [ALPM] removed gmic (2.9.4-1)   
[2021-02-12T11:36:57-0300] [ALPM] removed opencv (4.5.1-1) 
[2021-02-12T11:36:57-0300] [ALPM] removed tbb (2020.3-1)    
[2021-02-12T11:36:57-0300] [ALPM] removed lapack (3.9.0-3)   
[2021-02-12T11:36:57-0300] [ALPM] removed cblas (3.9.0-3)   
[2021-02-12T11:36:57-0300] [ALPM] removed blas (3.9.0-3)    
[2021-02-12T11:36:57-0300] [ALPM] removed graphicsmagick (1.3.36-1) 
[2021-02-12T11:36:57-0300] [ALPM] removed game-devices-udev (0.10-2) 

And a list of the ones i could not reinstall directly (did not find it, or maybe one passed as a dependency)

[2021-02-12T11:36:56-0300] [ALPM] removed xorg-fonts-alias (1.0.3-3)
[2021-02-12T11:36:56-0300] [ALPM] removed xorg-font-utils (7.6-6)
[2021-02-12T11:36:56-0300] [ALPM] removed xorg-mkfontscale (1.2.1-2)
[2021-02-12T11:36:56-0300] [ALPM] removed xorg-font-util (1.3.2-2)
[2021-02-12T11:36:56-0300] [ALPM] removed xorg-bdftopcf (1.1-2)
[2021-02-12T11:36:56-0300] [ALPM] removed startup-notification (0.12-7) 
[2021-02-12T11:36:56-0300] [ALPM] removed python-pytoml (0.1.21-6)
[2021-02-12T11:36:56-0300] [ALPM] removed opencolorio (1.1.1-6)
[2021-02-12T11:36:56-0300] [ALPM] removed mhwd-nvidia-340xx (340.108-1)  
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-vulkan-icd-loader (1.2.166-1) 
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-openal (1.21.0-1) 
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-libxss (1.2.3-1)
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-attr (2.4.48-1) 
[2021-02-12T11:36:57-0300] [ALPM] removed lib32-alsa-oss (1.1.8-2)
[2021-02-12T11:36:57-0300] [ALPM] removed js68 (68.12.0-1)
[2021-02-12T11:36:57-0300] [ALPM] removed js60 (60.9.0-2) 

After using the exit command it unmounted everything, i don’t think i used the exit command when i chrooted yesterday. Maybe it helps narrow down the problem? Also i used the pacman -Qs _name_of_package to see if some of the packages were already installed and did not need to reinstall, which was the case for linux510 and linux-firmware.

cat /var/log/pacman.log | grep PACMAN
will show the actual commands you ran

From the removed (and now re-installed packages)
I can’t glance anything other than:
with these in the list of packages about to be removed
I’d have at least hesitated to actually do it.

Are you sure that’s all of them?

cat /var/log/pacman.log
will show the whole thing
the grep command is used to filter the output by certain distinctive keywords

and then there is always the possibility of running a full system update/upgrade
if the here attempted reconstruction of the former state didn’t work

I’d try to re install xorg - possibly also your DE
your nvidia driver seems to have been among the victims
or was it even mhwd itself?
… don’t know

Here is the commands from pacman.log:

[2021-02-12T11:36:37-0300] [PACMAN] Running 'pacman -Rs game-devices-udev gm
ic gsl gtest js60 js68 kseexpr lib32-alsa-oss lib32-attr lib32-libxss lib32-
lz4 lib32-nss lib32-openal lib32-vulkan-icd-loader libpwquality linux-latest
linux59 lua mhwd-nvidia-340xx opencolorio python-pytoml python-sip4 quazip
startup-notification xorg-font-utils xorg-fonts-alias'
[2021-02-12T14:03:21-0300] [PACMAN] Running 'pacman -S linux59'
[2021-02-12T14:05:18-0300] [PACMAN] Running 'pacman -S linux 10'
[2021-02-12T14:27:24-0300] [PACMAN] Running 'pacman -S linux510'

Before them the latest is a full system upgrade last month in the 22. After them are the commands for the packages i reinstalled today.

After the first command at least GRUB would boot.

that huge long pacman command was generated by another, previous command
not here recorded

If you are interested what it was:
it is in the file ~/.bash_history
… likely similar if you used zsh as your shell

in the first command, your nvidia driver for your graphics card got removed

with the second command (installing a kernel)
the bootloader was finally updated and probably a new initrd generated
which then failed

You could try a system update/upgrade.

If that doesn’t work out as expected, I would not bother anymore
but backup my files from the /home partition (just in case)
and then re-install

it’s just quicker than trying to sort this out

give yourself some more room in /
or just put everything in one partition instead of separating / and /home
… just a suggestion

I don’t think i can make the system update, the total installed size is about 3.7gb while i only got about 1.5 of free space in root. Already backed up the important things in /home .

Last time i installed Manjaro it was months ago, is there no conflicts with all the partitions already made and windows 10, or do i just follow the same steps as before? I don’t want to break my system any further.

Is there a good guide to reinstall Manjaro? Or a guide to uninstall Manjaro and see if Windows is still intact?

There won’t be a problem as long as you only use /dev/sda5 - through /dev/sda8
or, rather, the space these partitions currently occupy
I’d make one 512 MB partition
or just re-use the current /dev/sda5 as EFI

and make one ~ 50 GB partition out of the rest of /dev/sda6 /dev/sda7 /dev/sda8

Very likely - probably here on the forum or on the Manjaro website.

There is no uninstall - not one that returns all the partitioning back to where you started from.

… you don’t know whether windows is still intact?
There is no reason that it would not be - none of it was touched.

Since GRUB broke, i lost the option to boot into windows. There was a "boot into windows " option when selecting to choose another boot option for the USB, but still hesitating to use it. At this point i don’t know what is safe to do and what would break things further.

Taking the helping hand the USB boot option offers you will not destroy anything.
It could fail.
But not change anything by trying to use it.
You’ll only know once you try.

So, i did end up trying to see if windows was okay. Selected “temporary startup devices” and choose “Windows bootloader”. There was some bitlocker screen and some “preparing bitlocker recuperation,”, i choose to “omit this drive” and later in the options presented selected shutdown.

Did the bitlocker thing screw things up further? I read that Windows can mess with Linux stuff, that was why i hesitated. I know that the two FAT32 partitions refer to two different bootladers, and bitlocker is supposed to protect/encrypt sda3 but that is my limit. How these things interact with each other i don’t know.

Can i try to reinstall Manjaro from a USB or must i boot into Windows to configure the partitions again?

This is the guide i used last time to install Manjaro:

Also fount this: which says some things about not formatting the EFI partition used last time, in my case i have to format all the linux partitions, i think.

Edit: Reading another guide seems bitlocker needs to be disabled to install/use Manjaro. I was stupid and enabled it after everything was working fine for some reason. Can anyone with dual-boot experience tell me how to boot into windows and disable it? is it okay to use the windows bootloader?

I don’t know.

I guess that
/dev/sda5 and /dev/sda6 and /dev/sda7 and /dev/sda8
all belong to your now defunct Linux install
not quite sure about /dev/sda5 - it seems to be the EFI partition of that linux install
while /dev/sda1 is the EFI partition of the Windows installation.
You should know.
I’m not sure how to find that out - other than mounting both and looking at the contents.

Windows will probably tell you if you are about to remove one of the partitions that it needs - so doing the repartitioning/deleting of the Linux partitions from within Windows might not be a bad idea.
Of course you can do that from Linux, too - during the installation
or before starting the installer
by launching the partition manager and removing those partitions and creating a single one in it’s place.

I don’t know about that.
It can be disabled - essentially decrypting the now encrypted drive.
How to do that - I don’t know.
The info is likely on the net.
I do not know whether that is neccessary - I’d not think so.

I can’t.
But: last time it worked, no?
The windows bootloader can be made to boot Linux by chainloading (I guess that’s the term) to Grub, which in turn then boots Manjaro.
Have never done this - just read about it. No experience at all.

the title of the thread is now not fitting what you want help for anymore
the subject changed - perhaps you should rename it or create a new one so that knowledgeable people will notice and can help

Here is the link where it says to disable bitlocker:

Am i right in thinking that enabling secure boot would bypass bitlocker and boot straight into windows without interfering with any linux partitions? That way i could disable bitlocker and prepare everything to reinstall Manjaro.

I’ll read it, eventually.
But even if I had read it right now:
I really wouldn’t know - it would all be just opinion based solely upon what I just read.

I don’t have Windows.
I can’t test any of this.
I’ll refrain from providing advice regarding this
if you, as it looks like
want to rely on that advice.

… instead of perhaps being prepared to learn by trial and error
which is no problem other than perhaps a time problem - if you have backup images of your windows … you can start over anytime

It really isn’t a big problem to reinstall either Windows or Linux.
You might loose your personal data - and time.
There is a fix for the former - as for the latter: learning takes time

but a re-install is the worst case scenario

My opinion now:
BitLocker seems to rely on Secure Boot to be enabled.
To install Manjaro (or Arch)
this has to be disabled.
There are Linux Distributions (like Ubuntu) that work and can deal with Secure Boot.
Manjaro … can’t - not easily, not “out of the box”.

… you changed the title of the thread
perhaps it’ll help attracting other knowledgeable people after that many posts
perhaps it’s better to start over with a fresh one, containing all the relevant information

It is probably not a big deal to unite the space that these partitions use by deleting them and creating one bigger one instead in that space - and then re-install linux

But it’s just a fact that you need to be sure what and which those partitions are that you delete and replace.
Only you can know/decide that.

… doing the deleting from Windows will probably be good - because it might tell you if you are about to remove a crucial component …


I, too, am unable to install Manjaro from a USB on a dual-boot system. I’m now getting Grub Rescue and have two questions. This is also my first time posting in the forum, so would this be the right place to post my question or should I do a separate post?