Linux can't find ssd disk

Hi all,

After my laptops’ battery going completely empty while into hibernation (or at least that is what I think happened), I am unable to boot. After the grub menu, I am dropped into an emergency shell. and are two different UUIDs:

ERROR: resume: hibernation device 'UUID=<UUID-1>' not fount
ERROR: device 'UUID=<UUID-2>' not found. Skipping fsck.
mount /new_root: can't find UUID=<UUID-2>
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off

I am having a dual boot on two different SSDs. A common problem is that the UUID is somehow changed and correcting it in the grub.cfg should fix it. However, when looking for the UUID using blkid or when booting using a live OS USB, the SSD is not found in any way. In the GRUB terminal, the SSD can be found using de GRUB ls command, which also shows for the root partition. Future more, when booting into Windows, the SSD appears in the partition manager, and I am able to read its contents using a 3rd party tool.

In the emergency shell, I looked through the dmesg, there is one error which may be related (I have skipped typing over all the times):

[rootfs ]# dmesg | grep nvme
[    0.994305] nvme nvme0: pci function 0000:02:00.0
[            ] nvme nvme1: pci function 0000:3e:00.0
[            ] nvme nvme0: missing or invalid SUBNQN field
[            ] nvme nvme0: failed to set APST feature (11)
[            ] nvme nvme0: could not set timestamp (270)
[            ] nvme nvme0: could not set queue count (11)
[            ] nvme nvme0: IO queues not created
[            ] nvme nvme0: Failed to configure AEN (cfg 200)
[            ] nvme nvme1: 7/0/0 default/read/poll queues
[    1.035554]  nvme1n1: p1 p2 p3 p4

A solution I found online was adding kernel parameter nvme_core.default_ps_max_latency_us=0, but that does not appear to change anything.

Anyone an idea how to recover my system?

Hi @tijm,

I think you’d do well to read thorough, and go thorough this:

And/or this:

Hope it helps!

1 Like

Hi Mirdarthos,

Thank you for your reply. I have tried those steps. However, the SSD is not showing up in the live OS. Thus, manjaro-chroot fails to find a Linux partition, and manually mounting the partition is not possible because the partition does not exist in the /dev folder.

lsblk is, besides the loops, only showing the Windows SSD and the USB of the Live OS. lspci is showing the two SSDs. In the Live OS dmesg related to nvme are the same as in my previous post.

Thanks for your time, hope you have some other ideas.

recheck all option in UEFI motherboard
all disks only in AHCI

1 Like

Please check in BIOS / UEFI if the ssd shows up there


Thank you, Stephane and Andreas for your replies. Unfortunately, my pc is rather old, and as far as I know it does not support AHCI. For the record, it is a Lenovo ThinkPad P51.

I am starting to worry the drive might be broken. However, it is weird that the filesystem is still accessible through the GRUB terminal, but not through the Live OS. And that it worked just fine with my system till just now.