Linux bootloaders not overriding windows bootloader

I have an acer oem laptop, came pre-installed with windows 8.1, that I have very recently reset due to some unrelated problems with grub and other. I’ve reinstalled windows and I have that working fine, so I tried to install manjaro (gnome, although I’m not sure it matters), which runs fine, but no matter what I try, I can’t get grub or rEFInd to boot (I’ve just been using the manjaro boot usb, or else it just defaults to windows).

What I’ve tried:
Reinstalling grub (including updating it)
Installing rEFInd
Setting grub to be booted from windows (not sure this is how you’re really meant to do it)

bcdedit /set {bootmgr} path \EFI\Manjaro\grubx64.efi

Putting ‘Windows boot loader’ at the back of the uefi boot list (for all it’s worth)

None of this has worked, and I’m not sure what info to give, I’m quite new to Linux, so lots of detail would be nice. Btw I had this issue pre-reset, but I don’t know how I fixed it.

Thanks.

EDIT: in case anyone wonders, I do have secure boot disabled

Lots of similar topics in the forum for useful details. Search the forum.
For your issue follow this Tutorial

1 Like

@petsam
The instructions from the link didn’t work for me, I’m still booting into windows as normal, but the post recommended I give some specific outputs I have listed below.
And, yes I have looked around the forum for situations relevant to mine but most’s solutions don’t work for me. If there is any other specific places you’d recommend me look, that would be much appreciated.
In any case, thanks.

Outputs:
efibootmgr -v :

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 2001,0000,2002,2003
Boot0000* Windows Boot Manager	HD(2,GPT,e894786d-8b92-4baf-a5d3-711a3f952af5,0x12c800,0x96000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* USB HDD: SanDisk Cruzer Blade	PciRoot(0x0)/Pci(0x14,0x0)/USB(4,0)/USB(1,0)/HD(2,MBR,0x0,0x38ef54,0x2000)RC
Boot0002* Unknown Device: 	FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)RC...0
Boot0003* Unknown Device: 	FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)RC...0
Boot0004* Unknown Device: 	FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)RC...0
Boot0005* rEFInd Boot Manager	HD(6,GPT,c078db9b-5612-437f-bd5c-f389baa968c0,0x18a79000,0x80000)/File(\EFI\refind\refind_x64.efi)
Boot0006* Linux	HD(6,GPT,c078db9b-5612-437f-bd5c-f389baa968c0,0x18a79000,0x80000)/File(\EFI\Manjaro\grubx64.efi)
Boot0007* manjaro	HD(6,GPT,c078db9b-5612-437f-bd5c-f389baa968c0,0x18a79000,0x80000)/File(\EFI\Manjaro\grubx64.efi)
Boot0008* manjaro	HD(6,GPT,c078db9b-5612-437f-bd5c-f389baa968c0,0x18a79000,0x80000)/File(\EFI\Manjaro\grubx64.efi)
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

sudo parted -l :

Model: ATA WDC WD5000LPVX-2 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  630MB   629MB   ntfs            Basic data partition          hidden, diag
 2      630MB   945MB   315MB   fat32           EFI system partition          boot, esp
 3      945MB   1079MB  134MB                   Microsoft reserved partition  msftres
 4      1079MB  212GB   211GB   ntfs            Basic data partition          msftdata
 6      212GB   212GB   268MB   fat32                                         msftdata
 8      212GB   293GB   80.5GB  ext4
 9      293GB   477GB   184GB   ext4
 7      477GB   479GB   2147MB  linux-swap(v1)
 5      479GB   500GB   20.9GB  ntfs            Basic data partition          hidden, diag


Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdb: 8004MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32.8kB  1910MB  1910MB  primary               boot
 2      1910MB  1915MB  4194kB  primary               esp

sudo blkid :

/dev/sda1: LABEL="RECOVERY" UUID="A4486EFA486ECB1E" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="d1f383ac-20c3-4150-816f-fe7928a05487"
/dev/sda2: LABEL="ESP" UUID="EE6F-B124" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="e894786d-8b92-4baf-a5d3-711a3f952af5"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="d2069848-d8ac-4d39-b418-c540e19ebcd9"
/dev/sda4: UUID="C058CCA758CC9E12" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="d18f1324-9bfe-426f-ab60-4f76582b12aa"
/dev/sda5: LABEL="Push Button Reset" UUID="A69C74909C745CAD" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="8dda5bc6-a668-4cae-85da-957a7dcee796"
/dev/sda6: UUID="06C9-1B6F" TYPE="vfat" PARTUUID="c078db9b-5612-437f-bd5c-f389baa968c0"
/dev/sda7: UUID="6c64c1b2-d6d7-425c-bd44-fdc6f36fd4ac" TYPE="swap" PARTUUID="f79737df-51a2-4b34-88ff-15cafb7139e7"
/dev/sda8: UUID="e2ae46c5-230a-4f96-89f8-91d71d6d6b59" TYPE="ext4" PARTUUID="b11cf045-41ee-439f-afe1-43ccb4938f32"
/dev/sda9: UUID="1ec47d72-3607-4d4c-9ef6-f3b04d8dced2" TYPE="ext4" PARTUUID="dba0986b-f79d-4c81-9cfb-42b01ce5c55f"
/dev/sdb1: UUID="2018-05-07-20-05-15-00" LABEL="MJR17110" TYPE="iso9660"
/dev/sdb2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="FDB1-353B" TYPE="vfat"

findmnt -s :

TARGET    SOURCE                                    FSTYPE OPTIONS
/boot/efi UUID=06C9-1B6F                            vfat   defaults,noatime
/         UUID=e2ae46c5-230a-4f96-89f8-91d71d6d6b59 ext4   defaults,noatime
/home     UUID=1ec47d72-3607-4d4c-9ef6-f3b04d8dced2 ext4   defaults,noatime
swap      UUID=6c64c1b2-d6d7-425c-bd44-fdc6f36fd4ac swap   defaults,noatime

findmnt /boot/efi :

TARGET    SOURCE    FSTYPE OPTIONS
/boot/efi /dev/sda6 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iochars

hope this helps someone :slight_smile:

First, your output does not show sda6 (manjaro’s $esp) as flagged as boot,esp
Try doing this and then provide output of “sudo parted -l” again.

sudo parted /dev/sda set 6 esp on

Then

sudo efibootmgr -o 0008,0007,0006,0006,0005

note: it is possible that your computer is tied in with windows.
In your ‘efibootmgr -v’ there is the “RC” at end of the entries which will only boot.
If doing above won’t help, as is possible, then you might have to look this link.

Also let’s have a look at

ls /sys/firmware/efi/efivars | grep ^Boot
ls /sys/firmware/efi/efivars
1 Like

@petsam @AlManja
(gohlip, i wouldve referenced you too for your posts but i cant apparently)
Al, your gparted solution worked for me. No grub after fresh installation
Thanks all for your help and patience :grinning:

(please notify me if anyone wants something done as the solution has been found or something…)

Just lucky beginner guess, but I’m glad it worked this time

Edit, oh now I see, you were peeking into another thread, lol, I hope it helps to that other guy also :wink:

And
efibootmgr

@gohlip
All that should have changed was sda6’s flags…(and the reference to the boot file)
Heres the outputs for reference anyway.

efibootmgr -v

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,2001,2002,2003
Boot0000* Windows Boot Manager	HD(2,GPT,e894786d-8b92-4baf-a5d3-711a3f952af5,0x12c800,0x96000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* HDD: WDC WD5000LPVX-22V0TT0	PciRoot(0x0)/Pci(0x13,0x0)/Sata(0,0,0)/HD(6,GPT,c078db9b-5612-437f-bd5c-f389baa968c0,0x18a79000,0x80000)RC
Boot0002* Unknown Device: 	FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)RC...0
Boot0003* Unknown Device: 	FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)RC...0
Boot0004* Unknown Device: 	FvVol(a881d567-6cb0-4eee-8435-2e72d33e45b5)/FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)RC...0
Boot0005* rEFInd Boot Manager	HD(6,GPT,c078db9b-5612-437f-bd5c-f389baa968c0,0x18a79000,0x80000)/File(\EFI\refind\refind_x64.efi)
Boot0006* Linux	HD(6,GPT,c078db9b-5612-437f-bd5c-f389baa968c0,0x18a79000,0x80000)/File(\EFI\Manjaro\grubx64.efi)
Boot0007* manjaro	HD(6,GPT,c078db9b-5612-437f-bd5c-f389baa968c0,0x18a79000,0x80000)/File(\EFI\Manjaro\grubx64.efi)
Boot0008* manjaro	HD(6,GPT,c078db9b-5612-437f-bd5c-f389baa968c0,0x18a79000,0x80000)/File(\EFI\Manjaro\grubx64.efi)
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

parted -l

Model: ATA WDC WD5000LPVX-2 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  630MB   629MB   ntfs            Basic data partition          hidden, diag
 2      630MB   945MB   315MB   fat32           EFI system partition          boot, esp
 3      945MB   1079MB  134MB                   Microsoft reserved partition  msftres
 4      1079MB  212GB   211GB   ntfs            Basic data partition          msftdata
 6      212GB   212GB   268MB   fat32                                         boot, esp
 8      212GB   293GB   80.5GB  ext4
 9      293GB   477GB   184GB   ext4
 7      477GB   479GB   2147MB  linux-swap(v1)
 5      479GB   500GB   20.9GB  ntfs            Basic data partition          hidden, diag

Okay. What has actually changed is that your boot is now in bootx64.efi (0001), the hard disk entry.

And that bootx64.efi was set by following commands (copy manjaro’s efi to bootx64.efi) at petsam’s link. Still not ‘manjaro’ entries (0007,0008).

Anyway, since you are not booting up Manjaro efi which is what we wanted, though bootx64.efi not grubx64.efi. Let’s leave it as that.

Cheers, take care.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.