Linux 4.12

Overall it’s been quite smooth for me with my intel + nvidia hardware setup, support for some peripherals (xbox one bluetooth controller) seems somewhat improved as well.

There comes no driver for nvidia 340 with kernel 4.12.
Kernel 4.11 works fine because the driver is included.

regards
caho

4.12 has implemented KASLR in the kernel, (which is as old as Vista).
So, when will Linux implement the unique wonder of KARL, free, from OpenBSD ?
It may not be the magic-bullet but it’s a dam sight more kernel-secure than KASLR. -aka STOP following Windoze.
you can google the rest…
which I originally found from here:
https://forum.manjaro.org/t/openbsd-will-get-unique-kernels-on-each-reboot/27242?source_topic_id=27111

Thanks for all of you guys for the feedback and suggestions…

VirtualBox Modules might work now with v5.1.22-3. Please check and give some feedback.

@philm you’re right, it’s working now

It’s working for me too. :slight_smile:
But the system still freezes when I return from suspend (kernel 4.12.1).

I had more time for testing and here are some facts from my end regarding the start of the kernels and resume from suspend things, and virtual box:

  • 4.9.37 in 8.447s - works 100% no issues at all
  • 4.11.10 in 8.499s - suspend makes the VGA port to act funky by changing the resolution, restart solves that. VBox works ok
  • 4.12.1 in 8.450s - suspend forces me to hard reset and VBox freezes the system. Everything else seems to work

Update Edit: Got the linux412-virtualbox-host-modules Version 5.1.22-3 just now and:

  1. now i can run virtual box as is suppose to, no hang or freeze of the system
  2. the boot time of the kernel 4.12.1-1 is now 8.320s
  3. now the suspend and resume works perfectly
    Thank you @philm !!! Awesome job !!!

I noticed that BFQ is not the default scheduler in kernel 4.12 (tested all kernel versions):

╰─ cat /sys/block/sd*/queue/scheduler
[mq-deadline] kyber bfq bfq-mq none
[mq-deadline] kyber bfq bfq-mq none
╰─ sudo tlp-stat -d|grep Sch
 Scheduler = mq-deadline

I opened an issue here:

I tried also 4.12.2 and I can’t resume from suspend. My system still freezes (not immediately but after a few seconds). Are you sure that has been fixed for you?

Yes, it works on my main machine as i mentioned but i have no idea why only after the update to the linux412-virtualbox-host-modules Version 5.1.22-3.
If i downgrade to the previous one nothing works regarding VBox and suspend … Instant crash.
Also i solved the BFQ thing (as you did) and now i’m a bit more happier … You also updated the linux412-virtualbox-host-modules to 5.1.22-3 ?

1 Like

I’m already with 5.1.22.4 (unstable branch).
I don’t have issues with VB anymore but the problem with freezing system after suspend remains. :joy:

That’s a bugger!!! :sob:
One thing i will mention, my machine has only a legacy BIOS and is set to suspend to ram. I don’t use swap at all. Does this help somehow?

1 Like

Maybe this, I have a swap file…I don’t know…I never had this problem before with any kernel.

I posted about the issue I am having on my KDE install on my Intel laptop:

[Stable Update] 2017-07-16 - Kernels, Deepin, Palemoon, KDE-Framework, XFCE4-GTK3

Suspend (well actually resume :D) not working for me. I get a circle rotating around my wifi icon and then have to reset. No access to VT, ctrl+alt+bkspace does not work. Have removed 4.12.

Intel everything here:

1 Like

Now with the stable - update

comes the driver nvidia 340xx to the kernel 4.12 and works fine. :grin:

regards
caho

Suspend issues aren’t present for me with 4.13-rc1. Looks like 4.12 might be a miss for my systems (even-numbered releases seem to do this regularly for me…).

After upgrading to kernel 4.12.1-1 my computer freezes when I try to resume from suspend. I can type in my password and press enter then it freezes. I have to power down and start the computer again. I have reverted to kernel 4.11.10-1 which does not exhibit the problem.

I am running xfce and here is the oupt from inxi:

System:    Host: manjaro Kernel: 4.12.1-1-MANJARO x86_64 (64 bit gcc: 7.1.1)
           Desktop: Xfce 4.12.4 (Gtk 2.24.31) Distro: Manjaro Linux
Machine:   Device: portable System: Dell product: Inspiron 5521 v: A04
           Mobo: Dell model: 0K08H3 v: A00
           UEFI [Legacy]: Dell v: A04 date: 11/21/2012
Battery    BAT1: charge: 35.5 Wh 86.2% condition: 41.1/42.0 Wh (98%)
           model: SDI DELL PT43699R status: Discharging
CPU:       Dual core Intel Core i5-3337U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7186
           clock speeds: max: 2700 MHz 1: 2499 MHz 2: 2499 MHz 3: 2694 MHz
           4: 2700 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.3) driver: intel
           Resolution: 1366x768@60.04hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile
           version: 4.2 Mesa 17.1.4 Direct Render: Yes
Audio:     Card Intel 7 Series/C216 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.12.1-1-MANJARO
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 01:00.0
           IF: enp1s0 state: down mac: <filter>
           Card-2: Intel Centrino Wireless-N 2230
           driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 1000.2GB (56.2% used)
           ID-1: /dev/sda model: WDC_WD10JPVT size: 1000.2GB
Partition: ID-1: / size: 908G used: 516G (60%) fs: ext4 dev: /dev/dm-0
           ID-2: swap-1 size: 9.45GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
Sensors:   System Temperatures: cpu: 48.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 2600
Info:      Processes: 199 Uptime: 2 min Memory: 1026.5/7863.1MB
           Init: systemd Gcc sys: 7.1.1
           Client: Shell (bash 4.4.121) inxi: 2.3.23

Thanks in advance.

@jonathon - Just tested 4.13 - exactly the same problems

1 Like

Forum kindly sponsored by Bytemark