Linking to anything to desktop won't show on desktop

As title: I linked dragged an appimage to desktop and clicked the button to link here. It didn’t show up, so I figured I might have missclicked, and tried again. I then got the pop up saying that it was already linked there. If look at my desktop through dolphin though, it shows up. any thoughts?

I tried running a command that I found online in a different thread:

sudo find /tmp/ /var/tmp/ -mindepth 1 -delete
sudo reboot

This command makes the links show, but then repeating the steps again makes new links not show up.

Alright, a few of the links I made today have reappeared randomly, I’m not sure what triggered it, but I’m almost certain that this is not working as intended.

Make sure your desktop is configured as “folder view” in the dialog where you set your wallpaper.

1 Like

it is, and it already has a bunch of links from when it was previously working as intended

This started happening after I made a second activity for the purpose of writing, and, after realizing that it didn’t give me a clean desktop with nothing on it in the new activity, I deleted the new activity. When I did so, it deleted all the links on the desktop, but they all showed in dolphin. I restarted pc and they showed up again, but this issue is still here now.

If you place something in the Desktop folder it doesn’t appear on the desktop?

that and linking to desktop via dragging there

Have you already checked if “folder view” is active on the dialog where you set the wallpaper?

yes and it is indeed checked

So does no one have a solution to this problem? At least a way to try and diagnose what is causing it?

are you able to click on that file name in dolphin? if yeah then click once, hold and drag that appimage onto the desktop. does that work?

That is how you link things to the desktop, yes. My problem is that it doesn’t actually show what I drag onto the desktop on the desktop until I restart my pc. I’ve no idea why it does that.

do you get that menu when you try to drag and drop that appimage or file on the desktop? just simply click link here and you should be good to go!

are you on the latest update? are you using any custom global themes ?

have you tried this?

check your basic DE settings like has the preview or folder view enabled on the desktop in the dropdown menu which you get when you right click on the desktop?

This doesn’t work, and I am on the latest update of kde, I’m using 5.15 kernel, and no I’m not using and custom global themes, I’m using breeze dark without the desktop layout from the theme.

do you mean you’re just using the system panel? or something else?


oh okay, well im runnin outta ideas, does that work when you create a new kde profile?

you mean a second user?

yes. you can try and set a new user in the users settings, try linking that appimage on the desktop then report back, in this way we can find if the issue is user profile specfic or not

it works perfectly on the other user