Lightzone installation

Im new to manjaro although being dealing with other linus distros more than 10 years. I really like it and just missed my prefered photo editing software, Lightzone. Found there is updated maintainned aur.archlinux Try to install it but Im not familiar with building this. Could anyone pls guide me to do it, step by step, like a I was a moron

Welcome to the forum! :wave:

Start here: Arch User Repository - Manjaro

many thanks, got an error
/home/bruno/lightzone/src/LightZone-4.2.3/linux/build.xml:37: The following error occurred while executing this line:
/home/bruno/lightzone/src/LightZone-4.2.3/lightcrafts/build.xml:129: exec returned: 2


Sorry for asking, but how are you installing lightzone and which package are you opting for?

Try from the terminal with the command:
pamac install lightzone

T+ = See you later

The log you provided wasn’t really the whole error message, so I gave it a shot myself.
Got the same error, but were able to figure it out;
pamac install jdk-openjdk then try again, and it should work.

But when installing lightzone from pamac it no longer informed you of the necessary dependencies

T+ = See you later

I originally tried it on a VM running the stable branch (using pamac-manager, not cli) and weren’t informed of any missing or necessary dependencies. When trying it on my production machine running the unstable branch, I get a choice in both cli and gui:

Choose a provider for java-environment:
1:  jdk-openjdk    16.0.1.u9-1      extra
2:  jdk11-openjdk  11.0.11.u9-1     extra
3:  jdk7-openjdk   7.u261_2.6.22-1  extra
4:  jdk8-openjdk   8.u292-1         extra

Builds fine on both using jdk-openjdk.

Yes pamac-gtk shows yes, the necessary dependencies

Click on the image to enlarge

As well as the pamac-cli

T+ = See you later

Please post the full build log. Since it could be fairly long, please use a pastebin service and link it here.

1 Like

lightzone is not in the pacman list, Im actually trying to install the AUR package

how can i get the repositories where lightzone is included?

I used lightzone for a long time and had the problem that a certain Java version was required as the system standard for lightzone, which led to a collision with some other java applications. May be that this problem has been resolved in the meantime. Since then, I have been using darktable without need java , in which, for example, the Ansel Adams zone mapper is also available. This is only mentioned here as an alternative in the event of problems.

Many thanks. I always found darktable a bit messy might be worth to give it a try now I switch to Manjaro as Im planned to stik to this lovery distro

pamac-cli is an AUR repo or a package?sorry abt my ignorance

The installation of the lightzone found in the aur repor wroked following given instructions but when trying to launch nothing happenned, got that from the terminal:

Starting LightZone version 4.2.3 …
with options :
openjdk version “1.8.0_292”
OpenJDK Runtime Environment (build 1.8.0_292-b10)
OpenJDK 64-Bit Server VM (build 25.292-b10, mixed mode)
Error: A JNI error has occurred, please check your installation and try again
Exception in thread “main” java.lang.UnsupportedClassVersionError: com/lightcrafts/platform/linux/LinuxLauncher has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(
at Method)
at java.lang.ClassLoader.loadClass(
at sun.misc.Launcher$AppClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(
at sun.launcher.LauncherHelper.checkAndLoadMain(

Your default Java version is too old, apparently. Switch your default to the newest version (currently 15 on the stable branch). See Java - ArchWiki

Thanks I have been eventually able to install it although get an msg on launching

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.