Lightdm won't fully boot - Linux kernel 4.19.0-3


#1

Hi all,

Recently upgrade to Linux kernel v4.19.0-3 (LTS), which FAILED for me! I’m forced to switch back to kernel v4.14.71.

After upgrade, I’m unable to use my system. Lightdm (XFCE) seems to start, but after that I can’t not do anything anymore. My system is basically locked and unresponsive. By background keeps gray, with a dot (?) in the middle. Lightdm only stays starting (but not started):
okt 28 21:37:41 melroy-pc systemd[1]: Starting Light Display Manager...

Boot-up video (kernel v4.19):

# Xorg -version
X.Org X Server 1.20.3

# lightdm --version
lightdm 1.28.0

See the full kernel log.

Nvidia driver v340 (linux419-nvidia-340xx)
XFCE v4.12
Manjaro v18

Grub boot settings (4.19):

EDIT, more info:

hwinfo --gfx 
13: PCI 200.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.378]
  Unique ID: B35A.W_PkaSFCR7B
  Parent ID: 3hqH._4Jk6Hys5IC
  SysFS ID: /devices/pci0000:00/0000:00:03.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: graphics card
  Model: "nVidia GT200b [GeForce GTX 275]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x05e6 "GT200b [GeForce GTX 275]"
  SubVendor: pci 0x1462 "Micro-Star International Co., Ltd. [MSI]"
  SubDevice: pci 0x1772 
  Revision: 0xa1
  Driver: "nvidia"
  Driver Modules: "nvidia"
  Memory Range: 0xf8000000-0xf8ffffff (rw,non-prefetchable)
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  Memory Range: 0xf6000000-0xf7ffffff (rw,non-prefetchable)
  I/O Ports: 0xac00-0xac7f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 28 (123226 events)
  I/O Port: 0x00 (rw)
  Module Alias: "pci:v000010DEd000005E6sv00001462sd00001772bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
  Driver Info #1:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #37 (PCI bridge)

Primary display adapter: #13

I can’t run mhwd because my system is then inresponsive (I do know that nvidia driver 340 for kernel 4.19 is used)

Help me!
Regards,
Melroy


[Stable Update] 2018-10-25 - Linux 4.19, KDE Plasma 5.14.2, Xorg 1.20.3, Gnome 3.30.2, Deepin, Grub
#2

Well, you can try to boot v18.0 which comes with XFCE 4.13. Didn’t had this issue at all.


#3

My system is working fine with XFCE (GTK2) and kernel 4.19.0-3…

inxi -Fxz of My system

System: Host: neon Kernel: 4.19.0-3-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1
Desktop: Xfce 4.12.4 Distro: Manjaro Linux
Machine: Type: Desktop System: ASUS product: All Series v: N/A serial:
Mobo: ASUSTeK model: MAXIMUS VI IMPACT v: Rev 1.xx serial:
UEFI: American Megatrends v: 1603 date: 08/15/2014
CPU: Topology: Quad Core model: Intel Core i7-4771 bits: 64 type: MCP arch: Haswell rev: 3
L2 cache: 8192 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28013
Speed: 1300 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 1201 2: 1258 3: 1205 4: 1220
Graphics: Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Micro-Star MSI driver: nvidia
v: 410.73 bus ID: 01:00.0
Display: x11 server: X.Org 1.20.3 driver: nvidia resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 410.73 direct render: Yes
Audio: Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Device-2: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel bus ID: 01:00.1
Sound Server: ALSA v: k4.19.0-3-MANJARO
Network: Device-1: Intel Ethernet I217-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f040
bus ID: 00:19.0
IF: eno1 state: up speed: 100 Mbps duplex: full mac:
Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel port: e000 bus ID: 03:00.0
IF: wlp3s0 state: down mac:
Drives: Local Storage: total: 3.17 TiB used: 667.06 GiB (20.6%)
ID-1: /dev/sda vendor: Intel model: SSDSC2BP240G4 size: 223.57 GiB
ID-2: /dev/sdb vendor: Intel model: SSDSC2BW240H6 size: 223.57 GiB
ID-3: /dev/sdc vendor: Western Digital model: WD3003FZEX-00Z4SA0 size: 2.73 TiB
Partition: ID-1: / size: 206.63 GiB used: 14.39 GiB (7.0%) fs: ext4 dev: /dev/sda2
ID-2: /home size: 2.67 TiB used: 652.66 GiB (23.9%) fs: ext4 dev: /dev/sdc1
ID-3: swap-1 size: 17.18 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdc2
Sensors: System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 33 C
Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0%
Info: Processes: 187 Uptime: 1m Memory: 15.60 GiB used: 911.7 MiB (5.7%) Init: systemd Compilers:
gcc: 8.2.1 clang: 7.0.0 Shell: bash v: 4.4.23 inxi: 3.0.27

And

neofetch details

██████████████████ ████████ user@neon
██████████████████ ████████ ----------
██████████████████ ████████ OS: Manjaro Linux x86_64
██████████████████ ████████ Host: All Series
████████ ████████ Kernel: 4.19.0-3-MANJARO
████████ ████████ ████████ Uptime: 3 mins
████████ ████████ ████████ Packages: 1057 (pacman)
████████ ████████ ████████ Shell: bash 4.4.23
████████ ████████ ████████ Resolution: 1920x1080
████████ ████████ ████████ DE: Xfce
████████ ████████ ████████ WM: Xfwm4
████████ ████████ ████████ WM Theme: Matcha-dark-sea
████████ ████████ ████████ Theme: Matcha-dark-sea [GTK2], Adwaita [GTK3]
████████ ████████ ████████ Icons: Vertex-Maia [GTK2], Adwaita [GTK3]
Terminal: xfce4-terminal
Terminal Font: Monospace 12
CPU: Intel i7-4771 (4) @ 3.700GHz
GPU: NVIDIA GeForce GTX 1060 6GB
Memory: 1009MiB / 15977MiB


#4

I’m using different version of the nvidia driver (340) because of my older card: GTX 275.


#5

I’m using Manjaro v18 it says Manjaro Hello…


#6

My system is working fine with XFCE (GTK2) and kernel 4.19.0-3…

And my system is not working fine…


#7

Without joking, any idea how to find the root cause? Since my kernel.log doesn’t say too much.


#8

I encounter the same problems with Linux kernel 4.18.16-1 actually. Which installs:

linux418
linux418-nvidia-340xx

Similar packages as for 419. So only 4.14.78 works for me afaik.


#9

Follow-up: Although my system is reporting I’m using Manjaro v18 I do see differences in layout in comparison with the live USB.

So I booted up the live USB Manjaro v18. Which indeed uses kernel v4.19. And this works…!?

As you could see I selected non-free in grub, just to be the same as possible:

So back to my installed Manjaro on disk. I though maybe I forgot to update something??
Manually running of pacman: sudo pacman -Syyu
Leads to a message ‘nothing to do, up to date’.


#10

Aha… I’m using Compton to fix screen tearing. Could that be the issue? Compton config:

backend = "glx";
paint-on-overlay = true;
glx-no-stencil = true;
vsync = "opengl-swc";
unredir-if-possible = true;

# Shadow
shadow = true; # Enabled client-side shadows on windows.
no-dock-shadow = true; # Avoid drawing shadows on dock/panel windows.
no-dnd-shadow = true; # Don't draw shadows on DND windows.
clear-shadow = true; # Zero the part of the shadow's mask behind the window (experimental).
shadow-radius = 7; # The blur radius for shadows. (default 12)
shadow-offset-x = -7; # The left offset for shadows. (default -15)
shadow-offset-y = -7; # The top offset for shadows. (default -15)
shadow-exclude = [
 "n:e:Notification",
 "n:e:Docky",
 "g:e:Synapse",
 "g:e:Conky",
 "n:w:*Firefox*",
 "n:w:*Chromium*",
 "n:w:*dockbarx*",
 "class_g ?= 'Cairo-dock'",
 "class_g ?= 'Xfce4-notifyd'",
 "class_g ?= 'Xfce4-power-manager'",
 "class_g ?= 'Notify-osd'",
 "_GTK_FRAME_EXTENTS@:c"
];

# Opacity
detect-client-opacity = true;

# Window type settings
wintypes:
{
 tooltip = { shadow = false; };
};