Lightdm webkit theme fails to load


#1

Hey community,

I was just going through the themes for lightdm and landed on a new theme, Litarvan
Did anyone get it installed correctly and is it working?
I configured everything and restarted lightdm service and got the usual error on webkit theme to load any fallback theme instead!
Does any one know how to sove this problem?


#2

Is this in the repos? I don’t see it with pacman -Ss litarvan.


#3

no, its in the AUR, I just wondered if anyone tried it out


#4

Ah, righty.


(moved from #general-discussion to #technical-issues-and-assistance:aur)


#5

Start by debugging it

  • Make sure you are using lightdm-webkit2-greeter itself by looking at the file /etc/lightdm/lightdm.conf and make sure greeter-session= was set to lightdm-webkit2-greeter and uncommented
#xdmcp-key=
#unity-compositor-command=unity-system-compositor
#unity-compositor-timeout=60
greeter-session=lightdm-webkit2-greeter
#greeter-hide-users=false
#greeter-allow-guest=true
#greeter-show-manual-login=false
#greeter-show-remote-login=true

#6

This theme looks nice. I am also using lightdm-webkit2-greeter theme https://github.com/FallingSnow/lightdm-webkit2-material2 and didn’t face any issues with it.

I’ll try litarvan and will let you know.


#7

Ok, so theme is working fine, just tested it. Make sure lightdm-webkit2-greeter is installed and then follow @thefallenrat above post. He has covered pretty much everything :slight_smile:

EDIT: Once you figure out your issue then you can use manjaro logo on splash screen instead of arch logo. Just cd to /usr/share/lightdm-webkit/themes/litarvan/images and sudo wget https://raw.githubusercontent.com/manjaro/artwork-logo/master/logo.svg . Then replace arch.svg with logo.svg in /usr/share/lightdm-webkit/themes/litarvan/index.html. Thank me later :wink:


#8

Is litarvan working on your system?

How did you install, through yaourt or from the github?
My screen just blinks with an Archlinux logo on it and shows error…


#9

yes, it’s working fine. I installed it from AUR. Tell us what you did from the start then may be we can figure out. Also try some other webkit2 theme to check if it’s some generic issue.


#10

I installed it normally through AUR and changed the config under

/etc/lightdm/lightdm.conf
&
/etc/lightdm/lightdm-webkit2-greeter.conf

I have previously tried all the available themes in AUR and most of them worked including the google, clean, material, manjaro-themes, ccontemporary, etc


#11
  1. Make sure you are using latest packages.
  2. Check if you have webkit2gtk engine installed.
  3. You can also try to run lightdm --test-mode --debug (do not run with sudo) and see what are the errors then resolve them.
  4. Also check /var/log/lightdm/seat0-greeter.log after system restart.

#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.