Lightdm manjaro cinnamon 17.1.9

#21

Thank you fhdk I was suspecting something along those lines but I thought it was strange to suddenly change as I never had issues previously.

I changed my root password as per your suggestion but unfortunately that did not fix the problem. I am in the same situation as before. The first password attempt fails, the second attempt works but nothing ever opens and running it through the terminal doesn’t give any hints.

#22

For clearing possible misunderstanding

root = su = superuser
sudo password is the same as the current user’s password if is in group wheel

And AFAIR

requires sudo password for me.

Translation:
Underlined: Requires authentication for one of the below users
Rectangle: Select user…

Edit: I also have different passwords for root and user, on purpose :smirk:

1 Like
#23

A lot of things change and it is often the little things that makes you go insane because they are understandable.

AS @petsam do - I also do - on purpose two distinct passwords. I initially started doing so after doing research on a similar issue and ended writing a howto about it.

But as it is not the case here - I will do some more thinking.

2 Likes
#24

And you are right - that is how we normally see it- but lightdm-settings has undergone some changes to reflect how the settings are saved. Even for lightdm itself, some of the posts on the linuxmint github on the slick-greeter seems to indicate that some changes has been or will be implemented.

The same thing that has caused confusion and hair pulling for @oberon.

When I researched on what caused the slick-greeter to - after first login - to consequently use the users chosen wallpaper ignoring conf, I installed the lightdm-settings and the lightdm-settings - on my openbox configuration - insisted on my root password before it would launch.

Furthermore I discovered that the lightdm-settings is confused and write settings in the wrong place. That I have noted in out github issue mention by oberon.

Which is why I suggested the password change - to ensure - that this was not the case :).

2 Likes
#25

i’m experiencing this with i3 too

#26

Just a follow up on the double password sandwich.

superuser != root

Today I had the issue once again.

My VirtualBox extension pack required an update from .8 to .10.

I download the file from the website and open it with VirtualBox.

When installing the extension pack it requires administrative password.

OK - so I input my usual superuser password - after a few seconds it prompts me back - not good enough.

OK - I then input my - on purpose different - root password - and then the installation succeeds.

So superuser does not equal root OR some apps asks explicitly for user ID 0.

https://wiki.manjaro.org/Linux_Security

1 Like
#27

There is a lot to study about su, sudo and root before teaching others IMHO.
In short

  • root is a user
  • su and sudo are commands
  • There is nothing like superuser, just a friendly alias to a meaning that all should understand the same, which doesn’t happen in a group of various levels of knowledge users.
  • Administrative, administrators are words originating/usually used in WinWorld
  • su means Substitute User and defaults to root user but can be used to any other user
  • and a lot more that can be studied at Archwiki like
    Users and groups
    Sudo
    Su
    Security

Cheers! :zipper_mouth_face:

2 Likes
#28

I know and as stated

which is confusing even to me.

As stated I have several times been forced to use the password for root user to execute a change which leads to the conclusion

Either superuser does not equal root OR some apps asks explicitly for user ID 0.

This is the experience I try to convey so others might skip the confusion.

Quote from wiki page:

It is a common perception that root = su = superuser and that will be correct for most situations.

However situations exist where the system will ask for your root password and not your superuser password and you have no way of knowing which one is asked for.

You will at times find yourself in a situation where you are absolutely sure you are inputting the correct password and the system refuses to comply and thereby drive you crazy.

If you make a habit of having different passwords for superuser and root you will just have to switch to the other and the system will comply.

#29

The confusion is created from wrong assumptions, IMHO.
If anyone reads the above posted links and still has a confusion then this is an issue to be reported upstream.

#30

What do you call a user when assigned such group membership that allows the user to make system wide changes without the need of the root password but using sudo?

They are not root user nor are they ordinary users - what should we call them?

https://www.definitions.net/definition/SUDO

I can rephrase it

EITHER user with sudo rights does not equal root OR some apps asks explicitly for user ID 0

Which is what I experience one time after another.

#31

A user with elevated privileges

sudo allows a system administrator to delegate authority to give certain users—or groups of users—the ability to run commands as root or another user while providing an audit trail of the commands and their arguments.

From Archwiki
Sudo is an alternative to su for running commands as root. Unlike su, which launches a root shell that allows all further commands root access, sudo instead grants temporary privilege escalation to a single command. By enabling root privileges only when needed, sudo usage reduces the likelihood that a typo or a bug in an invoked command will ruin the system.

“Superuser” is a general name in all OSes. It means only what the running OS developers suppose to be.

From Wikipedia

Depending on the operating system (OS), the actual name of this account might be root, administrator, admin or supervisor. In some cases, the actual name of the account is not the determining factor; on Unix-like systems, for example, the user with a user identifier (UID) of zero is the superuser, regardless of the name of that account;[1] and in systems which implement a role based security model, any user with the role of superuser (or its synonyms) can carry out all actions of the superuser account.

Edit: A graphical explanation

#32

But now it is only a discussion of my chosen wording.

The actual problem is still present.

In certain - not definable situations - it is not enough if the user has sudo rights - to enter the users password - it has to explicitly be the password of the root user.

When a user face such situation and have chosen to have identical passwords for the two different accounts then a confusion will rise since the user will be sure that the correct password has been entered.

On the other hand - having different passwords will ensure that the user can be aware that it is in fact the root password which is required.

Why such situations arise is not the issue - however resolving the issue is.

Which is why I have tried to explain it in a wiki entry for others to benefit from.

It is not a tutorial on subtle differences in the understanding of root/superuser/user differentiating but an approach to a factual issue several users - including my self - faces from time to time.

Previously I used to go nuts when my password wasn’t accepted though it was correct. Now - I switch to the root password and task accomplished.

It is a simple working solution to an otherwise really annoying situation.

#33

@eyzer24
I managed to “fix” this accidentally. I noticed there were two packages called lightdm setting in pamac. One was already installed and one was not, the one that wasn’t installed was newer so I installed it. It opened correctly when you input your password so I uninstalled the other one and ran:

systemctl enable lightdm.service
systemctl start lightdm.service

I still have no idea why it wasn’t working but at least it is now.

Preinstalled not working package:


Working version:
https://launchpad.net/lightdm-gtk-greeter-settings

#34

Okay maybe I got ahead of myself because something is still clearly wrong. While you can now open the “Login Window” entry under System Settings with your password you can’t change anything.

As a test I tried to remove the “Keyboard Layout” indicator, despite being able to delete and save my configuration Keyboard Layout was not removed from the login screen.

#35

We only have one package in the repos:
community/lightdm-settings

edit: maybe are you talking about the version from the AUR? I would not recommend you use that one…

I have just now updated it again to the latest git-snapshot. They have recently moved to pkexec and the old version created an error with sudo. Seems that was the issue with asking for a password twice and then not opening.
The issue with background settings not being respected I was able to fix with a patch.
I don’t know about your other settings… Maybe try removing your possible screwed up config file:
sudo rm /etc/lightdm/slick-greeter.conf
and then create a fresh one by using lightdm-settings (which is called ‘Login Window’ in the menu, yes)
Current updated version is 1.1.4.r4.gf25d985

1 Like
#36

I have just double-checked with both i3 and cinnamon and everything seems to work flawlessly for me.
I can launch lightdm-settings with pkexec and all the settings, be it background image or the panel items can be configured without problem.

#37

i’m getting this error, after trying what @oberon has suggested, via i3

Unable to init server: Could not connect: Connection refused

(yad:4159): Gtk-WARNING **: 22:17:53.056: cannot open display: 
triggered empty
#38

What exactly are you trying to do? and how?

#39

i am trying to get into lightdm-settings

pkexec --user adhunter lightdm-settings

now i’m thinking i may have misunderstood your post

#40

In a Desktop Environment like Cinnamon you can just use the launcher / menu-entry.
When you want to launch lightdm-settings from the terminal or with dmenu, use this command:
pkexec lightdm-settings