LightDM login loop annoying but [solved]

xfce
lightdm

#1

I had the issue described in this older post:

Can be quite annoying.
In short, I have the standard Manjaro install with XFCE, lightdm. And there was an error logging into the XFCE environment, such that the lightdm greeter just prompts me to login again (even though my password is correct). Below are details of my solution.

Still not sure the exact error that causes the lightdm greeter failure. The reference post notes

I would like to point out that the problem of login loop isn’t caused by this particular error. The login loop arises when there’s some error in starting the desktop environment.

In my case, some of the clues were:

  • My other Manjaro machine also has XFCE and lightdm but doesn’t have the problem.
  • My other login on the affected machine - in the manjaro/xfce/lightdm environment - also doesn’t have the problem. (this is the way I could access the files to make the fixes).

Solution:
in ~/.config/xfce4/xfconf/xfce-perchannel-xml/
xfce4-session.xml

I changed values back to something closer to the default. (using the no-problem machine as a reference).

Bottom of xfce4-session.xml (in the environment where error was occurring):

<property name="splash" type="empty">
  <property name="Engine" type="string" value="balou"/>
</property> 
<property name="shutdown" type="empty">
  <property name="LockScreen" type="bool" value="false"/>
</property> 

Bottom of xfce4-session.xml (in the environment which didn’t get the login loop, and in the fix/workaround I applied to the affected environment):

<property name="splash" type="empty">
  <property name="Engine" type="empty"/>
</property> 
<property name="shutdown" type="empty">
  <property name="LockScreen" type="bool" value="false"/>
</property> 
<property name="chooser" type="empty">
  <property name="AlwaysDisplay" type="bool" value="true"/>
</property> 

Takeaways:

  • having a spare login / spare OS / way to access your data can be a lifesaver.
  • The final stanza “AlwaysDisplay” set to “true” seems smart in retrospect as I have the option there to either re-start a saved xfce session, or to begin a new one. Didn’t need a new one here, but would have been a workaround in some situations. In the absence of having the 2nd login (which normally I do not have), I would have been more stuck. Maybe I could have ssh’ed in.
  • having multiple Manjaro boxen also helped

Manjaro 18.0 lxde stopped booting with lightdm error, after the latest update
[Stable Update x32] 2018-05-27 - Big update: Xorg 1.20, GCC 8.1.0, kernels, KDE and Plasma, LibreOffice, NVIDIA driver EOL
Can't log in after the last 32-bit update