Lightdm fails to start with only the lenovo logo shown

I'm having some issues getting to the Deepin greeter. Once the boot process gets past grub, the lenovo logo is shown once, then twice, with the screen hanging at that second instance. After some searching I suspect that it has something to with lightdm failing. However none of the advice I've found has provided me with specific help. I also suspect that it may have to do with the checking of the second box in the manjaro graphical settings, which installs the other driver (I assume, though which one it is I'm not sure). I've attached many Screenshots based on the help I've been using.

Here are the screenshots I took.

https://mega.nz/#F!Dhd0mC6K!t18WfiVwwtRQZIqDfmXXpw

Hi admdb,

I've added some screenshots to the original post.

you got a few things going on but xorg not knowing which driver to use is probably why lightdm wont start. either that or the screen is on strike until you clean it :laughing:.

get yourself to a TTY, seems like you already know how. uninstall both drivers

sudo mhwd -r pci video-linux
sudo mhwd -r pci video-vesa

delete any video related .conf files in these directories that may be left behind

/etc/X11/mhwd.d/
/etx/X11/xorg.conf.d/

install video-linux (not video-vesa)

sudo mhwd -i pci video-linux

#if that finishes without any issues

systemctl reboot

Thank you, everything works perfectly now. That's what I get for trying to install the non-free drivers to fix a screen tearing issue.

1 Like

theres a TearFree option for the i915 driver which is the driver your using.

see if there is already a video configuration in /etc/X11/xorg.conf.d/, if there is it's probably named 90-mhwd.conf or 20-intel.conf . if there is you can edit it and add the tearfree option line in the example below.

if there is not a current video related .conf file in there, create one.

sudo nano /etc/X11/xorg.conf.d/20-intel.conf
copy/paste these contents

#/etc/X11/xorg.conf.d/20-intel.conf 
 
    Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "TearFree" "true"
     EndSection

save/exit, reboot

Again, thank you. Worked magnificently. Can you tell exactly what this does? And why this setting isn't enabled by default?

yw, glad it worked out.:+1:

prevents screen tearing.

i honestly dont know but it often needs to be added to fix tearing/vsync issues.

Is this the non-free driver? I ask because I'm not sure if I will need to try installing it later when I'd like to do some light gaming. I tried the "sudo mhwd -a pci nonfree 0300" command, however this was skipped because it was the one already installed.

no, the intel driver is included in video-linux (free drivers). the actual driver package it uses for intel is xf86-video-intel

i dont think there is a nonfree driver for intel so it probably didnt install anything.

the video-linux mhwd driver package includes the free/open drivers for a bunch of various hardware

in the future, not that it should be needed but:

sudo mhwd -i pci video-linux
#OR
sudo mhwd -a pci free 0300