Lightdm fails to start after update

+1 this error made my system unbootable tonight after a routine update. Choosing different kernels from the boot menu didn’t help. I had to timeshift --restore a snapshot from 3 days ago to return to normal.

journalctl -xb didn’t show anything obviously helpful around lightdm messages, just something about exiting with code 1. If this happens again on my next update, what should I watch out for to help troubleshoot?

Same here. Journal says there is an api mismatch between the kernel and nvidia driver

Same here timeshift btrfs snapshots saved my @ss
I’m currently trying to figure it out

Thanks louson, that could be it. I’m running with nvidia driver also.

If there’s a straightforward way to upgrade and try an alternative version of the driver, I can try that… identifying which versions broke compatibility could help with a fix.

I don’t know if I can reproduce exactly what I did to fix my issue…

however I’m up and running and what I think worked was:

  1. removed lightdm
    pamac remove lightdm

  2. renamed the current X11 configuration
    mv /etc/X11 /etc/X11_notworking

  3. installed wayland
    pacman -S plasma-wayland-session

  4. Installed a wayland ready version of gdm
    pamac install gdm3setup

  5. relinked the default display manager to
    rm /etc/systemd/system/display-manager.service

    ln -s /usr/lib/systemd/system/gdm.service /etc/systemd/system/display-manager.service

  6. I might have enabled gdm
    systemctl enable gdm.service

  7. Then rebooted :

  8. Then selected my manjaro xfce login session right after clicking my user (gear icon on the bottom right corner)

Went into the snapshot again prior to the update to reproduce the issue and the fix…
I ran the process of my previous post but skipped step 3 and went with the regular gdm this time…
I got the gdm welcome screen, however I wasn’t fully able to login to xfce,
so this time I also opened

and edited these lines




got the tip from

BTW I was running an amd card

  Device-1: AMD Oland [Radeon HD 8570 / R5 430 OEM / R7 240/340 / Radeon 520

however issue was still there when I fell back to the onboard Intel graphics card… so I knew that wasn’t the issue.

Thanks Mikesco3 for all your comments, I may end up having to switch to wayland, but I’m seeing that as a last resort because I really value stability on this old system.

Feeling bold today, I gave updating another try. Failed and had to timeshift again. :frowning:

I really suspect some driver incompatibility in the upgraded dependencies (at least for my case). I saw this warning when I applied the update in pamac-manager:

Warning: installing nvidia-utils (495.44-4) breaks dependency ‘nvidia-utils=470.63.01’ required by linux512-nvidia
Add linux512-nvidia to remove

Then journalctl -xb on failed boot shows:

Nov 26 15:07:47 skyglass systemd-modules-load[433]: Failed to find module ‘nvidia’
Nov 26 15:07:47 skyglass systemd-modules-load[433]: Failed to find module ‘nvidia-drm’

But I have no idea why simply trying to update the system does this. Too many things changing at once, something breaks. Anyway, it’s a real problem for me as a Manjaro main user. When a rolling release breaks your system, you can’t upgrade other packages – by design. Any experts want to suggest some debugging steps? I’m a pro software engineer, I can generally find my way around, I just don’t have the deep Linux knowledge about which logs to check, commands to run, etc. My hope is to be able to “simply update” from & to a working system with no major changes.

I don’t have a solution, but I did run into this when trying to fix my ‘broken USB’ problem. After downgrading the 5.10 kernel to 5.10.70 I got this error when trying to startup. I’m guessing I needed a different NVIDIA version.

Found the logs. It is the new nvidia driver!

My old GPU is only “supported through the NVIDIA 470.xx Legacy drivers”… “The 495.44 NVIDIA driver will ignore this GPU.” … and then X finds no display.

So basically, support for my system is dropped and I have to keep the 470.xx driver. Now I just have to figure out how to tell the system to lock the driver at 470.xx instead of upgrading to 495.44…

Indeed an almost-fully updated system works, as long as it keeps using the NVIDIA 470.xx driver and this hack is applied.

So I got it running, but it seems fragile. For some reason, the 5.12 kernel stayed at 470.xx while other kernels upgraded nvidia drivers to 495.xx.

Is the rolling release rolling on after my system got knocked off the back of the wagon? What’s the general solution when you must hold back a critical package version like the GPU driver?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.