LightDM enters infinite start loop at boot after latest update to 5.10 (nvidia 460)

Hello, after a routine system update to kernel 5.10, my system has turned unusable.

The system starts booting ok, however once it gets to starting LightDM, the system enters an infinite loop trying to start it but failing every 3 seconds.

What’s most annoying is that I can’t even switch to a secondary console with Alt-F2 in order to investigate since the restart returns me back to the primary console.

I managed to boot into a Live Manjaro and with chroot managed to downgrade back to 5.9. However the problem persists. From the logs (see below), it looks like the actual problem is with the updated Nvidia drivers (455->460 which is now the default for linux510-nvidia).

Is my hunch about the nvidia drivers correct? Is there anything I can do to fix this apart from waiting for the drivers to be patched?

/var/log/lightdm/lightdm.log

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.30.0, UID=0 PID=3975
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /var/lib/flatpak/exports/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
[+0.00s] DEBUG: Monitoring logind for seats
[+0.00s] DEBUG: New seat added from logind: seat0
[+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.00s] DEBUG: Seat seat0 has property CanMultiSession=no
[+0.00s] DEBUG: Seat seat0: Starting
[+0.00s] DEBUG: Seat seat0: Creating greeter session
[+0.00s] DEBUG: Seat seat0: Creating display server of type x
[+0.00s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.00s] DEBUG: Using VT 7
[+0.00s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.00s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.00s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.00s] DEBUG: XServer 0: Launching X Server
[+0.00s] DEBUG: Launching process 3981: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.00s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.00s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.01s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.01s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.01s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+1.32s] DEBUG: Got signal 15 from process 1
[+1.32s] DEBUG: Caught Terminated signal, shutting down
[+1.32s] DEBUG: Stopping display manager
[+1.32s] DEBUG: Seat seat0: Stopping
[+1.32s] DEBUG: Seat seat0: Stopping display server
[+1.32s] DEBUG: Sending signal 15 to process 3981
[+1.32s] DEBUG: Seat seat0: Stopping session
[+1.32s] DEBUG: Seat seat0: Session stopped
[+3.94s] DEBUG: Got signal 10 from process 3981
[+3.94s] DEBUG: XServer 0: Got signal from X server :0
[+3.94s] DEBUG: XServer 0: Connecting to XServer :0
[+4.60s] DEBUG: XServer 0: Error connecting to XServer :0
[+4.70s] DEBUG: Process 3981 terminated with signal 6
[+4.70s] DEBUG: XServer 0: X server stopped
[+4.70s] DEBUG: Releasing VT 7
[+4.70s] DEBUG: XServer 0: Removing X server authority /run/lightdm/root/:0
[+4.70s] DEBUG: Seat seat0: Display server stopped
[+4.70s] DEBUG: Seat seat0: Stopped
[+4.70s] DEBUG: Display manager stopped
[+4.70s] DEBUG: Stopping daemon
[+4.70s] DEBUG: Exiting with return value 0

/var/log/lightdm/x-0.log

X.Org X Server 1.20.10
X Protocol Version 11, Revision 0
Build Operating System: Linux Manjaro Linux
Current Operating System: Linux jarvis 5.10.13-2-MANJARO #1 SMP PREEMPT Sat Feb 6 10:28:21 UTC 2021 x86_64
Kernel command line: BOOT_IMAGE=/@/boot/vmlinuz-5.10-x86_64 root=UUID=941f84a5-1e4b-47cf-8730-5fc2d3352d2f rw rootflags=subvol=@ cryptdevice=UUID=2277d9cd-bd93-4a8a-9e32-fc803d5f3c4f:luks-2277d9cd-bd93-4a8a-9e32-fc803d5f3c4f:allow-discards root=/dev/mapper/luks-2277d9cd-bd93-4a8a-9e32-fc803d5f3c4f resume=/dev/mapper/luks-2277d9cd-bd93-4a8a-9e32-fc803d5f3c4f apparmor=1 security=apparmor udev.log_priority=3
Build Date: 16 December 2020  10:33:32PM
 
Current version of pixman: 0.40.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb 10 14:37:21 2021
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
(EE) 
(EE) Backtrace:
(EE) 0: /usr/lib/Xorg (xorg_backtrace+0x53) [0x55825ee77f63]
(EE) 1: /usr/lib/Xorg (0x55825ed31000+0x151da5) [0x55825ee82da5]
(EE) 2: /usr/lib/libc.so.6 (0x7f8fd55ba000+0x3cf80) [0x7f8fd55f6f80]
(EE) 3: /usr/lib/libnvidia-glcore.so.460.39 (0x7f8fb20f8000+0xe42041) [0x7f8fb2f3a041]
(EE) 4: /usr/lib/libnvidia-glcore.so.460.39 (0x7f8fb20f8000+0xdd3c03) [0x7f8fb2ecbc03]
(EE) 5: /usr/lib/nvidia/xorg/libglxserver_nvidia.so (0x7f8fc14ac000+0x656545) [0x7f8fc1b02545]
(EE) 6: /usr/lib/nvidia/xorg/libglxserver_nvidia.so (0x7f8fc14ac000+0x89f7a6) [0x7f8fc1d4b7a6]
(EE) 
(EE) Segmentation fault at address 0x10
(EE) 
Fatal server error:
(EE) Caught signal 11 (Segmentation fault). Server aborting
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(II) AIGLX: Suspending AIGLX clients for VT switch
(EE) Server terminated with error (1). Closing log file.

mhwd -li

 Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2020.11.30               false            PCI

There was an issue with extramodules and 5.10 kernel. Login to a TTY and update again:

CTRL + ALT + F3
<login>
sudo pacman -Syyu
<reboot>

As I said, I can not open a second TTY as I always get immediately returned to kernel log upon the restart of lightdm. Yesterday I tried the pacman update from chroot in Live image but it does not seam to have helped. I will try again today. Will let you know the results.

Hold the shift key while booting - when grub menu appears - press e to edit the kernel command line.

Append the digit 3 as an argument to the kernel command line (boots to CLI), press F10 to continue booting, login and issue a system update.

Ok, I managed to solve the issue now by reverting my root to one of my earlier snapshots and doing an upgrade from there again.

It looks like during my initial attempts at fixing the issue, something broke and the suggested pacman -Syyu could not fix it. However after rolling back and trying to update again, the update now fixed it.

Thank you all so much for your suggestions and support.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.