Lightdm and systemd-backlight fails to load on boot with fresh install of Manjaro XFCE

Hello there. First of all, I’m new here, this is my brand first post here, so, if I do something wrong, just tell me. That said, here’s my problem:

Yesterday I’ve installed the last version of Manjaro XFCE (on the stable release) on my laptop. The Live USB booted and did its things with no problems. But after restarting it gets stuck, outputing two lines saying Light Display Manager failed to load and the same thing for Systemd-backlight…

I’ll leave here the output with the details of systemctl on both services:

× systemd-backlight@backlight:acpi_video1.service - Load/Save Screen Backlight Brightness of backlight:acpi_video1
     Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static)
     Active: failed (Result: exit-code) since Tue 2021-09-07 15:58:30 CEST; 1h 40min left
       Docs: man:systemd-backlight@.service(8)
    Process: 1039 ExecStart=/usr/lib/systemd/systemd-backlight load backlight:acpi_video1 (code=exited, status=1/FAILURE)
   Main PID: 1039 (code=exited, status=1/FAILURE)
        CPU: 6ms

sep 07 15:58:30 linux-legion-5 systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:acpi_video1...
sep 07 15:58:30 linux-legion-5 systemd-backlight[1039]: Failed to get backlight or LED device 'backlight:acpi_video1': No such device
sep 07 15:58:30 linux-legion-5 systemd[1]: systemd-backlight@backlight:acpi_video1.service: Main process exited, code=exited, status=1/FAILURE
sep 07 15:58:30 linux-legion-5 systemd[1]: systemd-backlight@backlight:acpi_video1.service: Failed with result 'exit-code'.
sep 07 15:58:30 linux-legion-5 systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video1.
× lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Tue 2021-09-07 16:23:22 CEST; 21s ago
       Docs: man:lightdm(1)
    Process: 1049 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
   Main PID: 1049 (code=exited, status=1/FAILURE)
        CPU: 147ms

sep 07 16:23:22 linux-legion-5 systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
sep 07 16:23:22 linux-legion-5 systemd[1]: Stopped Light Display Manager.
sep 07 16:23:22 linux-legion-5 systemd[1]: lightdm.service: Start request repeated too quickly.
sep 07 16:23:22 linux-legion-5 systemd[1]: lightdm.service: Failed with result 'exit-code'.
sep 07 16:23:22 linux-legion-5 systemd[1]: Failed to start Light Display Manager.

I’ve noticed that if I turn off completely the system and turn it on again it fails, but if you only restart it will not fail at all… True it is that I can make it work manually with systemctl start lightdm.service.
I’ve got a workaround at the moment with LXDM, but I would prefer having back LightDm.

With this systemd-backlight: I don’t think is making the boot process stop, nor having problems with the brightness at all… Is it serious?

Thanks in advance to all of you. I’m looking forward for answers :slight_smile:

Hello @MrLinuxOsu :wink:

I would think that the gpu is not initialized properly at a cold boot. Maybe try to disable “fast boot” or set it to “full initialization” at your UEFI.

@megavolt think I don’t have such option on UEFI…? I’ve tried to look up on all settings in UEFI but I can’t seem to find it. Tried doing a search in Google, but nothing…

Could you share what system you have?

inxi -Fazy


$ inxi -Fazy
  Kernel: 5.13.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=576a151f-5f4c-48b2-922c-3d4f090d990e rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 1 
  dm: LightDM 1.30.0, LXDM Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 82B5 v: Lenovo Legion 5 15ARH05 
  serial: <filter> Chassis: type: 10 v: Lenovo Legion 5 15ARH05 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO 
  v: EUCN31WW date: 01/01/2021 
  ID-1: BAT0 charge: 49.5 Wh (60.0%) condition: 82.5/80.0 Wh (103.1%) 
  volts: 15.8 min: 15.4 model: SMP L19M4PC1 type: Li-poly serial: <filter> 
  status: Unknown cycles: 40 
  Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600106 cache: L2: 4 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 92664 
  Speed: 1397 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz): 
  1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 9: 1490 
  10: 1515 11: 1397 12: 1397 13: 1397 14: 1398 15: 1397 16: 1397 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU117M vendor: Lenovo driver: nvidia v: 470.63.01 
  alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f99 
  class-ID: 0300 
  Device-2: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 05:00.0 
  chip-ID: 1002:1636 class-ID: 0300 
  Device-3: Syntek Integrated Camera type: USB driver: uvcvideo bus-ID: 1-3:2 
  chip-ID: 174f:244c class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: amdgpu,nvidia unloaded: modesetting,nouveau failed: ati 
  alternate: fbdev,nv,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.13-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.2.1 direct render: Yes 
  Device-1: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
  driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 05:00.5 
  chip-ID: 1022:15e2 class-ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.13-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.34 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 2000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: eno1 state: down mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 2000 
  bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280 
  IF: wlp4s0 state: up mac: <filter> 
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-3:3 
  chip-ID: 8087:0029 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Local Storage: total: 1.84 TiB used: 26.95 GiB (1.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital 
  model: PC SN730 SDBPNTY-1T00-1101 size: 953.87 GiB block-size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD 
  serial: <filter> rev: 11170001 temp: 40.9 C scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Western Digital 
  model: WD Elements SE 25FE size: 931.48 GiB block-size: physical: 512 B 
  logical: 512 B type: N/A serial: <filter> rev: 1026 scheme: GPT 
  ID-1: / raw-size: 255.75 GiB size: 251.24 GiB (98.23%) 
  used: 26.91 GiB (10.7%) fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:5 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 44.6 MiB (46.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  Alert: No swap data was found. 
  System Temperatures: cpu: 57.4 C mobo: N/A gpu: amdgpu temp: 41.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 370 Uptime: 6m wakeups: 1 Memory: 15.01 GiB used: 2.4 GiB (16.0%) 
  Init: systemd v: 248 tool: systemctl Compilers: gcc: 11.1.0 Packages: 
  pacman: 1086 lib: 306 flatpak: 0 Shell: Bash v: 5.1.8 
  running-in: xfce4-terminal inxi: 3.3.06 

It should be a Nvidia Geforce 1650, but it doesn’t display…?

Ah I see… a hybrid GPU…

It loads first amdgpu and then nvidia:

So it must be the so called “timing issue”. Try this:

1 Like

I think it was solved… I’m going to put back the lightdm.service and see if it works…
BTW, some weeks ago I tried installing Manjaro GNOME, and nothing of this happened…

Damn! It’s working! I don’t have any issue with the LightDM nor the driver :smiley:
I really appreciate you answering this fast! Thank you very much!

1 Like

Nice to know :+1: Seems GDM is now improved for hybrid GPUs.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.