LightDM and NetworkManager fail to start after update

Both my laptops are fine after the update.

But on my ancient Dell Optiplex 380, NetworkManager and LightDM suddenly failed to start. It's running kernel 5.3.

journalctl -u NetworkManager:
https://pastebin.com/jqYY3B7q

journalctl -u lightdm:
https://pastebin.com/EHKfbF7d

Do they restart from TTY?
Is Xorg not working (startx fails) as well?
Have you set lightdm config option "Wait-for-graphical-target" (or similar)?

Nope, both failed to start in a tty ever since I've completed the update. sudo pacman -Syyu ran successfully, then I rebooted.

journalctl -xe | grep NetworkManager:
https://pastebin.com/YFJDDWhT

journalctl -xe | grep lightdm
https://pastebin.com/LyHyU4WL

Nope, I did not set any lightdm config option "Wait-for-graphical-target" (or similar).

Incidentally, I just realized my old Logitech webcam failed too after the update.

journalctl -xe | grep v4l
https://pastebin.com/DBzTXhgg

Have you tried older LTS kernels such as 4.19 & 4.14.

Also please post:

inxi -Fxxxz

If you are using the GTK greeter - have you tried the slick-greeter and vice-versa?

I ran into that problem earlier last week. Solution here.

Since I can't boot and can't connect to the internet from the installed system itself, I had to manjaro-chroot -a into it, from there every time I tried to change the kernel this happens, I tried looking around but I'm not quite sure what to do:

https://hastebin.com/orenokugal.shell

Also the output of inxi -Fxxxz (from within the chroot):

https://hastebin.com/acerarikak.makefile

Sorry for the extremely late reply, I've been too busy and too tired the past 2 weeks.

Thanks, but this computer does not have anything Nvidia.

Sorry for the late reply.

Forum kindly sponsored by