Librewolf won't launch at all

I use Librewolf as my main browser on Manjaro but it won’t launch after the recent update. I looked everywhere there isn’t any solution. If I have to wait until a later time I will. I installed from librewolf-bin.

backup/rename your current profile and start with a fresh profile.

How would I do that? I tried reinstalling it a few times.

config is stored in your home folder. In FF the profiles are in .mozilla (hidden folder) in librewolf. I don’t know as I don’t use LibreWolf. My understanding is that LibreWolf is just FF with heavily modified, custom preferences (prefs.js) . If for some reason folders in home are hidden- ctrl-h

I gave a shot. But nothing happens the program is installed but when I click Librewolf it won’t launch.

what happens when you try to launch librewolf in terminal?

Nothing pops up.

I saw this comment on the AUR

p: Basically it’s because Manjaro is still on gcc/gcc-libs 10, while Arch (and thus, the build environment) is on 11.

gcc 11 is already in stable-staging on Manjaro, though – so it should be in stable soon, I’d assume.

Until then, you could probably either temporarily switch your Manjaro to use the stable-staging repos (which should be “stable enough”) – or build LibreWolf from source to have a version that’s linked against your gcc-libs.

I guess I have to wait.

" /usr/lib/librewolf/librewolf: /usr/lib/ version `GLIBCXX_3.4.29’ not found (required by /usr/lib/librewolf/librewolf)
" From my terminal.

ok. I am on unstable and have gcc 11.1.0

I am having the same problem. I am also a nube. Thank you for sharing. I hope they fix it soon

1 Like

If AUR package doesn’t launch after package updates from the repos, try rebuilding the AUR package. Standard procedure.

I also started having this problem with Librewolf after doing a re-install. Which is weird because I was able to install it yesterday on another fresh install without a hitch…

EDIT: So I Librewolf updated during the time I made a fresh install, that would explain why it’s not working anymore.

1 Like

I gave that a shot. It will build the program fine but it won’t launch the program after it is done.

1 Like

Ah, okay. It really does need to be compiled with GCC 11 then. It’s available in our testing and unstable repos.


Rebuild a -bin package will not help, also building from source is failing for me but maybe is my CPU

Ah, I missed he was using the binary package. Well, he can always compile the regular package from source with GCC 10. I built Firefox 89 that way for the stable branch successfully.

1 Like

I switched to the testing branch and updated so it is working for me. I’ll switch back to stable now. Thank you for the help.

So the changes will come to the stable version any time soon, right? We just have to wait till it happen if we can afford to wait. What a bummer.

thanks for the information…im also had the problem like yours after update librewolf recently (currently im using librewolf-bin)…so for now i just install librewolf using flatpak…for me librewolf very smooth and light on resoureces compare to others.

Yeah, moving to the testing branch worked fine. But GCC 11 has been out for almost 3 months now. Is there anything holding it back from getting in the stable packages?

It’s now in the stable repo. :wink: