Libreoffice weirdness: writer and calc work, not impress or draw

I’ve been chasing rabbits trying to fix a new dead stop in libreoffice. Writer and calc are fine, but neither draw nor impress start. They throw a message about “” not loading properly.
After much searching I eliminated posted issues and solutions, including Akonidi installation.

I erased the ~/.cache, ran ldd, renamed the, reinstalled fresh and still versions repeatedly and the same errors persist. The same error happens with a new and different user.

All of LO worked fine using the same Manjaro flavor installed in a virtualbox vm, and on the same physical pc booted into a 2nd Manjaro partition.

I have some kind of path or xdg weirdness and I’m stuck.
Obviously not a show stopper since I can use the other partition or VM, but I’d love to fix this.

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Kernel Version: 5.10.4-3-MANJARO
OS Type: 64-bit
Processors: 16 × AMD Ryzen 7 3800X 8-Core Processor
Memory: 62.8 GiB of RAM
Graphics Processor: GeForce RTX 2060 SUPER/PCIe/SSE2

Just in case anyone else hits this problem, I solved it.

ldd /usr/lib/libreoffice/program/ |grep “not found” revealed 6 missing files (libicu*.so.67). newer .68 files were there but not being called. copying the .67 files into /usr/lib and /usr/lib32 fixed everything. All libreoffice programs work.

Sorry to dig this up. I am stuck with the same problem, however, in my case ldd gives no missing libs… It used to work just a few weeks ago, I think, the latest update killed it. Any ideas?

Never mind, I closed all the open LO windows, then started Impress again and it started without problems. I think, I should shut down my laptop more frequently…