Libreoffice hangs randomly

I have libreoffice-fresh 7.0.0-1 installed. Everything used to work just fine. From a few days ago (IDK what exactly caused this as I don’t use it that regularly), it started freezing and crashing randomly. It’d freeze whenever I select a large chunk of text, do anything else other than typing. It’d crash randomly. Has anyone else faced this issue? What to do?

  Kernel: 4.19.141-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: GDM, SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP Pavilion Laptop 14-bf1xx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: HP model: 83CE v: 59.38 serial: <filter> UEFI: Insyde v: F.31 
  date: 10/30/2017 
  ID-1: BAT1 charge: 21.6 Wh condition: 21.6/42.1 Wh (51%) volts: 13.0/11.6 
  model: Hewlett-Packard PABAS0241231 serial: <filter> status: Full 
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 31872 
  Speed: 800 MHz min/max: 400/1800 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Hewlett-Packard 
  driver: nvidia v: 430.64 bus ID: 01:00.0 chip ID: 10de:134d 
  Device-3: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo 
  bus ID: 1-5:4 chip ID: 04f2:b5d6 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 
  driver: modesetting,nvidia resolution: 1920x1080~60Hz s-dpi: 115 
  OpenGL: renderer: GeForce 940MX/PCIe/SSE2 v: 4.6.0 NVIDIA 430.64 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k4.19.141-2-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8168 v: 8.048.03-NAPI port: 3000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: eno1 state: down mac: <filter> 
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: 3000 
  bus ID: 03:00.0 chip ID: 8086:095a 
  IF: wlo1 state: up mac: <filter> 
  Local Storage: total: 1.03 TiB used: 509.55 GiB (48.5%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-2: /dev/sdb vendor: SanDisk model: SD8SN8U-128G-1006 size: 119.24 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-1: / size: 48.72 GiB used: 33.26 GiB (68.3%) fs: ext4 dev: /dev/sdb5 
  ID-2: /home size: 59.67 GiB used: 29.17 GiB (48.9%) fs: ext4 
  dev: /dev/sdb2 
  ID-1: swap-1 type: partition size: 8.10 GiB used: 1.26 GiB (15.6%) 
  priority: -2 dev: /dev/sdb3 
  System Temperatures: cpu: 48.0 C mobo: 29.8 C gpu: nvidia temp: 51 C 
  Fan Speeds (RPM): N/A 
  Processes: 302 Uptime: 2h 56m Memory: 7.71 GiB used: 3.25 GiB (42.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1848 pacman: 1847 
  flatpak: 1 Shell: fish v: 3.1.2 running in: server inxi: 3.1.05 

I am far from being an expert but can you confirm the way you installed the package? Is it from the repos or a flatpak?

Also you might want to try installing a newer kernel. If you want to stay on an LTS kernel, 5.4 is the current one. You can do it via the Manjaro Settings, thereafter don’t forget to reboot and let us know if that changes anything.

I installed it from the repo.
I’m intentionally using the 4.19 kernel as all the newer ones break gsync on my nvidia GPU.

Ok, so I guess you checked the availability for a newer graphics driver series for your graphics setup as well? I am not too proficient when it comes to that.

When you run libreoffice from terminal, does that throw any output when it crashes?

I’ve tried several things but couldn’t solve that issue.
The only output I get is this:

SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See for further details.

Try deleting (or rather move/rename) your (old) settings in $HOME/.config/libreoffice/.

Some problems have been reported with libreoffice-fresh, yes. The advice given from upstream is to replace it with libreoffice-still if the problems persist.

Okay, I’ll replace that and see if it persists.

EDIT: It’s still happening. I started in safe mode and reset everything. Still happening.

1 Like

Is this still with your libreoffice-fresh or is this the libreoffice-still already?

I did it for both.

1 Like

Does anyone know if libreoffice provides some kind of logging system that can be used to finding out the error?
EDIT: The issue doesn’t seem to happen if I write all the text from scratch. It only happens when I copy-paste something (even as unformatted text).

I don’t think it logs anything in and of itself ─ I could be wrong ─ but crashes would normally show up in the system log itself. Try looking for it with journalctl.

If you don’t use Base you could try disabling java in settings and see how it goes. Try a fresh config maybe?

I don’t use Base. I’ll try this one out let you know.

I would backup your current config and try a new one. Others have reported issues when updating to this version and using the old configuration file for LO 6… Or remove the Manjaro/Arch LO and give libreoffice-fresh-rpm from the AUR a try with a new configuration. That version builds directly from the rpm files from The Document Foundation. I have been using that one for a long time already with none of the issues that I had with the Manjaro/Arch spin.

I’ve already reset my profile. So that won’t help. I’ll maybe try switching to AUR, I don’t want to as it is a pretty big package, but I’ll do that if turning off java doesn’t help.

None of these worked, sadly. At this point, can anyone suggest some alternatives? I’m stuck using Google Docs for the time being. I can’t use OnlyOffice, as it doesn’t support ligatures and my mothertongue is full of ligatures.


This may not be related to your specific problem, but I had problems with version 6.4.6 hanging, or going very slow.

My solution was to go into Libreoffice Safe Mode and check Configure - Disable Hardware Acceleration.

  1. Click on LibreOffice Suite link
  2. Menu: Help - Restart In Safe Mode
  3. Check Configure
  4. Check Disable Hardware Accleration
  5. Restart in Normal Mode

This may not help you, but could be a solution to someone else’s issues.

I find that Libreoffice loads really fast now. Works in Manjaro and Windows 10.


Unfortunately, didn’t work for me.