Libreoffice-fresh (testing branch) broken?

The last usable version was 7.2.2-2. Unfortunately, on testing, it doesn’t launch anymore because of libraries incompatibility. To launch it, we must install any of the newer version, but ALL OF THEM ARE BROKEN:

libreoffice-fresh 7.2.2 3
libreoffice-fresh 7.2.2 4
libreoffice-fresh 7.2.3 1

To be specific: CALC IS BROKEN. I didn’t test other components, but Calc is the most important one and if it doesn’t work, all libreoffice is useless.

From what I know, this is a problem of the latest rebuilds on Arch. Those issues aren’t happening on Windows or other distributions.

What is happening? There are countless problems that make the program unusable, to name a few:

  • scrolling tables leaves various graphical artifacts, lines, etc.
  • changing size of the cells won’t update correctly graphics, namely, increased cell contains graphically other cells and their content inside, although the content is in other cells, which makes any table useless
  • sometimes clipboard doesn’t work, so forget copying any of the data to other programs…
  • various interface graphical glitches making the whole GUI a mess, so we can’t know what we are looking at or clicking at
  • sometimes saving documents doesn’t work or works, but we can’t tell, because UI is not updating
  • and many others

Since on testing, none of the latest libreoffice-fresh rebuilds that launch is usable, THERE IS NO USABLE REPO VERSION THAT LAUNCHES ON TESTING.

I was forced to install libreoffice from snap, which of course works without issues. Earlier, downgrading to the version that worked was a valid solution, now it’s not possible anymore and I had to use non-repo version.

This thread is about libreoffice-fresh only. I didn’t test libreoffice-still, because it’s lacking of features I need, so I consider it as vastly inferior, although probably usable, compared to fresh rebuilds on arch.

Not sure why this is all on bold, as i can’t say the same as you. All Libre Office Fresh Suite works for me

Version: / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

pacman -Qi libreoffice-fresh

Name            : libreoffice-fresh
Version         : 7.2.3-1
Description     : LibreOffice branch which contains new features and program enhancements
Architecture    : x86_64
URL             :
Licenses        : LGPL3
Groups          : None
Provides        : libreoffice  libreoffice-en-US
Depends On      : curl>=7.20.0  hunspell>=1.2.8  python>=3.7  libwpd>=0.9.2  libwps  neon>=0.28.6  pango  nspr
                  libjpeg  libxrandr  libgl  libxslt  redland  hyphen  lpsolve  gcc-libs  sh  graphite  icu
                  lcms2  poppler>=0.24.0  libvisio  libetonyek  libodfgen  libcdr  libmspub  harfbuzz-icu  nss
                  clucene  hicolor-icon-theme  desktop-file-utils  shared-mime-info  libpagemaker  libxinerama
                  libabw  libmwaw  libe-book  libcups  liblangtag  libexttextcat  liborcus  libtommath  libzmf
                  libatomic_ops  xmlsec  gpgme  libnumbertext  libfreehand  libstaroffice  libepubgen  libqxp
                  libepoxy  box2d  xdg-utils
Optional Deps   : java-runtime: adds java support [installed]
                  java-environment: required by extension-wiki-publisher and extension-nlpsolver [installed]
                  pstoedit: translates PostScript and PDF graphics into other vector formats [installed]
                  libmythes: for use in thesaurus [installed]
                  beanshell: interactive java -- good for prototyping/macros
                  libwpg: library for importing and converting WordPerfect Graphics format [installed]
                  sane: for scanner access [installed]
                  unixodbc: adds ODBC database support
                  gst-plugins-base-libs: for multimedia content, e.g. in Impress [installed]
                  libpaper: takes care of papersize [installed]
                  postgresql-libs: for postgresql-connector
                  mariadb-libs: for mysql-connector
                  coin-or-mp: required by the Calc solver
                  gtk3: for GTK3 integration [installed]
                  kio: for KF5 KDE desktop integration [installed]
Required By     : libreoffice-fresh-ro
Optional For    : None
Conflicts With  : libreoffice-still
Replaces        : None
Installed Size  : 419,03 MiB
Packager        : Andreas Radke <>
Build Date      : Jo 25 nov 2021 22:50:06 +0200
Install Date    : Sb 27 nov 2021 19:11:13 +0200
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

It was put in bold to stress the importance of the fact that testing rebuilds are broken and shouldn’t go to stable. Although it may not be possible to stop in current situation.

This is too vague statement. LO launches just fine for me either, so I could say it works. Just go to calc and start using it. It is possible that those issues happen on specific hardware. Currently, I’m on hybrid (intel-nvidia) setup, Plasma. Or maybe this is an issue with theming? This is something I didn’t check, although I could. Maybe I’ll test it when I find time.

I explained in this

meaning that this

does NOT happen on my end.

Either way, if you find a specific thing i should change to reproduce an issue, let me know. Tried disabling/enabling hardware acceleration, anti-aliasing, the use of OpenCL … in all the combinations, nothing crashed, but then maybe is a specific things that triggers it and i’m not doing that task?

Maybe we can make more people do some specific tests/tasks and see the outcome?

I know this is not a proper solution, but you should definitely give WPS Office a try. I use it mostly because I just cannot tolerate LO’s cold start time, and because it is featured enough to handle really complicated MSO files.

I already explained many times in other threads, aside MS Office which is number one, I use LO as the second best (although vastly inferior to MS Office), the rest don’t have basic options I use every day.

I tried to open the repo version using Breeze (Plasma default) instead of my current theme and the issue still exists, so it’s probably not tied to theming.

I created a simple, very small table to show you the difference on working LO version and how it looks on broken version:


Note that the LO shows other row data inside first row and incorrectly sizes the cells.

The same document opened in CORRECTLY WORKING VERSION (snap or older repo version):


Here everything looks in order, data in rows are showed correctly, cell sizes are looking good etc.

This is a tip of an iceberg of issues in the broken version.

Since this was happening earlier in other LO rebuilds from Arch but was perfectly fine in others (so there were 2 broken rebuilds, then one working, again broken one and again a working one, now we have the latest 3 broken rebuilds), I assume this has rather something to do with Arch builds, and some conditions must be met for the issues to appear. I don’t know what conditions those might be, but the effect is pretty strong. This isn’t a small bug. This breaks the app completely and since this is one of the more important apps, the issue is big, and I doubt I will be only one.

The fact that downgrading to a specific rebuild or changing the source fixes the problem, shows that the problem is in Arch rebuilds. My system is working fine and those problems are specific to LO only.

When launching repo LO via terminal, I get only one error:

qt.svg: link #path2410 is undefined!

Maybe this is the reason? Or maybe it’s just a normal, harmless, unrelated warning? No idea. But if this has something to do with my issue, it’s qt related, so it may only appear on QT DEs like Plasma.

Can someone with Plasma check how LO fresh runs for them on testing branch?

I was thinking what I can do to test it and recalled I can check my test user. And… the issue didn’t exist there! So this is a config problem! No wonder why you can’t confirm it.

I deleted the .config/libreoffice and the issue is fixed!

I’m ashamed that I didn’t figure it out earlier. On my defense, the issues were numerous and quite unspecific, showing up and disappearing depending on installed rebuild, which indicated strongly an issue on that side. However, it was something on my side that got corrupted.

Thanks for the discussion. It motivated to look for solution and I found it :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.