Libreoffice-Fresh 6.1.0-2 missing Menu Bar (File Edit View ...)

Starting up LibreOffice Impress, I’m missing the top menu bar (i.e. File, Edit, View …)

This may relate to LibreOffice Fresh Scrollbar Arrows in KDE where @kdemeoz says …

HOWEVER the major bummer is that using this EV has a fatal flaw… it removes the entire LO Menu Bar , making LO useless

… 6 days ago, saying “Finally SOLVED”.

Except that I didn’t have this problem before, and I’ve got it now!

Is there a setting I should change to get “File, Edit, View …” back?

$ lsb_release -rd
Description: Manjaro Linux
Release: 17.1.12

$ plasmashell --version
plasmashell 5.13.4

$ kf5-config --version
Qt: 5.11.1
KDE Frameworks: 5.49.0
kf5-config: 1.0

Pamac says …
libreoffice-fresh 6.1.0-2
Build Date: 2018-08-19
Install Date: 2018-08-26

FYI, I’m not having a problem with Kubuntu (dual-booted on the same X230T computer). I can see File Edit View …

LibreOffice
Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: kde4;
Locale: en-CA (en_CA.UTF-8); Calc: group

$ lsb_release -rd
Description: Ubuntu 18.04.1 LTS
Release: 18.04

$ plasmashell --version
plasmashell 5.12.6

$ kf5-config --version
Qt: 5.9.5
KDE Frameworks: 5.44.0
kf5-config: 1.0

Also, I have a backup computer (Thinkpad X200) where, File Edit View are showing up fine.

LibreOffice
Version: 6.1.0.3
Build ID: 6.1.0-1
CPU threads: 2; OS: Linux 4.14; UI render: default; VCL: gtk3_kde5;
Locale: en-CA (en_CA.UTF-8); Calc: group threaded

$ lsb_release -rd
Description: Manjaro Linux
Release: 17.1.12

$ plasmashell --version
plasmashell 5.13.4

$ kf5-config --version
Qt: 5.11.1
KDE Frameworks: 5.48.0
kf5-config: 1.0

Pamac says …
libreoffice-fresh 6.1.0-1
Build Date: 2018-08-12
Install Date: 2018-08-21

I have the same versions in Plasma and the menu is fine in Impress and Write.

Please see ^^

1 Like

Editing /etc/profile.d/libreoffice-fresh.sh shows the following contents …

# to force a certain look'n feel

#export SAL_USE_VCLPLUGIN=gen
#export SAL_USE_VCLPLUGIN=gtk3_kde5
#export SAL_USE_VCLPLUGIN=gtk
#export SAL_USE_VCLPLUGIN=gtk3

I first tried removing the # in front of the second line and restarted LibreOffice. The problem persists.

Then, I tried editing to …

# to force a certain look'n feel

#export SAL_USE_VCLPLUGIN=gen
#export SAL_USE_VCLPLUGIN=gtk3_kde5
export SAL_USE_VCLPLUGIN=gtk
#export SAL_USE_VCLPLUGIN=gtk3

… and rebooted Manjaro. Still no File Edit View …

right click a grab handle of any toolbar visible. then click customise toolbar. click on the Reset button and see if that restores the menus to view. It should do as they are a customisable option in that dialog window.

@anon71843593 Thanks for the directions. The customize and Reset doesn’t have any impact.

Is there any chance that you have accidentally enabled the [ghastly, IMO] Global Menu? If yes, removing it from your KDE Settings should resolve this hassle for you. If no, though i don’t expect this will help you [i suspect there’s a deeper problem with your LO config], you might try activating the KDE Application Menu tool:

…after which…

…and thence…

Assuming this also does not help you, maybe you’ll have to solve this the ugly way by nuking your current LO config & thus creating a virgin one?

1 Like

@kdemeoz the Global Menu isn’t something that I heard of, and I don’t think I had set it.

Your suggestion to activate the KDE Application Menu tool is a temporary workaround, so I can at least work with LibreOffice until a longer-term fix resolves.

It’s taken me a few steps to figure out how to navigate to the screenshots you’ve sent.

The Look and Feel that I have set is Breeze. (Under the Manjaro default, was it originally set to Breath?)

I hadn’t changed the Widget Style for Breeze.

The Window Decoration options that I’ve got are for Breeze, Oxygen and Plastrik.

Selecting on the Buttons pane, the Application Menu isn’t in the Titlebar.

I can drag-and-drop the Application Menu into the Titlebar.

This now gives me an Application Menu in the Titlebar of LibreOffice.

Thanks for that guidance. I had been rebooting into Kubuntu 18.04 for a day. With this workaround, I can at least stay in Manjaro KDE.

Since I have a Asus M5A88-N tower beside my Thinkpad X230T laptop, I’ve done the most recent updates there. The LibreOffice problem of not showing the Application Menu isn’t there, so there must be some deeply-hidden incompatibility on the Thinkpad.

After a week of working in Manjaro KDE with LibreOffice, I’ve found not having the application menu immediately visible to be a major productivity hit. For now, I’m changing over to the Kubuntu multi-boot option, so I can get work done.

If upgrades don’t resolve this soon, what are the options? I have a shared /home partition across four Linux distros, so the problem must be a configuration that is either on, or impacts, the Manjaro partition. If I do a reinstall of Manjaro KDE without formatting /home, would the problem still persist?

As i suggested earlier…

I hope you mean with different users/folders.
If you use the same user/folder on several distros, especially if mixed Arch-Debian, you have high probability of a conflict…
I suggest you create a new user in Manjaro and try again.

1 Like

Does this mean more than an uninstall and reinstall? Should I try installing libreoffice-still (which I presume means that libreoffice-fresh would be removed in conflict?

Or are you suggesting that I manually delete the .config files off /home? (Or both).

I said nothing about uninstalling anything… nor LO-Still, nor all your personal config files. All i suggested was directed specifically & only at your current config files for LO.

Find your LO user profile path. If you don’t already know it, look in LO like this:

Then, depending on your preference for command line or GUI tool [eg, Dolphin], either delete or [probably better] rename say the LO directory within, or the 4 directory, or the user directory [with LO closed of course]. Then relaunch LO, which will automagically create a new virgin suite of LO config directories & files. If LO is now good for you, then you had some error/corruption in your original config. If LO is still bad for you, the root cause lies elsewhere, hence more diagnostics would be needed.

I’m simply suggesting a logical measured step by step approach to try to uncover where the root cause lies.

EDIT:
When i wrote my initial iteration of this reply i had not noticed either your

nor the very salient advice by @AgentS Libreoffice-Fresh 6.1.0-2 missing Menu Bar (File Edit View ...), which i thoroughly endorse. Please can you action that, otherwise we might be chasing shadows. For the duration of the ongoing diagnostics, i also suggest that you return /etc/profile.d/libreoffice-fresh.sh to default, ie, with each option commented-out to deactivate. That might muck up your decorations, but will ensure the cause of the missing menu bar is not one of those options [as i’d discovered & reported in that earlier thread post you referenced in your OP].

While in Kubuntu, I followed the directions to …

… and moved the 4 directory out, leaving .config/libreoffice/ empty. I rebooted into Manjaro KDE, and I still don’t have an application menu.

Yes, I had reset those before.

In Manjaro, I created a new user “guest”. I logged out of my usual desktop, and logged in as guest. This worked! The application menu bar is back.

Unfortunately, this diagnosis now interferes with the way that I work, since the option to use the same /home across multiple distros allows me to work relatively uninterrupted when I hit a bug in one environment that isn’t in another.

So, I then logged out of guest, back into my main user ID. From the fix before …

… I dragged that feature out. Then, starting LibreOffice again, I ran into an error:

Error loading BASIC of document file:///home/daviding/.config/libreoffice/4/user/basic/Standard/script.xlb/:
General Error.
General input/output error.

I renamed the 4 directory in .config/libreoffice and restarted. The error message is now gone, and the application menu bar is still missing.

So, we’re one step ahead in diagnosis, but using the same /home across multiple distros is the way I work. I’m not having an application menu bar problem in anything other than LibreOffice. I’ve been using LibreOffice in Kubuntu 18.04 for a week. Is this something that is buried in LibreOffice-Fresh? Should I try LibreOffice-Still instead?

But not how things work.
Can you provide a link or a paper book title and page, where it is said this is a viable way of inter-operating between distros, even DEs?

I’m sorry but i have an antithetical opinion on this. I claim zero personal expertise, so will gladly stand corrected by more knowledgeable Manjaroos, but as i recollect, over the years i’ve read many webpages, posts & opinions on the question of unique /home per distro in a multiboot environment, vs single /home shared across all the distros. AFAIR a preponderance of opinion sided with NOT sharing a common /home… but instead if desired, sharing a common /Data partition. The rationale for this always made sense to me… different distros [even if all one DE, but only compounded when there’s other DEs too] will almost certainly NOT use identical versions of individual programs & all their dependencies, NOR all the DE’s “system” packages [eg KDE Frameworks, Applications…]. Yet having a common /home presupposes-away all those latent conflicts & incompatibilities [ie, one distro’s &/or program’s user config files might be incompatible with what another distro expects those files to be]. IMO the probable outcome of this mish-mash arrangement is distros &/or individual programs misbehaving in weird ways that resist “standard” troubleshooting diagnostics. In other words, your way that I work might well result in none of us here being able to help you.

In an earlier reply i asked you about Global Menu, & your reply was ambiguous. I’d just like one more opportunity to positively rule out any chance that you might have it activated, even without you meaning to [at least one time i installed Manjaro KDE, i was surprised to discover that the GM was active “out of the box”… i had to specifically disable/remove it]. If you launch, say, Kate, or Konsole, are their Menu Bars present within their windows [as opposed to being transplanted to the Plasma Panel]?

Go ahead & try LO-Still if you wish. I suspect the problem will continue, but seeing is believing. Just be aware that, afaik, installing Still will remove Fresh.

Yes, I had said …

You’ve now asked a clearer diagnostic question.

This helps. There is no menu bar in Kate. There is no menu bar in Konsole.

When I was looking into question before, I had seen " How to Activate the Global Menu in Kde Plasma 5.9" | Francesco Mondello | Feb. 5, 2017 at http://fasterland.net/activate-global-menu-kde-plasma-5-9.html . I went looking for “The Widget Style panel” that he had posted, that seems to be under “Widget Style and Behaviour” … “Fine Tuning”, and looks like …

On my installation, I don’t see the Menubar pane that Francesco shows. Mine looks like …

Wondering if it’s the Widget style I’m using, the tab on Applications is set to Breeze.

Further searching turns up a “Menubar style option missing from Widget style?” started around March 2018 at https://www.reddit.com/r/kde/comments/844rwn/menubar_style_option_missing_from_widget_style/ .

So, my question, now, is: where is the screen where I set the Menubar style?

I don’t either. Have you seen that in the new user’s Settings?
Distros create new configuration setups, on will.
Have you seen this setting in Manjaro?
If yes, then create a bug report on Manjaro Gitlab .
Your original problem is solved and now you start a complain of Manjaro not having a setting that another distro has.
Is this what you want to do?

Forum kindly sponsored by