LibreOffice crashes on startup

I’m having problems with my brand new Manjaro KDE. First of all, I’m not a big fan of ONLYOFFICE. It’s alright for small projects but as soon as you have medium to large data, it fails to perform. For example, it fails to create a scatter plot with over 4096 data points!

Anyways, I had to install LibreOffice for that specific reason. While it works perfectly fine on my laptop (same Manjaro KDE) but it fails to run on my desktop. No icon is added to the taskbar after I run the package and the only thing shown is the Calc’s intro splash window which will remains on the screen until I click on it (it won’t go away on its own). Once clicked, it will disappear and that would be the last that I see any sign of running Calc.

Here are some more info. I can find the process in the system monitor (named soffice.bin) but all I can do is to end it. Even when I run the calc from terminal, nothing happens.I mean it’s exact same experience and there’s no output printed in the terminal.

So I thought I should uninstall and reinstall the package. And I did but nothing changed. Also, it did not ask me for options what to install alongside of it (as it did the first time I installed it), so I thought it must have used the same settings as before and that’s why I’m facing the same issue. So if I can somehow nuke the current installation and reinstall it then, I might actually have a chance to make it work.

I appreciate it if someone could help me out find a way to run LibreOffice. Thanks.

Depends on what you have installed.

pacman -Qs libreoffice

Then remove the package(s), ex:

sudo pacman -Rns libreoffice-fresh

And lets remove its config in home (pacman is not supposed to remove things from home by design):

rm ~/.config/libreoffice

Remove package cache of libreoffice (optional? - ensures a fresh download):

paccache -rvk0 libreoffice-fresh

Then do your reinstall, ex:

sudo pacman -Syu libreoffice-fresh
1 Like

Thanks. But it did not work. I mean I still cannot run the LibreOffice. The same exact behaviour.

What if started from terminal?


Or maybe with some extra flags

libreoffice --nolockcheck --nologo --quickstart=no

Oh, I forgot about safe mode. :face_with_head_bandage:

libreoffice --safe-mode

(You can cancel a running action, like if hanging, by Ctrl+C)

Maybe there will be some clues. Please copy any errors here.

When I run the libreoffice like this:


Or this:

libreoffice --nolockcheck --nologo --quickstart=no

The LibreOffice icon is added to the taskbar and a window opens. But it crashes right away and the window does not render (it shows the background capture instead). And the only thing I can do is to close the program (Ctrl+C or end the process).

BUT running it in safe mode does work. It opens the program completely but of course, in safe mode. Then I thought, let’s do the “Reset to factory settings”. But selecting that option and checking the both boxes and then clicking the “Apply changes and restart” button, the new window will crash just the same.

If you ask me, LibreOffice files are corrupted and does not run unless in safe mode.

I’m thinking there is some issue like graphics.
Or possibly mounted shares? Do you use anything like that - like a shared ntfs ?

EDIT - Did you get any errors or logs? What do they look like?

We can also check launching it with SAL_DISABLE_OPENCL=1 and/or SAL_DISABLEGL=1 env vars. ex,

SAL_DISABLEEGL=1 libreoffice

Also please share system info:
[HowTo] Provide System Information


This worked for me:

SAL_DISABLE_OPENCL=1 libreoffice

Then I ran the libreoffice in safe mode and selected the “Configure” and checked the box “Disable hardware acceleration” and now, LibreOffice runs without any issue. I guess LibreOffice was conflicting with my GPU (Nvidia).

Huh. Well its workable now which is good.

I wonder if opencl-nvidia is installed and/or if it has anything to do with the recent change to mesa packages removing nonfree bits.

Of course its all dependent on your systen configuration and all.

Heres some extra links in case you feel like tinkering more…


I think is related to this, at least on my system does.

1 Like

I had installed LibreOffice Fresh and it was giving lots of problems. Then I removed it and moved to LibreOffice Still. No problems since

Hi everyone
I’m a beginner
I’m having the same issue since 24hr (last system update 2 days ago)
after running ‘SAL_DISABLEEGL=1 libreoffice’ and libreoffice in safe mode
libreoffice keeps crushing at startup:

SAL_DISABLE_OPENCL=1 libreoffice                                                                                                                                                        libreoffice --safe-mode                                                                                                                                                                   
kf.kio.filewidgets.kfilefiltercombo: Could not find filter "*|All files "
kf.coreaddons: Expected a KPluginFactory, got a KIOPluginForMetaData
Unspecified Application Error

tks everyone

I have had SO many problems and issues with LibreOffice. I used to think it was bc I use the nouveau driver. But that would not explain it crashing on my novel length documents.

As I was already using WINE for PS7, I decided to give the free Atlantis Lite word processor a try. I liked it so well, I paid the $35.00 for the full version. Best $ spent of software in decades. Give it a try.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.