Libreelec sees different files on USB

This is not a Manjaro related question. I hope that someone from here will be knowledgeable enough.

I have USB that I used in the past for live Ubuntu USB. Since years I use it as a media storage and all it remained from the past is the USB label which is still called ubuntu.

Today, I noticed something very weird. Namely, all systems see media files on it, except libreelec (media OS), which sees it still as a live disc from many, many years ago. Even if I go to terminal, that doesn’t changes. It’s as if I was looking at a very different device.

The problem may be the file system. Gparted shows it as one partition with file system iso9660:

If I haven’t checked, I would swear I changed it to fat32 years ago… Anyway, I can’t change the label of the USB without reformatting the file system, which I don’t want, because I have media files on it. When I plug it to Manjaro, I see correctly all media files and I can play them. Former media system OSMC also saw media files, the same does TV, TV SAT and so on. For years all was fine until today, where libreelec reads it as if it was 10 years ago…

Any clues how to fix it without wiping the USB completely?

You’ve been around long enough to know we don’t edit the topic title to mark posts solved.

You know what to do…



Nevermind. I decided to wipe out the media files anyway and format the USB to fat32.

And you are here long enough to know that there is no possibility to mark the first post as solved…

I thought there is no need to create new post just to make it solved.
By the way, I’m here long enough to know that in the past it was common that people were marking posts as solved in the topic, and it was fine, because it was very clear. I don’t understand what is the problem now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.