Libre Office Impress flickering transitions XFCE

Hello forum,

I have asked on the LibreOffice forum and looked for solutions online about Libre Office Impress transitions flickering between black and the slide, even with a basic fade. The responder on the LO forum suggested checking VSYNC, but I don’t know where that is. Other solutions relate to disabling OpenGL, but that is not an option in the LO preferences.

GPU details:
Graphics: Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 440.100 Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 1920x1080~60Hz OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100

This is the nvidia.conf file contents:

nvidia-xconfig:  version 440.31

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "InputClass"
    Identifier         "Keyboard Defaults"
    MatchIsKeyboard    "yes"
    Option         "XkbOptions" "terminate:ctrl_alt_bksp"

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AUS VZ249"
    HorizSync       30.0 - 83.0
    VertRefresh     48.0 - 75.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1050 Ti"
    Option         "NoLogo" "1"

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On}"
# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "1920x1080_60 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "1920x1080_60 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "COMPOSITE" "Enable"

There should be an OpenGL option if you use the:


command in terminal.

There may be an option for VSYNC as well.

Thanks for that. I deselected each item one at a time and restarted Libre Office. No change in display.