libappindicator-gtk3 makes broken dependency

Hi, I did some updates today and libappindicator-gtk3 (12.10.0-13 -> 12.10.0-14) broke dependency for two packages for me. I must remove indicator-application (12.10.0-2) and indicator-powersave (r98.8-1) because libappindicator3 was in conflict with libappindicator-gtk3 12.10.0-14.

Now I can't reinstall them because dependency not satisfied. I have this message:
could not satisfy dependencies: unable to satisfy dependency 'libappindicator3' required by indicator-application

I wanted to ask if possible to rebuild these packages.
Thank you so much.

Log from pamac:

[2020-03-16T18:00:24+0100] [ALPM] upgraded python-pip (19.3.1-1 -> 20.0.2-1)
[2020-03-16T18:00:24+0100] [ALPM] upgraded python-setuptools (1:45.3.0-1 -> 1:46.0.0-1)
[2020-03-16T18:00:24+0100] [ALPM] upgraded perl-alien-build (2.12-1 -> 2.14-1)
[2020-03-16T18:00:24+0100] [ALPM] upgraded matcha-gtk-theme (20200313-1 -> 20200315-1)
[2020-03-16T18:00:24+0100] [ALPM] upgraded linux56 (5.6rc5.d0309.g2c523b3-1 -> 5.6rc6.d0309.gfb33c65-1)
[2020-03-16T18:00:23+0100] [ALPM] upgraded linux55 (5.5.9-1 -> 5.5.9-2)
[2020-03-16T18:00:23+0100] [ALPM] upgraded linux54 (5.4.25-1 -> 5.4.25-2)
[2020-03-16T18:00:21+0100] [ALPM] upgraded libindicator-gtk2 (12.10.1-8 -> 12.10.1-9)
[2020-03-16T18:00:21+0100] [ALPM] upgraded libical (3.0.7-1 -> 3.0.8-1)
[2020-03-16T18:00:21+0100] [ALPM] upgraded libappindicator-gtk3 (12.10.0-13 -> 12.10.0-14)
[2020-03-16T18:00:21+0100] [ALPM] upgraded libindicator-gtk3 (12.10.1-8 -> 12.10.1-9)
[2020-03-16T18:00:21+0100] [ALPM] upgraded lib32-pcre (8.43-1 -> 8.44-1)
[2020-03-16T18:00:21+0100] [ALPM] upgraded kwindowsystem (5.67.0-1 -> 5.68.0-1)
[2020-03-16T18:00:21+0100] [ALPM] upgraded kitemmodels (5.67.0-1 -> 5.68.0-1)
[2020-03-16T18:00:21+0100] [ALPM] upgraded kauth (5.67.0-1 -> 5.68.0-1)
[2020-03-16T18:00:21+0100] [ALPM] upgraded kcoreaddons (5.67.0-1 -> 5.68.0-1)
[2020-03-16T18:00:21+0100] [ALPM] upgraded gst-plugins-bad (1.16.2-4 -> 1.16.2-5)
[2020-03-16T18:00:21+0100] [ALPM] upgraded imagemagick (7.0.10.0-1 -> 7.0.10.1-1)
[2020-03-16T18:00:21+0100] [ALPM] upgraded gst-plugins-bad-libs (1.16.2-4 -> 1.16.2-5)
[2020-03-16T18:00:21+0100] [ALPM] upgraded util-linux (2.35.1-1 -> 2.35.1-1.1)
[2020-03-16T18:00:21+0100] [ALPM] upgraded enchant (2.2.7-1 -> 2.2.8-1)
[2020-03-16T18:00:21+0100] [ALPM] upgraded libutil-linux (2.35.1-1 -> 2.35.1-1.1)
[2020-03-16T18:00:21+0100] [ALPM] upgraded pcre (8.43-2 -> 8.44-1)
[2020-03-16T18:00:21+0100] [ALPM] upgraded archlinux-appstream-data (20200103-1 -> 20200315-1)
[2020-03-16T17:55:20+0100] [ALPM] removed indicator-application (12.10.0-2)
[2020-03-16T17:53:43+0100] [ALPM] removed indicator-powersave (r98.8-1)

:+1: Welcome to Manjaro! :+1:

Where did you get these packages from?

  1. If the AUR, you should contact the package maintainer.
  2. If not, please state their origins.

:innocent:

1 Like

Thank you @Fabby for reply!

Here is the error message it gave when I updated:

:: Starting full system upgrade...
resolving dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libappindicator-gtk3 (12.10.0-14) breaks dependency 'libappindicator3' required by indicator-application
:: installing libappindicator-gtk3 (12.10.0-14) breaks dependency 'libappindicator3' required by indicator-powersave

The packages come from repos in Manjaro:

$ pamac info indicator-powersave


Name                 : indicator-powersave
Version              : r98.8-1
Description          : User discretion power managment utility
URL                  : https://launchpad.net/indicator-cpufreq
Licenses             : GPL
Repository           : community
Installed Size       : 649,2 kB
Depends On           : libappindicator3 python2 python2-dbus python2-gobject
                       pygtk polkit-gnome indicator-application
Optional Dependencies: x86_energy_perf_policy [Installed]
                       hdparm [Installed]
                       nvidia-utils
                       iw [Installed]
                       ethtool [Installed]
Provides             : indicator-cpufreq indicator-cpufreq-bzr
Conflicts With       : indicator-cpufreq indicator-cpufreq-bzr
Packager             : Philip Mueller <philm@manjaro.org>
Build Date           : 08/05/2017
Install Date         : 02/20/2020
Install Reason       : Explicitly installed

$ pamac info indicator-application
Name                 : indicator-application
Version              : 12.10.0-2
Description          : Indicator to take menus from applications and place them
                       in the panel
URL                  : https://launchpad.net/indicator-application
Licenses             : GPL
Repository           : community
Installed Size       : 115,7 kB
Depends On           : json-glib dbus-glib libappindicator3
Required By          : indicator-powersave
Packager             : Philip Mueller <philm@manjaro.org>
Build Date           : 08/05/2017
Install Date         : 10/30/2019
Install Reason       : Installed as a dependency for another package

They are depending on libappindicator3 but this was replaced by libappindicator-gtk3 (12.10.0-14).

Maybe they should be rebuild with libappindicator-gtk3.

Luckily for you @philm is the package maintainer, so he needs to be aware and will solve this for you...

:innocent:

Thanks @Fabby, good to know @philm can fix this.

Hi all, I am still with this issue. Is there any solution I can have for the packages? Thank you!

Sounds like an old overlay package. Haven't been rebuilt in 3 years.

There is chance that Manjaro Team build it again?

Forum kindly sponsored by