Lenovo x250 Laptop not waking up from suspend

Hi!

I’ve been off Arch for a few years and now back on Manjaro.

My Lenovo X250 doesn’t wake up after suspend if the laptop has been in suspend-mode for a few hours. The power-led pulsates normal in suspend, it just doesn’t wake up any more. Neither with lifting lid nor with pressing power-buttons.
Putting the machine to sleep with “systemctl suspend” works fine at first but after being in that state for more than, say 2h, the system refuses to wake-up.
inxi: Dump your inxi -Fxzc0 here and bookmark it

I responded here but the thread is already marked as solved (& might be different issue):

Get these ACPI-errors on boot (but apparently nothing to do with the issue):

Feb 04 08:19:05 patera kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query honored via cmdline
Feb 04 08:19:05 patera kernel: ACPI Error: Needed type [Reference], found [Integer] 00000000b121b6b1 (20181003/exresop-69)
Feb 04 08:19:05 patera kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Store] (20181003/dswexec-427)
Feb 04 08:19:05 patera kernel: ACPI Error: Method parse/execution failed \_PR.CPU0._PDC, AE_AML_OPERAND_TYPE (20181003/psparse-516)

No configured hibernate, no swap partition. The systemd-configs seem to be different on Manjaro than on Arch so this doesn’t help either:
https://wiki.archlinux.org/index.php/Power_management#Sleep_hooks
https://wiki.archlinux.org/index.php/Suspend

journalctl -p err -S 2019-02-03:

Feb 03 21:50:08 patera kernel: ACPI Error: Needed type [Reference], found [Integer] 000000004224d733 (20181003/exresop-69)
Feb 03 21:50:08 patera kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Store] (20181003/dswexec-427)
Feb 03 21:50:08 patera kernel: ACPI Error: Method parse/execution failed \_PR.CPU0._PDC, AE_AML_OPERAND_TYPE (20181003/psparse-516)
Feb 03 21:50:28 patera gnome-session-binary[861]: Unrecoverable failure in required component org.gnome.Shell.desktop
Feb 04 00:54:44 patera kernel: iwlwifi 0000:03:00.0: No beacon heard and the time event is over already...
-- Reboot --
Feb 04 08:19:05 patera kernel: ACPI Error: Needed type [Reference], found [Integer] 00000000b121b6b1 (20181003/exresop-69)
Feb 04 08:19:05 patera kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Store] (20181003/dswexec-427)
Feb 04 08:19:05 patera kernel: ACPI Error: Method parse/execution failed \_PR.CPU0._PDC, AE_AML_OPERAND_TYPE (20181003/psparse-516)

Only weird thing is that log-entry from iwlwifi at 00:54 cause the system was already in suspend since 21:50.
TPM-module is loaded like suggested here:
https://wiki.gentoo.org/wiki/Lenovo_Thinkpad_X250#Suspend.2Fresume
Added Grub-parameter intel_mmu=off like suggested here:
https://bugs.archlinux.org/task/55705

It’s a fresh install, I’ve tested kernels 4.20, 4.19, 4.14; Same thing.
Laptop also doesn’t hibernate when I close the lid.
Suspend works fine in Ubuntu, so there’s gotta be a way.

Anyone that can point me in the right direction?

Cheers!

You haven’t configured it to “hybrid suspend” or something where it tries to hibernate after a length of time?

My X230 will stay asleep for hours and resume without issue, so this should be solvable.

I thought about that too since it might switch to hibernate and then freezes cause there’s no swap-partition.

But I didn’t make any changes to suspend. Also I would assume if I call “systemctl suspend” the system does not automatically switch to hibernate after a few hours since I didn’t call the hybrid function.

The config-files seem to be a bit different than in Arch.
The config for hibernate oddly seems to be in /usr/lib/systemd/system/systemd-suspend.service where it simply calls /usr/lib/systemd/systemd-sleep.

Update:
Deactivated hibernate & hybrid-sleep with

sudo systemctl mask hybrid-sleep.target
sudo systemctl mask hibernate.target

Update-2:
OK, I think I’m onto something: Intel Rapid Start Technology (iRST) is activated in BIOS and goes into deep sleep after 3h. Apparently works on Windows 10 (never had any issues with suspend there) and Ubuntu (working fine as well). Deactivated iRST & testing.

Update-3:
Deactivating iRST (not to be confused with Intel Raid Storage Technology) in BIOS did the trick. Sometimes it’s easier than you might think :slight_smile:
However, it’d be nice to have iRST in Linux as well, if it uses the same hibernate-partition. Losing 16GB of precious SSD-space is not very sexy. I found some related Tutorials & How-To’s and I’ll report back when/if I got it running.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark