Lenovo V130 discrete GPU not working (Radeon 530)

I recently purchased a budget Laptop.
It's a Lenovo V130 [Modded]. I added SSD and extra ram for today's standards.
It comes with a discrete graphics card, AMD Radeon 530.
The thing is Manjaro detects the card as Topez XT. and the card doesn't work.
Can you guys please help me to find the right driver so the system recognizes the card and use it?
Thanks in Advance.

Make sure you have the latest BIOS, then use one of the latest ISO releases.

The only issues i could find
https://forums.lenovo.com/t5/Ubuntu/Touchpad-problem-Lenovo-V130-amp-Ubuntu-18-04/td-p/4250545
https://forums.lenovo.com/t5/Other-Linux-Discussions/V130-15IKB-internal-speakers-are-not-working/m-p/4432848
yet none is relevant in any way for a proper assistance ...

Try this:
https://bbs.archlinux.org/viewtopic.php?id=234774

I have the latest BIOS update

I went through it, I didn't understand it much tho, I am a student and I learn Linux as a hobby, I'll be glad if you could summarize the technical aspects in that thread.

Your reply to post is greatly appreciated. I love manjaro community!
Thank you.

It is explicitly written in the second post of the linked thread. There is nothing to summarise.

1 Like

What I dont get is the problem is still not solved... The OS is still using the integrated graphics and not the better discrete one. I want to change the source output from the integrated intel graphics to amd ones.

Thank you for replying & patience.
I was out of town, so late reply. Sorry :slight_smile:

Maybe your GPU and inter graphics are connected. Search your gpu model number and go to their official website and look for the latest driver.

I did that before posting here, the official page only has the windows driver and no linux driver.
Thank you for your reply, really appreciate it.

Can anyone just link me a appropriate driver for thr Radeon 530 GPU?

Please provide from terminal:
DRI_PRIME=1 glxinfo | grep OpenGL

I'm sure you have the proper drivers installed already. To run any application trough the AMD GPU, you have to use:
DRI_PRIME=1 application

DRI_PRIME=1 glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: AMD ICELAND (DRM 3.36.0, 5.5.11-1-MANJARO, LLVM 9.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.3.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5 (Compatibility Profile) Mesa 19.3.5
OpenGL shading language version string: 4.50
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 19.3.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

This is what it gives me

That shows that it works ... :slight_smile:


But the settings manager says I have Topez XT and none of which are my GPU

I wouldn't bother with cosmetics :slight_smile:

Thanks! Thank you for your patience! Really a great community Manjaro has. Love it. :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by