Lenovo T440s problems

i have never learned anything about computers or anything of that sort. about a year ago my t440s thinkpad started acting weird and suddenly couldn’t find ‘/boot/vmlinuz-5.15-x86_64’. i’ve tried almost everything, typing the code back in, whatever sudo commands i found on a thread multiple times, and watching videos…nothing worked? i called customer support for not much help at all…someone please help!!

Welcome to the forum!

Usually this is the result of an incomplete/interrupted update procedure. During the update process, the old kernel images are removed, and only at the end of the update process are the new kernel images written to /boot and is the boot loader updated.

The other possibility, if you have not interrupted the update procedure, is that the internal drive has begun failing. Whether it’s an HDD or an SSD, this sort of thing does happen. But given the error message, I suspect we’re dealing with an interrupted update.

My advice would be to download the latest Manjaro .iso here, put it on a USB stick in the proper manner — Ventoy is a great way of creating bootable USB sticks, and it’s available for Windows too, if that is what you’re currently using — and to then boot up from it and repair your system.

The procedure is not difficult. Boot up from the USB stick in live mode, and once the desktop has loaded, open up a terminal window. In this window, issue the following commands… :arrow_down:

sudo su -
manjaro-chroot -a
[ -f /var/lib/pacman/db.lck ] && rm -f /var/lib/pacman/db.lck
pacman-mirrors -f
pacman -Syyu

Be sure to let all of the above commands take their time and finish. When prompted for the replacement of certain packages, answer Y.

After that, reboot your machine and remove the USB stick.

hey, just recently got my hands on a usb and tried putting the files from XFCE DESKTOP, i wasn’t too sure on what you were talking about if i’m being honest…i’m a really big dummy. but i tried putting the files onto the drive, including the ventoy thing…i was confused on what exactly to put on the usb so could you tell me the exact thing i need to download onto the usb?

i wasn’t sure what ventoy file to put on the usb either, i put both the .iso and the linux.tar.gz…which i think was wrong. thank you!!

No, just the .iso is enough. Ventoy will read it and present you with a boot menu for each .iso you have on there. So you don’t have to mess with things like dd or imagewriter or anything like that, because it can read and boot .iso files directly.

so i just need the iso? no need to download whatever was in the first link?

The first link was where you can download a Manjaro .iso. The second link was to the Ventoy home page, because it exists for Microsoft Windows as well, in case you are working from a Windows machine.

You install Ventoy on your computer, then you insert a USB stick and you launch Ventoy. If necessary, Ventoy will partition and format the USB stick. Then all you need to do next is copy the .iso file(s) of your choice to Ventoy by way of drag & drop, safely unmount the stick, and then you boot up from it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.